Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Results 1 to 2 of 2

Thread: Patch required?

  1. #1

    Default Patch required?

    Hey Guys, I'm new to the battlefield 2 scene. I am trying to connect to the saix servers but get an error message "Connection to the server failed. Please check network connection and try again". Now, I c an connect to any of the servers on the list but to none of the saix servers. Someone told me there is a password??

    Do I need the patch (v1.41 / 1.40) installed to connect to these servers?

    Any advice greatly appreciated!!!

  2. #2

    Default

    Hi MartJans,

    Yes you have to patch your newly installed BF2 to the same version SAIX is running else you cannot connect.

    You can find the 1.41 path here ftp://ftp.games.saix.net/battlefield_2/patches/

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •