Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Results 1 to 7 of 7

Thread: Kenwood laser assembly replacement? Kei was right ...

  1. #1

    Default Kenwood laser assembly replacement? Kei was right ...

    Some of you may remember me complaining a while back about my Kenwood KDC-9023R that ejected CDs and refused to play them? Well, I took it in and was quoted over R1000.00 for a new laser assembly unit - after only 400hrs playing time. I thought it was a ridiculous price, and Kei warned me with the quote, "As for the repair game, with all due respect there are quite a few sharks out there that will say X part failed and that's why we charge you R1000, meantime all he did was fix a dry solder joint". Seems this was so ...

    I decided to collect the unit (I refused to pay to fix it) without them having fixed it (although they apparantly opened the unit) and decided that evening to connect it to have FM sound again. Outta interest I put in a CD and guess what? It plays all my CDs now!

    I'm guessing it was an alignment problem that was corrected when moving the unit (unintentionally) or maybe it was a very minor problem that was fixed - and the guy thought I'd pay the money to fix it! Either way I payed nothing and the unit is working.

    From now on I will be extra careful when it comes to repairs of any type.

  2. #2

  3. #3
    Super Grandmaster
    Join Date
    Aug 2003
    Location
    Afreek du Zuid - KZN - Ramsgate.
    Posts
    10,531

    Default

    Oh my word. Good for you Dolby.

  4. #4

    Default

    Seems to be a common problem with kenwood headunits, had a problem with my old headunit, chucked it away. My current MP3 unit is doing the same thing, constant TOC errors or it just spits the disc back at me.
    RSA Broadband = 1.44 Floppy & Stamp

  5. #5

    Default

    Sorry too lazy to check model numbers, but definately Kenwood
    Last edited by alchamy; 06-06-2005 at 07:41 PM.
    RSA Broadband = 1.44 Floppy & Stamp

  6. #6

    Default

    lol...no kenwoods here

    just sony, LG and JVC

  7. #7
    Super Grandmaster
    Join Date
    Aug 2003
    Location
    Afreek du Zuid - KZN - Ramsgate.
    Posts
    10,531

    Default

    Um - my JVC gave me crap a few times - was about 4 months old.
    Then it got worse, and would not play anything.
    Then I discovered CD lense cleaners. Wow, suddenly it worked.
    Stupid me.
    Had the same problem with me JVC DVD player, same solution.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •