Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22

Thread: Speedtest.net launches new user interface

  1. #1

    Default Speedtest.net launches new user interface

    Speedtest.net launches new user interface

    Broadband speed test company Ookla has launched their new Speedtest.net interface

  2. #2

  3. #3
    Super Grandmaster
    Join Date
    Aug 2008
    Location
    cape town
    Posts
    6,314

    Default

    your is faster then 99% of ZA,!!
    Clevo P150HM ,I7 2720QM , 1080P 95% gamut display , 8GB 1333mhz ,Blueray rom ,750gb 7200RPM ,GTX 485M 675/1600
    Dell 29 inch ultrasharp.

  4. #4

    Default

    It doesn't even load for me. Says "Configuration Load Fail"

  5. #5
    Super Grandmaster
    Join Date
    May 2009
    Location
    Pretoria, South Africa
    Posts
    5,811

    Default

    Quote Originally Posted by hereticangel View Post
    your is faster then 99% of ZA,!!
    Me is thinking it's a joke.

  6. #6

    Default

    Geez! Check my speed!

    http://www.speedtest.net/result/1188276186.png



    You must be on a fibre link
    There are no stupid questions, just stupid people.

  7. #7

  8. #8

    Default

    Quote Originally Posted by malier View Post
    Geez! Check my speed!

    http://www.speedtest.net/result/1188276186.png





    You must be on a fibre link
    I think it just shows the inaccuracy...

  9. #9

    Default

    Quote Originally Posted by kobuse View Post
    Stellenbosch University's isn't bad either ;-)

    http://www.speedtest.net/result/1188303995.png
    Thats the way to go!

  10. #10

    Default

    Those results indicate exactly why the generic 'Begin Test' button (which selects your closest server) is a bad idea.
    “He who conquers others is strong; He who conquers himself is mighty.” - Lao Tzu

  11. #11
    Senior Member pmbellis's Avatar
    Join Date
    Jun 2006
    Location
    Upper Bucklebury, Berkshire, United Kingdom
    Posts
    293
    Blog Entries
    1

    Default

    Times out on showing the result ...
    United Kingdom
    16Mbps

  12. #12
    Grandmaster
    Join Date
    Apr 2008
    Location
    Pretoria
    Posts
    1,152
    Blog Entries
    1

    Default

    Fails on my side as well. Maybe SA's broadband has just fallen behind so much that we are just too slow for the world to bother anymore.

  13. #13

    Default

    Quote Originally Posted by francoislr View Post
    Fails on my side as well. Maybe SA's broadband has just fallen behind so much that we are just too slow for the world to bother anymore.
    LOL

    Mine is fine

  14. #14

    Default

    Looks a little more like the Speedtest mobile app now and continuity is a good thing. The only thing I don't like is the dial running all the way up to 100meg... That's just rubbing 4meg in...

  15. #15
    Super Grandmaster RichardG's Avatar
    Join Date
    Apr 2005
    Location
    Johannesburg/Jozzi South Africa
    Posts
    6,741

    Default

    Image taken for ever to load - I prefer the old one, things loaded faster
    Loving technology&gadgets own a Samsung Galaxy S4, Ativ S , Apple iPad4 Cellular 64 GB, i7 ivy bridge - Porting Successful

Page 1 of 2 1 2 LastLast

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •