Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Results 1 to 5 of 5

Thread: Problems with incoming calls on some devices

  1. #1

    Question Problems with incoming calls on some devices

    I wonder if someone out there is smart enough to help me with the problem I've got:

    We use a routed Mikrotik network that has 12 hops from point A to B using several ADSL routers and one dedicated VOIP router. At point B I have several Asterisk based PBXs and some standalone IP phones. I can setup all of these devices to make perfect outbound calls. I can get all of the PBXs to receive incoming calls using the NAT=yes setting in my Asterisk trunk settings.

    My problem lies in my stand alone devices. I use Snom, Grandstream and Siemens phones. The Grandstream phones are fine with incoming calls. Some of the Snom phones are fine. None of the Siemens are fine - except when I enabled SIP ALG on my main VOIP router. Then ALL of my stand alone SIP devices can receive incoming calls. However then some of my PBX's don't register - they report "Request sent" when I do a sip show registry. When I check the SIP trace on my standalone device (usually Snom 300) it shows that it does receive the call but that it doesn't accept the invite. Probably due to the wrong port or IP address. The phones that can receive incoming calls do so on the same port the registration was sent out on. The phones are all registered at our VOIP service provider so thats also not it

    What I have tried:

    1) Turning Upnp on at the source ADSL voip router
    2) Turning Upnp on at the customer router
    3) Turning Upnp off everywhere
    4) Turning SIP Alg off and on
    5) Turning SIP helper off and on
    6) Change the SIP port and RTP port on the standalone devices that can't receive incoming calls to something other than 5060.
    7) Turned "Support broken registrar" on on the Snom 300

    The problem is that because we only have one VOIP router I can't do port forwarding and can't assign static IP's

    Any suggestions? This is a really big headache and keeping me back from more implementations. If anyone can help I'll gladly provide assistance to you for any of your problems.

  2. #2

    Default

    How are you routing traffic over the dedicated VoIP router? static routes for the SIP server your provider gave you?

  3. #3

    Default

    Hi

    Can't give much technical feedback on this.
    I know someone staying on a farm in the Freestate. They have a wireless internet link via Mikrotik equipment. They initially had Siemens 580 IP phones, but they would lose the call every now and then. They switched to Yealink phones (and another provider) and the problem was solved.

    One more sample, wireless internet link but using Ubiquity equipment. Here the Siemens phones work fine.

    There are too many variables so can't actually draw any conclusions.

  4. #4

    Default

    Quote Originally Posted by nkawit View Post
    How are you routing traffic over the dedicated VoIP router? static routes for the SIP server your provider gave you?
    The dedicated VOIP router is an ADSL router that has an ECN PPPoE dialup account on. Our Mikrotik's are setup to route all port 5060 requests to that router as well as any rtp traffic that is sent back to the source IP. They are static routes.

    Any suggestions?

  5. #5

    Default

    Quote Originally Posted by T-Man View Post
    Hi

    Can't give much technical feedback on this.
    I know someone staying on a farm in the Freestate. They have a wireless internet link via Mikrotik equipment. They initially had Siemens 580 IP phones, but they would lose the call every now and then. They switched to Yealink phones (and another provider) and the problem was solved.

    One more sample, wireless internet link but using Ubiquity equipment. Here the Siemens phones work fine.

    There are too many variables so can't actually draw any conclusions.
    I have had the same results. I can't get Siemens A580 to receive incoming calls as a standalone device. Snom 300's the same. I can get Snom M9 to receive incoming calls by using the "Tahi Project" option in advanced settings. Grandstream phones also work. Its quite frustrating

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •