Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Results 1 to 11 of 11

Thread: Afrihost - Weird ping times with google

  1. #1

    Default Afrihost - Weird ping times with google

    So I'm on Afrihost's 4Mbps package, and I've notice that google keeps timing out constantly.
    Be it googlefonts, google search, anything basically google.

    So I thought I'd ping their URL to see what's up.
    This is when I noticed something weird.
    google.co.za pings back at around 350ms
    google.com ping back at around 18ms

    Isn't that a bit weird? I thought so, so I did a tracert and it showed something quite strange.

    Tracing route to www.google.co.za [74.125.233.31]
    over a maximum of 30 hops:

    1 7 ms 1 ms 1 ms login.router [10.0.0.2]
    2 10 ms 10 ms 10 ms 196-210-215-1.dynamic.isadsl.co.za [196.210.215.
    1]
    3 17 ms 16 ms 16 ms 196.38.73.113
    4 17 ms 17 ms 17 ms cdsl2-rba-vl150.ip.isnet.net [196.38.73.9]
    5 21 ms 19 ms 18 ms core1-pkl-tg0-7-0-0.ip.isnet.net [168.209.1.162]

    6 198 ms 198 ms 200 ms 168.209.201.89
    7 224 ms 223 ms 229 ms 195.66.224.125
    8 227 ms 205 ms 217 ms 209.85.240.63
    9 237 ms 237 ms 244 ms 209.85.252.45
    10 372 ms 373 ms 423 ms 209.85.248.227
    11 371 ms 372 ms 370 ms 64.233.174.105
    12 349 ms 349 ms 348 ms cpt01s01-in-f31.1e100.net [74.125.233.31]

    Trace complete.

    Compared to google.com

    Tracing route to www.google.com [196.23.168.159]
    over a maximum of 30 hops:

    1 3 ms 1 ms 1 ms login.router [10.0.0.2]
    2 11 ms 9 ms 10 ms 196-210-215-1.dynamic.isadsl.co.za [196.210.215.
    1]
    3 17 ms 16 ms 17 ms cdsl1-rba-vl2153.ip.isnet.net [196.38.73.169]
    4 17 ms 18 ms 16 ms cdsl1-rba-vl150.ip.isnet.net [196.38.73.17]
    5 18 ms 17 ms 17 ms core1a-pkl-te-1-2.ip.isnet.net [168.209.1.139]
    6 17 ms 17 ms 17 ms csw5-pkl-tg2-7.ip.isnet.net [168.209.1.188]
    7 17 ms 17 ms 20 ms za196-23-168-159.cache.googlevideo.com [196.23.1
    68.159]

    Trace complete.

    Weird right?

  2. #2

    Default

    just force your dns for www.google.co.za and www.youtube.com to point to 196.23.168.159 and done , all your problems sorted

  3. #3

    Default

    That won't solve the underlying issue, as sometimes pages that are supposed to load other google services, like embeded google maps or google web fonts cause the pages to not load.

  4. #4

    Default

    I went and changed it in the hosts file. looks a lot better already though it won't be a permanent fix. cause I can't do the same on my iPad or iPhone

  5. #5

    Default

    Quote Originally Posted by timmie23 View Post
    I went and changed it in the hosts file. looks a lot better already though it won't be a permanent fix. cause I can't do the same on my iPad or iPhone
    Get your self a smart router that can do your dns for you, an example is a mikrotik

    Here is my mikrotik config and has all the underlying stuff

    /ip dns static
    add address=196.23.168.147 disabled=no name=www.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.l.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.google.co.za ttl=1d
    add address=196.23.168.147 disabled=no name=google.com ttl=1d
    add address=196.23.168.147 disabled=no name=google.co.za ttl=1d
    add address=196.23.168.147 disabled=no name=gmail.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.gmail.com ttl=1d
    add address=196.23.168.147 disabled=no name=mail.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=gmail-imap.l.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=googlemail.l.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=chatenabled.mail.google.com ttl=\
    1d
    add address=196.23.168.147 disabled=no name=gmail-smtp-msa.l.google.com ttl=\
    1d
    add address=196.23.168.147 disabled=no name=code.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.gmodules.com ttl=1d
    add address=196.23.168.147 disabled=no name=gg.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=kh.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mw1.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mw2.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mt0.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mt1.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mt2.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=mt3.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=khm.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=cbk0.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=cbk1.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=cbk2.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=cbk3.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=csi.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=maps.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=maps.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=earth.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=maps.google.co.za ttl=1d
    add address=196.23.168.147 disabled=no name=news.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=docs.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=play.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=plus.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=video.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=music.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=sites.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=support.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=books.google.co.za ttl=1d
    add address=196.23.168.147 disabled=no name=calendar.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=accounts.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=sketchup.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=translate.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=blitz.appspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=appengine.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.google-analytics.com ttl=1d
    add address=196.23.168.147 disabled=no name=ssl.google-analytics.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.blogblog.com ttl=1d
    add address=196.23.168.147 disabled=no name=bp0.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=bp1.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=bp2.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=bp3.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=img1.blogblog.com ttl=1d
    add address=196.23.168.147 disabled=no name=img2.blogblog.com ttl=1d
    add address=196.23.168.147 disabled=no name=www1.blogblog.com ttl=1d
    add address=196.23.168.147 disabled=no name=www2.blogblog.com ttl=1d
    add address=196.23.168.147 disabled=no name=0.bp.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=1.bp.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=2.bp.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=3.bp.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=4.bp.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=image.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=buttons.blogger.com ttl=1d
    add address=196.23.168.147 disabled=no name=upload.blogspot.com ttl=1d
    add address=196.23.168.147 disabled=no name=googleappengine.blogspot.com ttl=\
    1d
    add address=196.23.168.147 disabled=no name=id.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=dl.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=t0.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=t1.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=t2.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=t3.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.gstatic.com ttl=1d
    add address=196.23.168.147 disabled=no name=clients0.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=clients1.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=clients2.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=clients3.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=0.tqn.com ttl=1d
    add address=196.23.168.147 disabled=no name=s.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=i0.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=i1.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=i2.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=i3.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=i4.ytimg.com ttl=1d
    add address=196.23.168.147 disabled=no name=csi.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.youtube.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.youtube.co.za ttl=1d
    add address=196.23.168.147 disabled=no name=upload.youtube.com ttl=1d
    add address=196.23.168.147 disabled=no name=ad-emea.doubleclick.net ttl=1d
    add address=196.23.168.147 disabled=no name=youtube-ui.l.google.com ttl=1d
    add address=196.23.168.147 disabled=no name=www.youtube-nocookie.com ttl=1d
    add address=196.23.168.147 disabled=no name=pagead0.googlesyndication.com \
    ttl=1d
    add address=196.23.168.147 disabled=no name=pagead1.googlesyndication.com \
    ttl=1d
    add address=196.23.168.147 disabled=no name=pagead2.googlesyndication.com \
    ttl=1d
    add address=196.23.168.147 disabled=no name=pagead3.googlesyndication.com \
    ttl=1d
    add address=196.23.168.147 disabled=no name=webcache.googleusercontent.com \
    ttl=1d
    add address=196.23.168.147 disabled=no name=translate.google.co.za ttl=1d
    add address=165.165.46.16 disabled=no name=www.bing.com ttl=1d
    add address=165.165.46.16 disabled=no name=bing.com ttl=1d

  6. #6
    Afrihost Representative AfriMan's Avatar
    Join Date
    May 2012
    Location
    Rivonia, Johannesburg
    Posts
    10,033

    Default

    Hi Guys

    It's pretty strange indeed. It looks like google.co.za routes to www-cctld.l.google.com at 74.125.233.24, which is international. Google.com routes to www.l.google.com. at 196.23.168.148, which is local.

    Does anyone know if this is occurring with other ISP's?
    If AfriMan says it, it is so!

  7. #7
    Grandmaster
    Join Date
    Jan 2007
    Location
    Port Elizabeth
    Posts
    3,739

    Default

    Quote Originally Posted by AfriMan View Post
    Does anyone know if this is occurring with other ISP's?
    Yes, experienced it with TI over the weekend.

  8. #8

    Default

    Quote Originally Posted by AfriMan View Post
    Hi Guys

    It's pretty strange indeed. It looks like google.co.za routes to www-cctld.l.google.com at 74.125.233.24, which is international. Google.com routes to www.l.google.com. at 196.23.168.148, which is local.

    Does anyone know if this is occurring with other ISP's?
    Yeah, happening with SAIX too:

    Pinging google.co.za [74.125.233.24] with 32 bytes of data:
    Reply from 74.125.233.24: bytes=32 time=407ms TTL=46
    Reply from 74.125.233.24: bytes=32 time=407ms TTL=46
    Reply from 74.125.233.24: bytes=32 time=407ms TTL=46
    Reply from 74.125.233.24: bytes=32 time=406ms TTL=46

    Ping statistics for 74.125.233.24:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 406ms, Maximum = 407ms, Average = 406ms
    PrepaidGamer.com - Cheap Xbox LIVE, PSN, WoW codes

  9. #9

    Default

    AfriMan, could you guys please maybe even speak to Google about this.
    This isn't a small thing. I'm sure users from all ISPs will greatly appreciate if this weird routing issue was sorted out.
    It makes absolutely no sense at all. Getting more and more annoying with each passing day.
    Didn't notice it so much until I started working from home and starting using their products on a more frequent basis.

  10. #10

    Default

    Quote Originally Posted by Denouncer View Post
    Yeah, happening with SAIX too:

    Pinging google.co.za [74.125.233.24] with 32 bytes of data:
    Reply from 74.125.233.24: bytes=32 time=407ms TTL=46
    host 74.125.233.31
    31.233.125.74.in-addr.arpa domain name pointer cpt01s01-in-f31.1e100.net

    Ping to Google Servers at CINX in Cape Town (NEOTEL Fiber)

    PING 74.125.233.31 (74.125.233.31) 56(84) bytes of data.
    64 bytes from 74.125.233.31: icmp_req=1 ttl=58 time=14.1 ms
    64 bytes from 74.125.233.31: icmp_req=2 ttl=58 time=14.3 ms
    64 bytes from 74.125.233.31: icmp_req=3 ttl=58 time=14.4 ms

    traceroute to 74.125.233.31 (74.125.233.31), 30 hops max, 60 byte packets
    1 41.164.x.x (41.164.x.x) 1.515 ms 1.565 ms 1.629 ms
    2 41.164.11.2 (41.164.11.2) 12.798 ms 12.860 ms 12.926 ms
    3 41.164.0.242 (41.164.0.242) 13.855 ms 13.921 ms 14.152 ms
    4 google.cinx.net.za (196.223.22.41) 15.922 ms 15.831 ms 16.328 ms
    5 64.233.174.105 (64.233.174.105) 16.394 ms 16.457 ms 16.526 ms
    6 cpt01s01-in-f31.1e100.net (74.125.233.31) 16.208 ms 14.689 ms 14.526 ms

    Ping to Google Servers at CINX in Cape Town (Mweb DSL)

    traceroute to 74.125.233.31 (74.125.233.31), 30 hops max, 60 byte packets
    1 x.x.x.x (x.x.x.x) 0.198 ms 0.277 ms 0.349 ms
    2 41-134-xx-xx.dsl.mweb.co.za (41.134.xx.xx) 3.200 ms 3.585 ms 3.901 ms
    3 197-81-146-1.jhb.mweb.co.za (197.81.146.1) 64.134 ms 67.021 ms 69.464 ms
    4 197-81-146-3.jhb.mweb.co.za (197.81.146.3) 71.912 ms 74.885 ms 76.795 ms
    5 tengig0-0-0-2.11.vic-p-2.mweb.co.za (196.22.169.226) 101.716 ms 105.884 ms 109.803 ms
    6 TenGigE0-0-0-0.cpt-p-1.mweb.co.za (197.84.4.34) 112.736 ms 87.548 ms 88.050 ms
    7 GigE-1-0-1.cpt-cinx-2.mweb.co.za (197.84.4.57) 87.341 ms 89.744 ms 92.925 ms
    8 google.cinx.net.za (196.223.22.41) 95.653 ms 85.585 ms 88.187 ms
    9 64.233.174.105 (64.233.174.105) 90.424 ms 92.828 ms 95.555 ms
    10 cpt01s01-in-f31.1e100.net (74.125.233.31) 97.793 ms 85.845 ms 88.572 ms

    Ping to Google Servers at CINX in Cape Town (Afrihost DSL)

    traceroute to 74.125.233.31 (74.125.233.31), 30 hops max, 60 byte packets
    1 10.60.3.4 (10.60.3.4) 0.117 ms 0.093 ms 0.090 ms
    2 196-210-128-1.dynamic.isadsl.co.za (196.210.128.1) 9.023 ms 10.216 ms 11.749 ms
    3 cdsl1-ctn-vl2376.ip.isnet.net (196.38.72.205) 54.727 ms 55.906 ms 57.148 ms
    4 196.35.115.128 (196.35.115.128) 51.574 ms 52.944 ms 53.769 ms
    5 core2b-ctn-gi0-2.ip.isnet.net (168.209.6.3) 79.101 ms 79.091 ms 79.360 ms
    6 168.209.6.131 (168.209.6.131) 65.939 ms 65.582 ms 66.675 ms
    7 168.209.100.222 (168.209.100.222) 212.200 ms 203.745 ms 205.106 ms Latency on IS link to CINX
    8 64.233.174.105 (64.233.174.105) 206.761 ms 195.930 ms 195.671 ms
    9 cpt01s01-in-f31.1e100.net (74.125.233.31) 202.804 ms 202.399 ms 202.476 ms

  11. #11

    Default

    MWEB's is also high for local traffic. Shouldn't be bordering on 100ms for a local site should it?

Similar Threads

  1. Weird ping behaviour
    By aktor in forum ADSL Discussions
    Replies: 15
    Last Post: 25-03-2010, 11:45 PM
  2. Bad ping times
    By boerseun in forum ADSL Discussions
    Replies: 0
    Last Post: 29-04-2009, 09:25 AM
  3. ping times
    By nero in forum Sentech MyWireless
    Replies: 13
    Last Post: 21-04-2004, 10:27 PM
  4. Bad Ping Times
    By nero in forum Sentech MyWireless
    Replies: 5
    Last Post: 26-03-2004, 12:54 PM
  5. Ping Times :)
    By ProAsm in forum Sentech MyWireless
    Replies: 6
    Last Post: 23-02-2004, 09:34 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •