Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Results 1 to 9 of 9

Thread: Huawei E589 microSD sharing not working/ enabled!?

  1. #1

    Default Huawei E589 microSD sharing not working/ enabled!?

    Hi,
    I have a Huawei E589u-12 4G LTE router (by NetCom Norway) that I have been playing around with. I finally decided to get a micoSD (32 GB) card to make it available for all connected clients. This is advertised as a feature with this router.

    However, although the microSD card shows up properly (as a SD card device) when connected directly via micro-USB to PC. No such thing appears and is available from Web interface! I have tried nearly anything I can think of, including factory reset, but nothing.

    But by poking around in the firmware, I know the "interface" is in there somewhere. It's over here:
    http://192.168.1.1/html/sdcardsharing.html

    However, it is not enabled and does not register my SD card for some reason, and any clicking results in an error. The interface should look almost exactly as this: http://tinyurl.com/ke9mepw taken from this article HERE.

    I'm out of ideas...

    Please Help!
    Last edited by E:V:A; 22-08-2013 at 11:47 PM.

  2. #2

    Default

    Just to clarify, you want to share the SD card?
    Have you formatted it yet?
    “Being ignorant is not so much a shame, as being unwilling to learn."

    - Benjamin Franklin

  3. #3

    Default

    Yes, I want to share it across all connected devices.

    No, it seem to be pre-formatted since I was able to put files on it from Windows... What type FS should it have? I think it's FAT32.

  4. #4

    Default

    Quote Originally Posted by E:V:A View Post
    Yes, I want to share it across all connected devices.

    No, it seem to be pre-formatted since I was able to put files on it from Windows... What type FS should it have? I think it's FAT32.
    Fat32 is usually fine. So you can't see the sharing tab at all? Or there is a sharing tab, and there is nothing under it. Best to take screenshot an post

    Could be a firmware issue, different carriers tend to restrict functionality at a firmware level
    “Being ignorant is not so much a shame, as being unwilling to learn."

    - Benjamin Franklin

  5. #5

    Default

    It looks exactly like in this video: http://www.youtube.com/watch?v=TKCWM_6ZBkM
    (Except for the provider name.)

    Code:
    Device Information:
    ===================================================
    Found modem         : E589u-12
    Model               : Huawei E589
    IMEI                : 86303001*******
    Serial NR.          : P2T7NB92********
    Firmware            : 11.433.13.00.01
    Web UI Version:     : 12.001.00.00.03
    Compile date / time : Jun 18 2012 13:27:56
    Hardware ver.       : CL1E589M22
    Chipset             : Qualcomm MDM9200
    NAND Flash          : TC58NYG1S3C
    SIM Lock status     : unlocked
    Wrong codes entered : 10 (unlock attempts left : 0)
    ===================================================

  6. #6

    Default

    Yeah, it could be disabled by courier/firmware.

    Will sniff around tomorrow to see if I find anything
    “Being ignorant is not so much a shame, as being unwilling to learn."

    - Benjamin Franklin

  7. #7

    Default

    Quote Originally Posted by imranpanji View Post
    Will sniff around tomorrow to see if I find anything
    Thanks, that would be great! Any news?

    Certainly the entire API is in there and working, but looking at the HTML code it pop out, it seem that these functions are commented out. I wonder if there is a setting somewhere (perhaps even inside the AT processor) that can change this?

    Also, I'd like someone with a working E589 web interface (with SDcardsharing enabled) to post the results of these AT commands.

    Code:
    at+cmee=2
    ati
    at^sfm?
    at^setport?
    at^getportmode
    at^cardmode
    at^cardlock?
    at^csdflt?
    at^authver?
    at^platform?
    at^portsel?
    at^rdcust=?
    Sorry, this is a load, but I need it, since we don't really know what we're looking for...

  8. #8

    Default

    HI, there is no way to access the SD card over a WiFi connection. The only way is to plug in your E589 device using the USB cable.

  9. #9

    Default

    There are several new Firmware updates available. Has anyone tried them? (And see if SD card sharing has changed?)

Similar Threads

  1. Huawei E589 LTE Router
    By webdudeZA in forum Mobile Broadband
    Replies: 15
    Last Post: 09-01-2014, 02:25 PM
  2. Internet Connection Sharing not working
    By The_Assimilator in forum ADSL Discussions
    Replies: 5
    Last Post: 03-09-2007, 11:18 AM
  3. Sharing a huawei E220 connection
    By fuzzybunny in forum Vodacom Broadband and Mobile Internet | LTE, HSPA+, HSDPA, 3G, EDGE, GPRS and BIS
    Replies: 16
    Last Post: 20-06-2007, 05:37 PM
  4. Gigabyte AP GN-A16B sharing working
    By buckinghamrd in forum ADSL Discussions
    Replies: 2
    Last Post: 04-08-2004, 05:09 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •