Afrihost: Github speed un-usable

Huppe

Member
Joined
Jun 8, 2009
Messages
25
Hi all,

Just wondered if any of you guys are struggling with speed on Afrihost Fibre to clone any repo from GitHub?

Any Git-repo I try to clone I would get a max speed of about 30Kb /s
when I do the same thing on my Moblie CellC hotspot - the very same repo are cloned in excess of 3Mb /s

On AH fibre traceroute to Github:

Code:
traceroute to github.com (140.82.121.4), 64 hops max, 52 byte packets
 1  amplifi (192.168.1.1)  4.413 ms  3.390 ms  3.098 ms
 2  100.99.107.1 (100.99.107.1)  13.378 ms  5.505 ms  5.098 ms
 3  169-1-2-113.ip.afrihost.capetown (169.1.2.113)  3.621 ms  4.168 ms  4.409 ms
 4  169-1-21-1.ip.afrihost.co.za (169.1.21.1)  6.157 ms  6.312 ms  4.922 ms
 5  * * *
 6  cpt-os1.ip.adsl.co.za (169.1.2.243)  5.097 ms  5.371 ms  4.873 ms
 7  * * *
 8  169-1-21-83.ip.afrihost.co.za (169.1.21.83)  5.451 ms  5.846 ms  4.398 ms
 9  wdcnw-os-cer-1-wan.osnet.co.za (196.25.26.65)  6.480 ms  5.406 ms  5.334 ms
10  * * *
11  be5956.rcr21.b023101-0.lon13.atlas.cogentco.com (149.11.248.209)  170.037 ms  174.244 ms  167.914 ms
12  zayo.lon09.atlas.cogentco.com (130.117.15.182)  171.307 ms  170.916 ms  168.121 ms
13  ae3.cs1.lhr15.uk.eth.zayo.com (64.125.28.150)  179.124 ms  204.463 ms  204.939 ms
14  ae10.cs3.ams10.nl.eth.zayo.com (64.125.29.16)  183.547 ms *  184.955 ms
15  ae4.cs1.ams17.nl.eth.zayo.com (64.125.28.36)  183.661 ms  182.717 ms  184.051 ms
16  ae2.cs1.fra6.de.eth.zayo.com (64.125.29.58)  183.874 ms  184.745 ms  183.377 ms
17  ae1.mcs1.fra6.de.eth.zayo.com (64.125.29.57)  184.197 ms  184.036 ms  184.152 ms
18  82.98.193.31 (82.98.193.31)  183.052 ms  183.119 ms  184.105 ms
19  * * *
*times out from here

my Hotspot route through Seacom, with higher latency, but speed.

any ideas?
 

KingMikel

Expert Member
Joined
Aug 18, 2011
Messages
1,036
I use Afrihost at home, and when I pull a GitHub repo down (via work VPN), it is as fast as when I'm in the office.
I think it might be an isolated issue.
 

shadow_man

Executive Member
Joined
May 27, 2005
Messages
5,457
I use Afrihost at home, and when I pull a GitHub repo down (via work VPN), it is as fast as when I'm in the office.
I think it might be an isolated issue.
You're using the work connection, not Afrihost to do so...

Afrihost --> VPN Tunnel --> Work (different ISP?) --> Github
Afrihost <----------> Work ------> Github

Hardly the same as other users going Afrihost --> Github...
 
  • Like
Reactions: OCP

Huppe

Member
Joined
Jun 8, 2009
Messages
25
valid point @jsheed_sa

I tried a VPN to my office (ISP = Sessions Telecom) but hardly saw any difference.
Speedtest-wise I'm getting my full 50Mbps on both VPN & local

so I'm a bit confused.
 

AfriNatic

Afrihost Rep
Staff member
Joined
Nov 18, 2016
Messages
4,503
Hi all,

Just wondered if any of you guys are struggling with speed on Afrihost Fibre to clone any repo from GitHub?

Any Git-repo I try to clone I would get a max speed of about 30Kb /s
when I do the same thing on my Moblie CellC hotspot - the very same repo are cloned in excess of 3Mb /s

On AH fibre traceroute to Github:

Code:
traceroute to github.com (140.82.121.4), 64 hops max, 52 byte packets
1  amplifi (192.168.1.1)  4.413 ms  3.390 ms  3.098 ms
2  100.99.107.1 (100.99.107.1)  13.378 ms  5.505 ms  5.098 ms
3  169-1-2-113.ip.afrihost.capetown (169.1.2.113)  3.621 ms  4.168 ms  4.409 ms
4  169-1-21-1.ip.afrihost.co.za (169.1.21.1)  6.157 ms  6.312 ms  4.922 ms
5  * * *
6  cpt-os1.ip.adsl.co.za (169.1.2.243)  5.097 ms  5.371 ms  4.873 ms
7  * * *
8  169-1-21-83.ip.afrihost.co.za (169.1.21.83)  5.451 ms  5.846 ms  4.398 ms
9  wdcnw-os-cer-1-wan.osnet.co.za (196.25.26.65)  6.480 ms  5.406 ms  5.334 ms
10  * * *
11  be5956.rcr21.b023101-0.lon13.atlas.cogentco.com (149.11.248.209)  170.037 ms  174.244 ms  167.914 ms
12  zayo.lon09.atlas.cogentco.com (130.117.15.182)  171.307 ms  170.916 ms  168.121 ms
13  ae3.cs1.lhr15.uk.eth.zayo.com (64.125.28.150)  179.124 ms  204.463 ms  204.939 ms
14  ae10.cs3.ams10.nl.eth.zayo.com (64.125.29.16)  183.547 ms *  184.955 ms
15  ae4.cs1.ams17.nl.eth.zayo.com (64.125.28.36)  183.661 ms  182.717 ms  184.051 ms
16  ae2.cs1.fra6.de.eth.zayo.com (64.125.29.58)  183.874 ms  184.745 ms  183.377 ms
17  ae1.mcs1.fra6.de.eth.zayo.com (64.125.29.57)  184.197 ms  184.036 ms  184.152 ms
18  82.98.193.31 (82.98.193.31)  183.052 ms  183.119 ms  184.105 ms
19  * * *
*times out from here

my Hotspot route through Seacom, with higher latency, but speed.

any ideas?

Do you have any ip overrides set in the hostfile? Try blocking the IP that is slow?

I will do some testing but I have haven't seen any issues. Are you still pulling from the same source when using mobile data?
 
Top