CCTV Monitor keeps gving message "No Video Input"

ivanlotter

Active Member
Joined
Jan 29, 2017
Messages
35
Hi,

I have a Philips monitor connected to my CCTV DVR with VGA cable. I am getting a No video Input message on the Screen.

I took the DVR into the shop I bought it and it works fine there.
I replaced the VGA cable today and still the same message.
I connected the monitor to my laptop and it displays the laptops screen.

I unplugged the 8 channel cctv power supply cable harness and link only one camera and still the same error.

The cameras have power on them as the infra red light are showing at night.

What else can I try except take the whole system to the shop?
 

mbayshark

Expert Member
Joined
Apr 5, 2015
Messages
4,827
Hi,

I have a Philips monitor connected to my CCTV DVR with VGA cable. I am getting a No video Input message on the Screen.

I took the DVR into the shop I bought it and it works fine there.
I replaced the VGA cable today and still the same message.
I connected the monitor to my laptop and it displays the laptops screen.

I unplugged the 8 channel cctv power supply cable harness and link only one camera and still the same error.

The cameras have power on them as the infra red light are showing at night.

What else can I try except take the whole system to the shop?
Stupid question but does the no video input not mean an av type input. Does the monitor have different input options. If so can't you choose the pc input for the vga cables signal?
 

Arthur

Honorary Master
Joined
Aug 7, 2003
Messages
26,325
Or perhaps you need to select the video output type in your DVR's setup menu. Make sure you've selected VGA.
 

ivanlotter

Active Member
Joined
Jan 29, 2017
Messages
35
Tested everything, looks like VGA card blew. however it is part of the main board so I need to get a new DVR:mad:
 
Top