Centurion G-Speak Ultra 2G

neoprema

Executive Member
Joined
Jan 12, 2016
Messages
6,474
I need some help with a g speak intercom from centurion. I’ve moved into the property and Centurion Sys have transferred the device into my profile.
Ive put a Vodacom Sim in it with airtime and data. On the device display it shows full network and connected to “G” with apn internet.

however in my G-Web profile the device still shows with its old number and says it’s disconnected. Also on the device it seems to think it needs to dial MTN USSD codes for balance enquiy despite saying it’s on Vodacoms network.

any ideas/help? Thx
 

Grumpy Old Man

Senior Member
Joined
Nov 12, 2008
Messages
518
I need some help with a g speak intercom from centurion. I’ve moved into the property and Centurion Sys have transferred the device into my profile.
Ive put a Vodacom Sim in it with airtime and data. On the device display it shows full network and connected to “G” with apn internet.

however in my G-Web profile the device still shows with its old number and says it’s disconnected. Also on the device it seems to think it needs to dial MTN USSD codes for balance enquiy despite saying it’s on Vodacoms network.

any ideas/help? Thx

Why don't you contact Centurion Technical Support on 011 699 2481 or support@centsys.co.za

Their customer service is exceptional.
 

neoprema

Executive Member
Joined
Jan 12, 2016
Messages
6,474
Why don't you contact Centurion Technical Support on 011 699 2481 or support@centsys.co.za

Their customer service is exceptional.
I did, and he tried a few things and it doesn't work. It was at 17h54 lol so i'll call them again tomorrow.

However, I think I know what might be the problem. I just downloaded the manual from Centsys (the other one I had was from another installer) and it says it uses MTN Sim Cards. I've put a Vodacom sim in. I'm wondering if the APN's and USSD codes etc aren't hard-coded to MTN's network and thats why this thing doesn't connect anywhere or do anything...
 

Grumpy Old Man

Senior Member
Joined
Nov 12, 2008
Messages
518
I did, and he tried a few things and it doesn't work. It was at 17h54 lol so i'll call them again tomorrow.

However, I think I know what might be the problem. I just downloaded the manual from Centsys (the other one I had was from another installer) and it says it uses MTN Sim Cards. I've put a Vodacom sim in. I'm wondering if the APN's and USSD codes etc aren't hard-coded to MTN's network and thats why this thing doesn't connect anywhere or do anything...

I have a vodacom sim in mine. I think they only switched to mtn earlier this year.
 

neoprema

Executive Member
Joined
Jan 12, 2016
Messages
6,474
Its fixed now.
I tried an MTN SIM card and it came online instantly, updated and announced itself on G-Web. I've reconfigured it and all is well.

Seems non MTN sims just don't work.
 
Top