Chevrolet Sonic 1.6 LS - Check Engine Light and ABS Light

luahn53

New Member
Joined
Aug 1, 2015
Messages
3
#1
Good day all

I'm hoping to get an opinion or advice if at all possible on a problem i am experiencing at the moment.

Stated a little while ago where the car suddenly loses power and has a jerking motion when trying to accelerate then the lights come on. Keep driving and the problem would stop and the lights will turn off. I took the car in and had the spark plugs replaced and this seemed to sort out the problem. It has now restarted doing the same and a bit more intense than usual. I had to fill up with 93 the other day and it all restarted right after this. It comes and it goes, but it is quite frustrating and stressful losing power suddenly on busy roads.

Has anybody experienced the same or could possibly give me a diagnosis on the possible causes.
 
Joined
Oct 7, 2018
Messages
5
#3
Hi Luahn, I'm having the same issue today... you got a fix or momentum on your Sonic? Cant find any other forums with the ABS and check engine light.with the same issue like the timing is out. I notice mine has an almost electric ticking sound when accelerating. Cant find anything after changing the plugs. Keep us posted plz.
 
Joined
Oct 7, 2018
Messages
5
#8
Thanks MP! Will find someone with a similar coil pack and test before buying it. Thanks again for the info, sounds like it's the issue.
 
Joined
Oct 7, 2018
Messages
5
#11
Sounds like it could be the problem, sounds like it misfires or the timing is out, sparking sound ticks when accelerating. In my old Ford when the plugs got wet it sounded the same so assuming it's what MP said.
 
Top