Deco M4: Ethernet Halves Speed?

Norri

Well-Known Member
Joined
Jan 23, 2007
Messages
114
Hey all,

I have the Deco M4 system and I've got one of the units connected via CAT5e ethernet (through a wall) to the primary unit.

Before doing this, I was getting 500Mbps downloads in a speed test.

Now, I'm getting 250Mbps. Doesn't matter which unit I'm connected to. Even the primary unit's speed seems to have been halved.

I understand that the cable can limit the speed downstream but why would it affect the primary unit's speed? Does the Deco system split the available bandwidth between the two "halves" of the network?

Is this a known issue? Anything I can do to fix it?
 

Crumbl0x

Senior Member
Joined
Mar 18, 2020
Messages
914
Hmm, we need to determine at what point and for what reason that's happening, I tested this kind of scenario with my M4 by setting up an iperf server at different devices and points and I've managed to get above 900mbps optimally over ethernet and ~300-500mbps over Wi-Fi at all access points, and my regular internet hasn't been affected regardless apart from some minor glitches with WiFi when it gets confused as to which point to connect to at first.

Sorry to hear that's happening though, I can confirm (along with some reviewers) that this *shouldn't* happen but some possibly faulty units had shown degraded performance like yours does (and even more severely, like 80% regressions)
 

shadow_man

Executive Member
Joined
May 27, 2005
Messages
5,773
I helped a friend with his Deco setup - he had a similar bottleneck - seems that QoS somehow got enabled on the router and throttled the WAN port to 100mbps... Perhaps check that?
 

Norri

Well-Known Member
Joined
Jan 23, 2007
Messages
114
Thanks, after some research I found similar complaints. I had mine set up correctly for my needs but rather turned it off and it seems "normal" now.

Normal still isn't great as I can't seem to get over 500Mbps on 5Ghz but I'll take it!
 

Gtx Gaming

Gtx Gaming
Joined
Aug 25, 2008
Messages
24,013
I dont have fast enough internet to be able to test :(

Fastest I had for while was rain 5g which did full speed on eth and wifi around 150mbps.
 
Top