High ping to EU

SeanZA

New Member
Joined
Feb 9, 2020
Messages
1
Hi recently my ping to EU has increased. It use to be around 170ms now its 300ms+ ping to other regions are the same as always just wanted to see if anyone else has this problem or if it is only on my side
 

cavedog

Honorary Master
Joined
Oct 19, 2007
Messages
19,311
Hi recently my ping to EU has increased. It use to be around 170ms now its 300ms+ ping to other regions are the same as always just wanted to see if anyone else has this problem or if it is only on my side

Who is your ISP because the latency should still be below 220ms to EU.
 

Go_Getter

Active Member
Joined
Feb 7, 2020
Messages
58

Trashcanman2000

Active Member
Joined
Mar 25, 2019
Messages
44
Same for me. Latency was usually 170 - 190 to EU. It now sits at 250 - 270. I thought the repaired WACS cable would resolve it but it has not. My ISP is Mind the speed on Frogfoor.
 

Go_Getter

Active Member
Joined
Feb 7, 2020
Messages
58
Same for me. Latency was usually 170 - 190 to EU. It now sits at 250 - 270. I thought the repaired WACS cable would resolve it but it has not. My ISP is Mind the speed on Frogfoor.
It isn't fully repaired yet.

They expect to have it fixed by the end of the month.
 

ArnoVermeulen

Well-Known Member
Joined
Jun 7, 2013
Messages
231
Same for me. Latency was usually 170 - 190 to EU. It now sits at 250 - 270. I thought the repaired WACS cable would resolve it but it has not. My ISP is Mind the speed on Frogfoor.
I get 179 on Afrihost. At work on Neotel/liquid telecom get 220
 

d.casper.b

Well-Known Member
Joined
Mar 22, 2010
Messages
139
Is the problem still not completely fixed?
I also used to get around ~160-170ms to EU, now it's ~198-205ms.
Or is it VOX? I was better off with VDSL.
 

CrypticZA

Expert Member
Joined
Sep 21, 2019
Messages
1,870
getting 143ms to London on Cool Ideas, everything has been fixed for a while now :cool:
 
Top