Hisense TV won't connect to WiFi


Senior Member
Apr 14, 2009
Hi guys

Please try and help me out.

My cousin is trying to connect his TV to his WiFi network without success.


1. Hisense 50a6100uw TV
2. Tenda N300 F3 Router
3. Android Phone (S8 or S9)
4. Windows Laptop

Scenario 1.

Both Phone and Laptop connect to the Router but the TV times out.

Scenario 2.

He creates a WiFi hotspot on his phone and both Laptop and TV connect fine.

I helped him to change the IP address on the TV, it seems like it connects but there is no data throughput. (Did I mess up the DNS settings or something like that?)

When he checks the WiFi on WiFi Analyser the channel is listed as 6+10. Why is there a "+10"?
Can he change it to only channel 6?

Any other ideas that he can try? I told him to change security to only WPA2 but that also did not work. Perhaps he should disable security altogether to test.

Sorry guys, my knowledge of networks are very limited and it is very difficult to try and troubleshoot if you are not close by.

Last edited:
Feb 19, 2019
Hi there,

Firstly he should log into the router and make sure that DHCP is enabled this will allow the router to automatically assign the tv with a new ip address.

He can change the channel to 6 or any other channel, he must make sure that the channel width is set to 20mhz (if it allows him to set it) some routers on 2.4ghz use 40mhz and most tv's do not support this.

He should also change his routers primary dns to and secondary dns to

If he needs assistance just pm me, i will gladly assist him over team viewer and explain what settings do what and why.

I have a LG 4K TV which sometimes also gives me trouble and requires me to manually set the IP, Subnet, Gateway and DNS


Senior Member
Apr 14, 2009
Thank you so much for the detailed reply.
Pretty sure it will help future members with similar issues.

The channel width did the trick for him.


Aug 19, 2013

I have the same problem and tried all of the above, yet no luck.

My TV does not find any wifi signal at all. I've tried from router and phone hotspot. I also saw that the option to turn on Bluetooth does not do anything.

Any advice?