How I got Neotel running on Ubuntu 9.04...

Beanmonster

Member
Joined
May 3, 2008
Messages
11
Decided to install Jaunty as my Hardy was very messy. I've been running linux since Breezy but still regard myself as a noobie.

After much trial and tribulation, and many failed attempts on Hardy, I finally got my Neotel Prime running, first time round on Jaunty.

Following is a step-by-step process which I take NO CREDIT for!

I am merely posting this in an attempt to make the process a bit easier to understand and follow for all linux(Ubuntu) users out there wishing to use Neotel.

This was done on a fresh installation of Ubuntu 9.04 Jaunty Jackalope.

It helps having an internet connection for the first step of the process... Otherwise packages can be downloaded seperately and google will provide details on unpacking and installing.

Code:
Step 1)
First download the necessary packages we need.

Open System>Administration>Synaptic Package Manager

Find and install:
[CODE]     1) wvdial
     2) linux-source

If the above are not listed, open terminal, use the code(s):
Code:
     1) $ sudo apt-get install wvdial
     2) $ sudo apt-get install linux-source

Step 2) --- All credit goes to cbrunsdonza for this step ---

Open a terminal and type:
Code:
$ sudo -s
$ cd /usr/src
$ tar xjvf linux-source-2.6.28.tar.bz2
$ gedit /usr/src/linux-source-2.6.28/drivers/usb/serial/option.c

"Now look for static struct usb_device_id option_ids[] about line 300 and add the following just above it:"
Code:
        // +++ chrisb
        #define NEOTEL_DEVICE_VENDOR_ID                 0x1d09
        #define NEOTEL_DEVICE_PRODUCT_ID                0x4000
        // +++

"and then in the struct add:" (the line in BOLD)
Code:
static struct usb_device_id option_ids[] = {
	[B]{ USB_DEVICE(NEOTEL_DEVICE_VENDOR_ID, NEOTEL_DEVICE_PRODUCT_ID) },[/B]
	{ USB_DEVICE(OPTION_VENDOR_ID, OPTION_PRODUCT_COLT) },
	{ USB_DEVICE(OPTION_VENDOR_ID, OPTION_PRODUCT_RICOLA) },

save and close gedit.

"To compile:"
Code:
$  cd /usr/src/linux-source-2.6.28/drivers/usb/serial/
$  make -C /lib/modules/`uname -r`/build M=`pwd`

If successful you should see a long list without errors resembling the following:
Code:
             make: Entering directory `/usr/src/linux-headers-2.6.24-21-generic'
               LD      /usr/src/linux-source-2.6.24/drivers/usb/serial/built-in.o
               CC [M]  /usr/src/linux-source-2.6.24/drivers/usb/serial/usb-serial.o
               CC [M]  /usr/src/linux-source-2.6.24/drivers/usb/serial/generic.o
               CC [M]  /usr/src/linux-source-2.6.24/drivers/usb/serial/bus.o
             ....
             make: Leaving directory `/usr/src/linux-headers-2.6.24-21-generic'

"Backup the old drivers"
Code:
$  mv /lib/modules/2.6.28-11-generic/kernel/drivers/usb/serial/option.ko /lib/modules/2.6.28-11-generic/kernel/drivers/usb/serial/option.ko.backup

"Now add new drivers (compiled):"
Code:
$ cp  /usr/src/linux-source-2.6.28/drivers/usb/serial/option.ko  /lib/modules/2.6.28-11-generic/kernel/drivers/usb/serial/option.ko

"You also need to load the new option:"
Code:
$ gedit /etc/modules

"And just add to the end of the file:"
Code:
        option

Reboot your computer, open a terminal again and type:
Code:
$ lsusb

Which should produce, among others:
Code:
Bus 002 Device 002: ID 1d09:4000 TechFaith Wireless Technology Limited

Step 3) --- All credit goes to potgietdl ---

Open a terminal and type:
Code:
$ sudo -s

And then:
Code:
$ wvdialconf

Which should produce something similar to:
Code:
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- Manufacturer: QUALCOMM INCORPORATED
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Max speed is 9600; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

[B]Found a modem on /dev/ttyUSB0.[/B]
Modem configuration written to /etc/wvdial.conf.
ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

Now run:
$ gedit /etc/wvdial.conf

Copy and paste the following and change your username and password:
Code:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Stupid Mode = 1
Phone = #777
Modem = /dev/ttyUSB0
Username = [B]1234567890[/B]@neotel.co.za
Dial Command = ATDT
Password = [B]1234[/B]
Baud = 460800
PPPD Options = crtcts multilink usepeerdns lock defaultroute

[Dialer neotel]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Baud = 460800
Stupid Mode = 1
Modem = /dev/ttyUSB0
Modem Type = USB Modem
Dial Command = ATDT
PPPD Options = crtcts multilink usepeerdns lock defaultroute

Save and close gedit

Step 4)

In the terminal, as any user, type:

Which, if successful, should result in:
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Thu May 14 22:59:46 2009
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 4541
--> Using interface ppp0
--> pppd: 0�[1c][08]P�[1c][08]
--> pppd: 0�[1c][08]P�[1c][08]
--> pppd: 0�[1c][08]P�[1c][08]
--> pppd: 0�[1c][08]P�[1c][08]
--> pppd: 0�[1c][08]P�[1c][08]
--> local IP address 41.174.2.250
--> pppd: 0�[1c][08]P�[1c][08]
--> remote IP address 2.2.2.2
--> pppd: 0�[1c][08]P�[1c][08]
--> primary DNS address 41.160.0.36
--> pppd: 0�[1c][08]P�[1c][08]
--> secondary DNS address 41.160.0.37
--> pppd: 0�[1c][08]P�[1c][08]

and a fully working internet connection!!!!! :D


to disconnect, in the terminal that is running wvdial, hold ctrl-c[/CODE]

Thank you once again to cbrunsdonza and potgietdl

I really hope this helps somebody and I really hope it works as nicely as it worked for me.

I haven't looked at a graphical way of dialing yet but I'll keep everybody updated. :p
 

Beanmonster

Member
Joined
May 3, 2008
Messages
11
For a graphical way of dialing...

Install Gnome-PPP, it uses wvdial as it's backend and works perfectly.
 

eagle-slayor

Senior Member
Joined
May 19, 2006
Messages
890
Hey Beanmonster

For me, I got errors in the first step, it seems that I can't install linux-source:

Code:
meraj@meraj-laptop:~$ sudo apt-get install linux-source
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libtwolame0 liba52-0.7.4 libdvdnav4 libdvdread4 libsidplay1 libmad0
  libid3tag0 libmpeg2-4
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  linux-source-2.6.28
Suggested packages:
  libncurses-dev ncurses-dev kernel-package libqt3-dev
The following NEW packages will be installed:
  linux-source linux-source-2.6.28
0 upgraded, 2 newly installed, 0 to remove and 252 not upgraded.
Need to get 57.0MB of archives.
After this operation, 57.2MB of additional disk space will be used.
E: You don't have enough free space in /var/cache/apt/archives/.
meraj@meraj-laptop:~$ -s
bash: -s: command not found

Do you have any idea of how to fix this?

Thanks in advance!
 

busker

Active Member
Joined
Mar 3, 2009
Messages
59
I think the error may be:
E: You don't have enough free space in /var/cache/apt/archives/.

so free up some space there ?
 

eagle-slayor

Senior Member
Joined
May 19, 2006
Messages
890
My Ubuntu installation just stopped working.

I'll just make a new partition and install it there, and hopefully won't have space problems
 
Top