How to RDP to a VM over the internet.

Rickster

EVGA Fanatic
Joined
Jul 31, 2012
Messages
18,987
Hi all, im a bit stumped with this issue, ive followed all the steps that i know of to get this working to no avail.

In VM ware i tried all the network options like bridge etc.

In router ive forwarded the port XXXXX.no-ip.com -> 5000

Changed the RDP port in the VM to 5000

Enabled remote desktop on the VM.

Before you guys say its unsafe to expose RDP to the internet, I know. This is just a project im working on.


PS, I can connect to my main PC from the internet via RDP so the router is setup fine.
 

swakop_toe

Well-Known Member
Joined
Sep 17, 2013
Messages
369
Else, find the RDP Windows Firewall incoming rules for port 3389 and change it to your specified RDP port number.
 

syntax

Executive Member
Joined
May 16, 2008
Messages
8,053
Does RDP work locally?
As above you can also check local firewall rules
Check internet connectivity from the server to make sure network connectivity is fine
 

irBosOtter

Expert Member
Joined
Feb 14, 2014
Messages
2,789
Is that a esxi vm or a vm on your PC with Vmware workstation installed? If Workstation then bridge would be the correct one to choose to get it on the same subnet as your local lan, just check firewall settings like people said above

And you could leave the default port to 3389 on the VM, unless your router can't portforward to a different port... ie from outside you connect to port 5000, and your router then forwards it to port 3389 internally to the vm....
 

PsyWulf

Honorary Master
Joined
Nov 22, 2006
Messages
11,949
Guacamole is fantastic and a good excuse to play with docker

Generally though windows firewall is usually the culprit for RDP issues
You did connect to xxx.noip.com:5000 in the RD app yeah?
 
Top