Huawei Mate 10 / Pro Review, tips and tricks

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
Finally my 9.1 update came through this evening. Same for my GF's P20 Pro
 

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
Anyone having bluetooth audio issues after the update? Connection to my headphones hasn't been great since the update
 

SykomantiS

Expert Member
Joined
May 7, 2012
Messages
2,356
Anyone having bluetooth audio issues after the update? Connection to my headphones hasn't been great since the update
My Android Auto started randomly freezing up after a few minutes of use. Started yesterday. I'm unsure if it's related to the EMUI update or an update of the Android Auto app itself or even some other app like Maps. I doubt it's the head unit as its firmware hasn't changed in the last year. Haven't noticed any Bluetooth specific issues, but then the Bluetooth on my Mate 10 Pro has never been great to start with.
 

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
My Android Auto started randomly freezing up after a few minutes of use. Started yesterday. I'm unsure if it's related to the EMUI update or an update of the Android Auto app itself or even some other app like Maps. I doubt it's the head unit as its firmware hasn't changed in the last year. Haven't noticed any Bluetooth specific issues, but then the Bluetooth on my Mate 10 Pro has never been great to start with.
Do you have USB debugging enabled in developer options? That helped me when I rented a car a little while ago.

My bluetooth wasn't bad before the update. Now very sketchy
 

SykomantiS

Expert Member
Joined
May 7, 2012
Messages
2,356
Do you have USB debugging enabled in developer options? That helped me when I rented a car a little while ago.

My bluetooth wasn't bad before the update. Now very sketchy
No it's disabled currently. To be honest I've never used it on any of my previous phones either (apart from rooting, I think)
 

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
No it's disabled currently. To be honest I've never used it on any of my previous phones either (apart from rooting, I think)
Give it a bash, helped me out when I was having issues with Android auto
 

SykomantiS

Expert Member
Joined
May 7, 2012
Messages
2,356
Didn't actually do any debugging, just enabled it. It's what someone suggested on reddit, as well as disable battery management on the android auto app

https://www.reddit.com/r/AndroidAuto/comments/7wrmd3
I'm thinking the battery management is what fixed your issue since USB debugging by itself doesn't really do anything (that I am aware of). Regardless, I'm glad you got it sorted.

In my case, it didn't help any (not that I expected it to), what did help though was switching back to the old AA interface- no freeze-ups this morning. When I did that, it ran through that welcome/tips screen on the head unit so I'm wondering if that has anything to do with it, since I cleared cache and data when switching to the new interface. I'll try switching back to the new interface tonight and see what happens. If it doesn't work I guess I'll use the old interface until they update the app.
 

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
Is it just me having bluetooth issues? Sheesh, listening to music (spotify) on my headphones is becoming unbearable with the connection dropping and coming back every few seconds. I guess I should try test the headphones with another phone to isolate the issue
 

SykomantiS

Expert Member
Joined
May 7, 2012
Messages
2,356
Is it just me having bluetooth issues? Sheesh, listening to music (spotify) on my headphones is becoming unbearable with the connection dropping and coming back every few seconds. I guess I should try test the headphones with another phone to isolate the issue
If you go back far enough in this thread, you'll find the many, many times I've mentioned my Bluetooth issues, along with android auto issues.
 

jman

Expert Member
Joined
May 9, 2014
Messages
2,353
If you go back far enough in this thread, you'll find the many, many times I've mentioned my Bluetooth issues, along with android auto issues.
Ah, alright. I don't think I had any of these issues until the latest 9.1 update, which is why I'm only mentioning now. Anyways, it sucks! I'll probably have to use the wired cable to listen to stuff on my phone
 

SykomantiS

Expert Member
Joined
May 7, 2012
Messages
2,356
Ah, alright. I don't think I had any of these issues until the latest 9.1 update, which is why I'm only mentioning now. Anyways, it sucks! I'll probably have to use the wired cable to listen to stuff on my phone
It's more often than not an intermittent issue, but I've had some form of displeasure with the Bluetooth on this phone from the beginning.
 

Park@82

Honorary Master
Joined
Jun 6, 2008
Messages
11,718
I'm thinking the battery management is what fixed your issue since USB debugging by itself doesn't really do anything (that I am aware of). Regardless, I'm glad you got it sorted.

In my case, it didn't help any (not that I expected it to), what did help though was switching back to the old AA interface- no freeze-ups this morning. When I did that, it ran through that welcome/tips screen on the head unit so I'm wondering if that has anything to do with it, since I cleared cache and data when switching to the new interface. I'll try switching back to the new interface tonight and see what happens. If it doesn't work I guess I'll use the old interface until they update the app.
I also had issues with android auto freezing with the P30 pro. Tried a bunch of things (also did some settings in developer options - edit: I set it to charge only) so not sure what fixed it. Also switched back to the old interface so maybe that caused it.
 
Top