I've used up Google; now I need you guys!

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
I've trawled through Google for two days now. My Canon MX494 wireless printer suddenly stopped printing. Says no printer is installed. When I try to install a printer it says cannot install wsd drivers, instalation failed. I've deleted and reinstalled the printer drivers from the Canon site, rebooted, no joy. The last time I manually got the printer wifi connected to the router using the printer buttons themselves, then reinstalled, then I get an error box "New port could not be created : 0010"
I often get an error message that the print spooler service is not running, so I switch the spooler service on, and it just gets switched off again, even in manual! I've run the Windows troubleshooter, it says the WSD print device is not installed, so I tell it to install and the installation tries and then fails, - now it's just giving me a message 'WSD device doesn't have a driver" but I've just installed one from Canon themselves, the newest one. Anyone had this hassle? On all the forums I've been through I can't find a similar problem.
Running Windows 7 on a Lenovo i7
 

"D"

Expert Member
Joined
Oct 20, 2006
Messages
1,563
Step 1: Refill the ink cartridge! ;)
Step 2: Replace Windows 7 with Linux! ;)
Step 3: Replace Lenovo i7 with Lenovo i9 without delay! ;)

If none of the aforementioned solves the problem miraculously, remember:

When uninstalling printer drivers, clear the cache and reboot Windows before attempting to reinstall the printer drivers.

By the way, don't install 64-bit software if you are running a 32-bit system. (And vice versa.)

Another little tip: Your particular printer has drivers available for a number of other operating systems - not only for Windows! (This is great news for troubleshooting a problematic device!)
 

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
Step 1: Refill the ink cartridge! ;)
Step 2: Replace Windows 7 with Linux! ;)
Step 3: Replace Lenovo i7 with Lenovo i9 without delay! ;)

If none of the aforementioned solves the problem miraculously, remember:

When uninstalling printer drivers, clear the cache and reboot Windows before attempting to reinstall the printer drivers.

By the way, don't install 64-bit software if you are running a 32-bit system. (And vice versa.)

Another little tip: Your particular printer has drivers available for a number of other operating systems - not only for Windows! (This is great news for troubleshooting a problematic device!)
Thanks for the highly biased advice! (Only kidding!)
Ya, didn't clear the cache, so I'll try that one. Thank you.
 

newklear

Senior Member
Joined
Apr 15, 2008
Messages
935
Hey, I'm so desperate now I'll take any advice! :)
If not already done, try;
  • A complete reset of the printer.
  • Complete driver uninstall, including deleting the driver software.
  • Open Devices and Printers > Print server properties > Driver tab > delete all the drivers listed other than 'Microsoft XPS Document Write' and 'Send to Microsoft OneNote Driver'. Try install again. Try "run as Administrator"
  • Install an alternate similiar driver, https://printerdrivers.com/canon-pixma-mp490-driver/
  • Trial and error, do not give up!
 

Rickster

EVGA Fanatic
Joined
Jul 31, 2012
Messages
17,137
Hey, I'm so desperate now I'll take any advice! :)
Sounds like your windows is cooked, best to backup your stuff and clean install windows.

Sure it's a schlep but much easier than figuring out the real reason behind the issue.
 

"D"

Expert Member
Joined
Oct 20, 2006
Messages
1,563
If I had such a fancy printer, I would download its Android/iOS software and then attempt to print something from my mobile phone. If that does not work, then at least you will know your Windows is fine but the printer is farcked.
 

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
If not already done, try;
  • A complete reset of the printer.
  • Complete driver uninstall, including deleting the driver software.
  • Open Devices and Printers > Print server properties > Driver tab > delete all the drivers listed other than 'Microsoft XPS Document Write' and 'Send to Microsoft OneNote Driver'. Try install again. Try "run as Administrator"
  • Install an alternate similiar driver, https://printerdrivers.com/canon-pixma-mp490-driver/
  • Trial and error, do not give up!
Thanks for the advice. Sorry for the lengthy reply delay, had another crisis which eclipsed the printer problem for a week or two!
 

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
Perhaps try it with the USB cable attached instead of the wireless?
Thanks, yes I did try that.
(Sorry for the lengthy reply delay, had another crisis which eclipsed the printer problem for a week or two! )
 

newklear

Senior Member
Joined
Apr 15, 2008
Messages
935
Thanks for the advice. Sorry for the lengthy reply delay, had another crisis which eclipsed the printer problem for a week or two!
No problem, it's a pay-as-you-go/minute rate so take your time.
2 Steps back and 1 step forward is still progress ;)
 

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
If I had such a fancy printer, I would download its Android/iOS software and then attempt to print something from my mobile phone. If that does not work, then at least you will know your Windows is fine but the printer is farcked.
Thanks, ya it works from my wife's cellphone and her tablet, so the printer is still OK.

( Sorry for the lengthy reply delay, had another crisis which eclipsed the printer problem for a week or two! )
 

wrinklyo

Well-Known Member
Joined
Sep 26, 2008
Messages
192
Sounds like your windows is cooked, best to backup your stuff and clean install windows.

Sure it's a schlep but much easier than figuring out the real reason behind the issue.
Ya, you've got a point there...
 
Top