Message "sign into Wifi network" on Samsung android phone driving me NUTS

Joined
May 28, 2018
Messages
26
#1
Can a fundi out there please tell me why this is happening all of a sudden? I use a wifi router to log into internet, email and send/receive Whatsapp messages on my phone. I use the same router on my laptop. It has always worked absolutely perfectly, in that I connect to the router via my phone and off I go using it for what it is meant for.
For the past week, whenever I connect to the router on my phone...it connects to the router, but then a message pops up "sign into Wifi network". And then I cannot get onto internet nor can I send/receive Whatsapp messages. I have tried connecting to the IP address and typing in 'admin'.....but it does not help. This ONLY works on my laptop.
When I use the router on my laptop, as soon as it connects, it pops up with a 3G Mobile Hotspot website, showing the IP address of the router....here I log in using 'admin' and here I can see my data usage. But I don't want to do this on my phone. I don't need to. I have never had to either, until a few days ago.
Why on earth is my android phone suddenly asking me to sign into the wifi network??? Driving me INSANE here, folks. If there is somebody out there who has the answer, please, please do tell me. Netz
 

isie

Executive Member
Joined
Jan 16, 2010
Messages
9,936
#2
Can a fundi out there please tell me why this is happening all of a sudden? I use a wifi router to log into internet, email and send/receive Whatsapp messages on my phone. I use the same router on my laptop. It has always worked absolutely perfectly, in that I connect to the router via my phone and off I go using it for what it is meant for.
For the past week, whenever I connect to the router on my phone...it connects to the router, but then a message pops up "sign into Wifi network". And then I cannot get onto internet nor can I send/receive Whatsapp messages. I have tried connecting to the IP address and typing in 'admin'.....but it does not help. This ONLY works on my laptop.
When I use the router on my laptop, as soon as it connects, it pops up with a 3G Mobile Hotspot website, showing the IP address of the router....here I log in using 'admin' and here I can see my data usage. But I don't want to do this on my phone. I don't need to. I have never had to either, until a few days ago.
Why on earth is my android phone suddenly asking me to sign into the wifi network??? Driving me INSANE here, folks. If there is somebody out there who has the answer, please, please do tell me. Netz
so when you connect to the hotspot with your laptop , can you use the internet?
 

MightyQuin

Honorary Master
Joined
Oct 6, 2010
Messages
11,993
#3
Can a fundi out there please tell me why this is happening all of a sudden? I use a wifi router to log into internet, email and send/receive Whatsapp messages on my phone. I use the same router on my laptop. It has always worked absolutely perfectly, in that I connect to the router via my phone and off I go using it for what it is meant for.
For the past week, whenever I connect to the router on my phone...it connects to the router, but then a message pops up "sign into Wifi network". And then I cannot get onto internet nor can I send/receive Whatsapp messages. I have tried connecting to the IP address and typing in 'admin'.....but it does not help. This ONLY works on my laptop.
When I use the router on my laptop, as soon as it connects, it pops up with a 3G Mobile Hotspot website, showing the IP address of the router....here I log in using 'admin' and here I can see my data usage. But I don't want to do this on my phone. I don't need to. I have never had to either, until a few days ago.
Why on earth is my android phone suddenly asking me to sign into the wifi network??? Driving me INSANE here, folks. If there is somebody out there who has the answer, please, please do tell me. Netz
So it does not ask you for your SSID and password to log in with?

Usually you only sign in once and then your device remembers the connection.

I would reset the router and re-create the SSID and password.

That would be the quickest and easiest way. Basically just do it from scratch. It will take a few minutes.
 

irBosOtter

Expert Member
Joined
Feb 14, 2014
Messages
1,785
#4
Happens to me (and the guy's iphone next to me) when we use my Huawei mobile device (on rain network) when it does not have service (internet access). As soon a the internet connection comes back then that message goes away and internet access works fine.... not sure if your wifi router looses it's internet connection perhaps?

Edit: "3G Mobile Hotspot website" Any settings on your router for this hotspot webpage, perhaps there is a setting ticked that users must log into a portal before being able to use the internet, switch that off if there is such a setting...
 
Last edited:

isie

Executive Member
Joined
Jan 16, 2010
Messages
9,936
#5
Happens to me (and the guy's iphone next to me) when we use my Huawei mobile device (on rain network) when it does not have service (internet access). As soon a the internet connection comes back then that message goes away and internet access works fine.... not sure if your wifi router looses it's internet connection perhaps?

Edit: "3G Mobile Hotspot website" Any settings on your router for this hotspot webpage, perhaps there is a setting ticked that users must log into a portal before being able to use the internet, switch that off if there is such a setting...
you answering your own question
if you connect to a wifi connection and the phone detects no internet connection on that same connection- android assumes its a sign on type connection hence pops that message and tries to route you to a sign on page
 

irBosOtter

Expert Member
Joined
Feb 14, 2014
Messages
1,785
#6
you answering your own question
if you connect to a wifi connection and the phone detects no internet connection on that same connection- android assumes its a sign on type connection hence pops that message and tries to route you to a sign on page
If I connect to any normal AP wifi network that has no internet access it will only show a ! on the wifi connection icon on my Android phone.... does not automatically think it's a sign on type.... seems most mobile routers does it though...
 

isie

Executive Member
Joined
Jan 16, 2010
Messages
9,936
#8
If I connect to any normal AP wifi network that has no internet access it will only show a ! on the wifi connection icon on my Android phone.... does not automatically think it's a sign on type.... seems most mobile routers does it though...
yep correct on mobile router it does this
might be some protocol set up.
 

irBosOtter

Expert Member
Joined
Feb 14, 2014
Messages
1,785
#10
yep correct on mobile router it does this
might be some protocol set up.
Mine only does it when there is no internet service on the mobile router, if the mobile router is connected to 3G/4G it does not ask to sign in anywhere, just works like any normal AP would, so I am wondering if his device has a setting to force all connected devices to authenticate first, that one should be able to switch off on the router...
 
Joined
May 28, 2018
Messages
26
#11
I have found a few answers useful, thanks. I have reset the router and recreated the SSD and password, twice, already.
It worked fine for a while then went haywire again and did the same thing.
HOWEVER....now THIS is very interesting.....dunno if someone else has come across this.
When I use the Wifi router on my laptop, it immediately logs on via the IP address when I put in the 'admin' log in. Then it works absolutely perfectly. If my phone is connected to the router at the same time, everything is absolutely fine as well. Whatsapp and internet works.
BUT.....when I disconnect from my laptop and switch off and the router is no longer connected to the internet via my laptop.....and I connect to the Wifi on my phone again....lo and behold....up pops the message..."log on to wifi network". Say WHAAAAAAT?????
When I haven't used the wifi router on my laptop for say....a day or two....and I connect to the router via my phone....no problem at all. I do not get that message.
Could this be some sort of 'clash' between the laptop and phone?
Mystery....indeed....:oops::unsure:
 

ld13

Honorary Master
Joined
Oct 28, 2005
Messages
10,917
#12
Could you show us the modem/router you are using? Even just a model number would maybe reveal some info...
 

MightyQuin

Honorary Master
Joined
Oct 6, 2010
Messages
11,993
#13
I have found a few answers useful, thanks. I have reset the router and recreated the SSD and password, twice, already.
It worked fine for a while then went haywire again and did the same thing.
HOWEVER....now THIS is very interesting.....dunno if someone else has come across this.
When I use the Wifi router on my laptop, it immediately logs on via the IP address when I put in the 'admin' log in. Then it works absolutely perfectly. If my phone is connected to the router at the same time, everything is absolutely fine as well. Whatsapp and internet works.
BUT.....when I disconnect from my laptop and switch off and the router is no longer connected to the internet via my laptop.....and I connect to the Wifi on my phone again....lo and behold....up pops the message..."log on to wifi network". Say WHAAAAAAT?????
When I haven't used the wifi router on my laptop for say....a day or two....and I connect to the router via my phone....no problem at all. I do not get that message.
Could this be some sort of 'clash' between the laptop and phone?
Mystery....indeed....:oops::unsure:
Are you using static IP or DHCP on your devices?
 
Top