Mweb Talk SIP trunk with asterisk freepbx trunk configuration settings

Zapo

Active Member
Joined
May 13, 2014
Messages
57
Good day all,

Im new to the broadband forum, I had an account that seemed to be deactivated and I couldn't find a way to message any admins or anything. So I just created a new one. (So for the admins, i donot know if they can merge my two accounts, pm me for more info please)

So my main issue,

I have a client who wants a voip pbx server,

I have installed and set up the asterisk with free pbx, I have struggled for about a week with trying to get my nexus sip account working, I still never got it working. ( Could never call outwards, well I could occasionaly)

I have now since moved over to a mweb mytalk sip trunk as nexus support simply said they dont give support with connecting the account to 3rd party devices.

Does anyone here know of the trunk sip settings to work with mweb sip trunk?

Outgoing:

Incoming:

RegisterString:

Currently I have just filled in the default parameters which freepbx provided when creating the trunk. it registers fine, but I can only make outgoing calls.

when I phone the mweb number (my voip number) from my phone it doesn't ring or anything it just hangs up, and there are no symptoms that the pbx received it. (ie its not my incoming route, as far as I know).

So if some one could provide me with some information and help relive me from my frustrated state I would greatly appreciate it.

I am sure that some here on the forums has successfully set up mweb talk on an asterisk freeepbx system.


Thanks
 

Hummercellc

Expert Member
Joined
Jan 6, 2008
Messages
3,446
Trunk Name: what ever you like
Outbound Caller ID: 27XXXXXXXXX (your sip number)

Outgoing settings:

Trunk Name: 27XXXXXXXXX (your sip number)

PEER Details:

username=27XXXXXXXXX
type=peer
qualify=yes
secret='sip password'
nat=yes
insecure=invite,port
host=196.28.95.12
fromuser=27XXXXXXXXX
fromdomain=196.28.95.12
dtmfmode=rfc2833
context=from-trunk
disallow=all
allow=g729 (change to alaw if you don't have g729 installed)
canreinvite=no

Incoming setting - Leave them all blank

Register string: 27XXXXXXXXX:YOUR-PASSWORD@196.28.95.12/27XXXXXXXXX

Remember to create a outbound route....
 

Zapo

Active Member
Joined
May 13, 2014
Messages
57
Thanks for your response, I will give them a try.

May I ask why incoming must be blank? Does it not use them?

And do I need to make any changes to my global sip.config ?
 

Hummercellc

Expert Member
Joined
Jan 6, 2008
Messages
3,446
Thanks for your response, I will give them a try.

May I ask why incoming must be blank? Does it not use them?

And do I need to make any changes to my global sip.config ?

The incoming section causes more problems than it's worth, So instead you leave it blank and add the line
'context=from-trunk' to the outgoing section...

If you are using Asterisk 1.8 or later, the default config is fine.

Prior to 1.8 you only had to make sure you had the following:
You add this at the bottom under
Other SIP Settings

allowguest=no
alwaysauthreject=yes
 

Zapo

Active Member
Joined
May 13, 2014
Messages
57
Thanks for you response,

I think I got it sorted.
I am using the latest version of freepbx. But I think I still added the allowguesy=no, alwaysauthreject=yes

However I am having an issue where the trunk registrations go offline?
They where connected then I came back and looked a while later and they where both offline.

What could be causing this?

I am running asterisk in a VM ontop of windows 7? I have some feeling that it is networking related some how. But the trunk lines are online but the registration isnt?
 
Last edited:

Hummercellc

Expert Member
Joined
Jan 6, 2008
Messages
3,446
Change your registration settings under the 'Asterisk SIP Settings'

Registration Settings

Registrations: 5 (registertimeout) 0 (registerattempts)
Registration Times: 60 (minexpiry) 120 (maxexpiry) 90 (defaultexpiry)

That should do the trick....
 

rapidblue

Expert Member
Joined
Jul 30, 2007
Messages
1,554
Trunk Name: what ever you like
Outbound Caller ID: 27XXXXXXXXX (your sip number)

Outgoing settings:

Trunk Name: 27XXXXXXXXX (your sip number)

PEER Details:

username=27XXXXXXXXX
type=peer
qualify=yes
secret='sip password'
nat=yes
insecure=invite,port
host=196.28.95.12
fromuser=27XXXXXXXXX
fromdomain=196.28.95.12
dtmfmode=rfc2833
context=from-trunk
disallow=all
allow=g729 (change to alaw if you don't have g729 installed)
canreinvite=no

Incoming setting - Leave them all blank

Register string: 27XXXXXXXXX:YOUR-PASSWORD@196.28.95.12/27XXXXXXXXX

Remember to create a outbound route....

Was also struggling to get incoming calls - this helped!! Thanks :)
 

riazsabi

Member
Joined
Dec 30, 2016
Messages
10
I cant seem to get this to work. Same setup but using a Grandstream DP750 DECT setup
 
Top