My rain 5G router is not connecting to both 4G and 5G networks

Emjay@101

New Member
Joined
Apr 28, 2024
Messages
2
I've tried moving the router around in the house and I still get no connection whatsoever. This is the second time now, first time it happened I called rain and they escalated the matter to the technical department and the issue was fixed in 2 days time. Now within two weeks it happened again, I called them and they said the same thing but it's hasn't been fixed, it's been over two weeks now, they can't seem to figure out what's wrong
 
I've tried moving the router around in the house and I still get no connection whatsoever. This is the second time now, first time it happened I called rain and they escalated the matter to the technical department and the issue was fixed in 2 days time. Now within two weeks it happened again, I called them and they said the same thing but it's hasn't been fixed, it's been over two weeks now, they can't seem to figure out what's wrong
Hi @Emjay@101,

Please provide us with your email via PM | https://mybroadband.co.za/forum/conversations/add?to=rain_mobile
 
I've tried moving the router around in the house and I still get no connection whatsoever. This is the second time now, first time it happened I called rain and they escalated the matter to the technical department and the issue was fixed in 2 days time. Now within two weeks it happened again, I called them and they said the same thing but it's hasn't been fixed, it's been over two weeks now, they can't seem to figure out what's wrong
I am having the exact same issue, is yours sorted out now?
 
ai ai ai I am definitely having the same problem. Sometimes it disconnects and reconnects. Router also restarts on its own sometimes even when I do a speedtest on my route(Does not happen a lot).
Another issue I have is yes there is no 5G coverage by me however here is everywhere 4G coverage and the router does switch to 4G but comparing my speed tests with the router and the two 4G sim cards for which one is in my phone and the other one in a mobile router, the router runs at 2-4Mb and the sim in my phone and mobile router runs more than 20Mb---almost 30mb. Now I asked them why and I said that, it's not fair as I am limited with both sims with 2GB data and cant be using that for my uploads and download otherwise it will be finished with a few minutes. They replied to me that they using 3rd party for the 4G sims which I think is ridiculous because why the hell don't my 5G router when on 4G also run that speed and connect to their 3rd party.

Rain is literally the crappiest network in THE WORLD but cheapest. I would so like to leave these idiots and switch but there is no other network that gives two sims cards with data and talk time and SMSs with uncap router. So in plain words, I am screwed and stuck with them.

Also now recently I have been having issues with their website as I am changing the password and it says successful but when trying to log in it tells me email or password is wrong.

They should fix their entire company like everything....employees, coverage, website, services etc......
 
Back
Top