Pastel Xpress v12, Windows 7 Registry Fix.

Joined
Jun 25, 2018
Messages
26
#1
Hi,

I'm hoping someone will be able to jog my memory, as I can't remember how to do this...

I'm trying to sort this out for a Non Profit Organization and Sage Pastel's response is 'buy a new version and buy a support contract.' "Ker-Ching!!!", R6500. (Did I mention "Non Profit Organization?", and yes, it's a legal license.) We're not averse to paying for tech support, but as usual Pastel are being dicks about it. (Dealt with them on several occasions over the years, and being a dick about customer support is a company policy.)

The problem is as follows:

We have Pastel Xpress v12 running on clean install of (legal) Windows 7 Basic. It installed and registered online OK. We set up the company and restored successfully from a backup. No problem then, everything seemed to work OK.

When you close the program and the start it again, that is where things go pear-shaped. When you start Pastel and the attempt to open the company, the company has been Deactivated and cannot be re-activated. It can be recreated but you have exactly the same issue next time you start Pastel.

I have a vague recollection that there is a Windows registry entry that needs to be either modified or created, but I can't remember what it is. (I've done the usual, disable UAC, run as admin, compatibility mode, etc.)

Anyone remember how to fix this?

Thanks.
 

ODTech

Senior Member
Joined
May 9, 2010
Messages
820
#2
Did you install pervasive as a service or as application?

On Windows 7 install it as a application and on anything newer as service.
 
Joined
Jun 25, 2018
Messages
26
#4
Did you install pervasive as a service or as application?

On Windows 7 install it as a application and on anything newer as service.
Thanks. It didn't give me the option, (even installing manually. Ver 9.6 workgroup) but it's not listed under "Services" so it must be an app.
 
Last edited:
Joined
Jun 25, 2018
Messages
26
#6
For some reason the folder when you try and activate the company doesn't allow you to select "OK." It's Grayed out. This doesn't happen with the "Demo" company.

I've had a look at the security permissions on both folders and they are identical. Is there a specific file it references in these folders? I heard something about having to specify a path in the registry?
 

signates

Expert Member
Joined
Dec 8, 2009
Messages
3,876
#7
The build version could be different.

Do you know what build version it was running before the clean install? It could be a newer version to the clean install.
 
Joined
Jun 25, 2018
Messages
26
#8
The build version could be different.

Do you know what build version it was running before the clean install? It could be a newer version to the clean install.
I don't. Sorry. All I know that it was originally v11 and was upgraded to v12 at some point in 2012. They had some problem with USB drivers on the machine recently, so they took the PC to Matrix somewhere in Boksburg, and they installed an un-licenced Windows 10 which really stuffed it up. I backed it up, formatted, and re-installed the original licensed OS (Win 7 Basic x64).
By the time the PC came to me it was a real mess (no main-board driver support for Win 10.) BTW the USB ports work fine now.

The thing that I don't understand is that it worked fine when I restored the backup. After re-opening Pastel after it was shutdown down, the company was deactivated and couldn't be re-activated. The Pastel Xpress application stays registered.

Version 12 lists Windows 7 as a supported OS. I have a feeling that v11 doesn't support Windows 7, perhaps I should try v11 and see if that works...

I'll let you know.
 
Last edited:

The_Librarian

Another MyBB
Super Moderator
Joined
Nov 20, 2015
Messages
18,316
#9
Was about to suggest that - install v11, test it - and if it works, yay... then, do a bare metal backup, then upgrade to v12 ...
 
Joined
Jun 25, 2018
Messages
26
#11
Looks like we've come to the end of the road here...

The accountant has decided to 'Bite the bullet' and fork out for an upgrade to Pastel Xpress 2018. I'm out of my depth on Pastel, and I haven't been able to find anyone who is prepared to do (paid) support on a version from 2012.
All we can hope for is that our backups will restore on v18. No guarantees from Sage Pastel though, "Pays your money, take your chance." No refunds. That's the type of company they are - Totally Mercenary - bugger the customer.

I want to say a BIG THANK-YOU! to everyone who replied to this thread and tried to help us out. It was very much appreciated.
 
Last edited:
Top