Please do a MyBroadband speed test on Rain

This is literally every single day without fail. Great speeds and 0 issues when nobody is online, and it slowly progresses to absolute crap as more and more people come online or get home from work. One would think that 45 down and 1 up is fine for gaming on local servers for games like Call of Duty, Battlefield and Counterstrike (which in theory it should be) but that's not the issue. The issue is MASSIVE amounts of rubberbanding, latency, ping spikes and disconnects.

Extremely frustrating.

EDIT: I'll do Mybroadband speed tests as well :)

Same situation,regarding the gaming side of things.
It was still playable on a competitive level for CS about 2/3 weeks ago, now its constant rubberbanding :'(
 
Ping 19ms
upload : 18mbs
download : 24mps

better than my 8meg adsl line for now ...
 
Ping: 12ms
Download: 342.73Mbps
Upload: 38.44Mbps

1597910313627.png

Not normally this fast but have load shedding currently and running on UPS. The other traffic is probably gone.
 
rain.png

I must say I cannot complain on the R250 option. Constant more that 30Mbps download and 10Mbps upload. Poynting outdoor antenna. Closest tower line of sight 5km. Also not a big town, so speed should hopefully be like this for some while.
 
24/7 Sim tested to rain (speedtest server) to showcase its full speed, which you can get with the R250 package. I just wish they let me combine these two sims so we can have 24/7 access but with the unshaped version outside of 6-11pm.

Outside of this speedtest its 12-20mbps down and 4-5mbps up on the 2600 band. Can only get 10/10 on the 1800 band at like 5am otherwise it's saturated to a 4mbps.

9924872094.png
 
Ping 606ms
Download: 0.03Mbps
Upload: 0.42Mbps

Trying for a month now to get this sorted. 90% 5g coverage but no service.
 
Pretoria, Rietfontein...
rainb-png.899760
 
Anybody using 5g around strand or somerset west area???? How is ur speed looking like?
 
Wow it still running well.

Download speed vary from 200-350Mbps but upload speed have increased quite a bit. Router still at the same place. Now it averages between 20-32Mbps where as before it was like 8-9Mbps.

9978172597.png
 
Last edited:
Download speed vary from 200-350Mbps but upload speed have increased quite a bit. Router still at the same place. Now it averages between 20-32Mbps where as before it was like 8-9Mbps.

9978172597.png
Might it be a closer tower that can increase the upload? We received a tower closer to use and our uploads went from 10mbps to around 40-50 mbps.
 
Might it be a closer tower that can increase the upload? We received a tower closer to use and our uploads went from 10mbps to around 40-50 mbps.

Could be but I haven't noticed any new towers and the towers that are close to me are all pretty far away anyways
 
Screenshot_20200828-235438.png

This has been my experience for the first 2 days on the R250 package. 1km away from the nearest tower.
 
Last edited:
Glen Austin, Midrand

Ping
23ms
Download
4.50Mbps
Upload
0.09Mbps

Don't upload anything with LTE. Took over an hour to upload a 30MB file to Google Drive, and in that time, nothing else worked, the whole line was consumed by the upload. * sigh *
30GB or 30MB?
 
Back
Top