Telkom High Latency and Slow Speed in the Evening

DYreX146

Senior Member
Joined
Nov 14, 2018
Messages
615
Hi everyone, this is my first post on the forum and I created an account just to post this thread.

For over the past year now I have had issues on Telkom in the evenings almost EVERY SINGLE DAY. I have a 10Mbps Capped ADSL line through them which I was only just eligible to get in February this year, as my area couldn't get anything higher than 4Mbps previously, before which I had an Uncapped 4Mbps account through them as well. In mid 2017, when I was still on 4Mbps, I started getting high latency and a lot of the time speeds lower than 1Mbps to most servers in and outside of the country between 6pm and 12am.

What I found extremely odd was that on certain servers it was completely fine and my speeds and latency were perfectly normal. These certain servers were, for example; MWEB Connect (DBN) and TelkomSA (CPT), but would sometimes change depending on the day or time. So for example; I would sometimes get high ping and low speed to Liquid Telecom (JHB) but then I would sometimes get normal ping and speed to it while all the other servers were bad or I would get high ping but normal speed and sometimes I would have high packet loss to certain servers and sometimes I would have no packet loss to others, while some days I won't even have this issue altogether.

This would change randomly to different servers everyday, with having any combination of these speeds, pings and packet loss to any server, leading me to believe that this is some sort of routing issue on Telkom's side. I usually get about 8.8Mbps download on speed tests and about 20ms to JHB, 8ms to DBN and 35ms to CPT (I asked Telkom to put me on fast path), but during the evenings my results usually show less than 1Mbps download and ping between 80-120ms to any of these servers regardless of their location. I also usually have between 5 and 15% packet loss during these times but my upload speed is almost never affected and my outgoing packet loss is always 0.0%. I live in Pietermaritzburg, KZN but I found a thread on the Telkom forum where many other Telkom and non Telkom users from all over the country were describing the EXACT same problems as myself and they also started occurring at the same time that I started experiencing these issues. Here is the link to this thread.

Bear in mind that I am nowhere near my cap limit, neither was I close to my throttle threshold when I had my 4Mbps account. Then in about June or July these problems magically vanished and everything was fine for a month or 2, then in August it went back to the exact same thing as before. Some of my friends also experienced this issue even on different ISPs and in different parts of South Africa but weirdly not always at the same time as me.

I made this thread to help draw attention to these issues that myself and some of my friends have been experiencing on and off for almost a year and a half. I would also like to know if anyone else has also had to deal with the same problems that I have and hopefully someone can provide a solution to, or at least give some clarity on them.

Thank you for your time.
 
Last edited:

xodosman123

Expert Member
Joined
May 30, 2012
Messages
1,505
Do you know the type of Dslam that you are on and the connection mode that it is set at? and all you are talking about is the speed test what is the problem that you are having?

what is the Attenuation and the SNR and sync rate?
 

DYreX146

Senior Member
Joined
Nov 14, 2018
Messages
615
Do you know the type of Dslam that you are on and the connection mode that it is set at? and all you are talking about is the speed test what is the problem that you are having?

what is the Attenuation and the SNR and sync rate?
Well I don't really know anything about my DSLAM other than it is VDSL capable but I live too far away from it to get VDSL but I am using ADSL2+ to connect to it. My SNR has been fine as I usually get 14-15DB and my line attenuation is 35DB, my sync rate is about 10239 down and 1023 up and my max attainable rate is about 15000 down and 1400 up, so everything seems fine on that end. I also don't suspect that it has anything to do with congestion as some nights my speed and latency is completely fine. But mainly my problem is the high latency, low speed and usually high packet loss between 6pm and 12am.
 

dews

Well-Known Member
Joined
Mar 10, 2011
Messages
374
Hi DYreX146m and welcome to the forums.
The problem here i think has to do with capacity on Telkom's side, and not your DSL line. They have an open network (openserve) that supports both DSL and Fiber clients and it seems they have too many subscribers.

I am on their 10mbps home uncapped (openserve fiber) and have the same latency issues you have during some evenings, although i think yours is more severe. I see that the latency can fluctuate and peaks at around 8 to 10pm. From 10pm to 12 it seems to go down again (as people go to sleep) and after 12 its back to normal.

However if I want to game without latency issues during that time, i switch to a free Axxess capped account (2gig) and then my latency is 3ms to battlefield1 servers, where on Telkom it can be anything from 50 to 150ms to the same servers.

Try to get a free adsl test account and switch to it.
I suggest you try out Vox Telecoms Fatpipe accounts if they go on special again, and ditch Telkom. Those are the best ADSL capped packages that you can get by far. But if there is a DSL congestion issue where you stay, then changing ISP will not help much, unfortunately.
 
Last edited:

DYreX146

Senior Member
Joined
Nov 14, 2018
Messages
615
Hi DYreX146m and welcome to the forums.
The problem here i think has to do with capacity on Telkom's side, and not your DSL line. They have an open network (openserve) that supports both DSL and Fiber clients and it seems they have too many subscribers.

I am on their 10mbps home uncapped (openserve fiber) and have the same latency issues you have during some evenings, although i think yours is more severe. I see that the latency can fluctuate and peaks at around 8 to 10pm. From 10pm to 12 it seems to go down again (as people go to sleep) and after 12 its back to normal.

However if I want to game without latency issues during that time, i switch to a free Axxess capped account (2gig) and then my latency is 3ms to battlefield1 servers, where on Telkom it can be anything from 50 to 150ms to the same servers.

To summarize this is only an issue with Telkom's network. I suggest you try out Vox Telecoms Fatpipe accounts if they go on special again, and ditch Telkom. Those are the best ADSL capped packages that you can get by far.
Hi @dews thanks for the welcome :).

It would make a lot of sense because I know some people that are even on 200Mbps Openserve fibre that also sometimes experience the same issues that I describe. My friend also once tried using an account from I think Crystal Web and then the problems immediately stopped, his ping was about 40 but it was still much more playable than 100. I play a lot of CS:GO and our team played in first division in DGL but ever since these issues started occurring I've stopped even trying anymore.

I've been waiting for any news of fibre in our area for a few months now since Openserve said that they were going to install but I feel that those were just false promises. If I could get fibre I would jump ship straight away to Cool Ideas but I've basically given up any hope of that happening.

Thanks for the suggestions and this is kinda what I suspected all along, but its sad that there is no real solution to this and that we just have to deal with it because I feel that switching from Telkom is probably gonna cause more issues than its worth. I will definitely now look into getting a small account from another ISP when I want to play during the evening.
 
Top