Telkom Mobile Speed, Disconnections & Coverage Problems – click here first!

BandwidthAddict

Expert Member
Joined
Apr 19, 2005
Messages
2,272
I'm suffering with Telkom LTE in Umhlanga. For the last few weeks I have mostly been getting sub Mbps download speeds. My upload speeds, on the other hand, never been faster. Did a speed test to Spain for international:
1592751129422.png
2nd later attempt https://www.speedtest.net/result/9640825781
1592754288051.png

I see this speed all day and all night.

My local speed to Durban is as follows: https://www.speedtest.net/result/9640648636
1592751248489.png

My speed test using the Google and Ookla speed test:
1592751420813.png
1592751803387.png
1592752074096.png
I was expecting same speed as Durban but apparently this is not the case although Afrihost is better.

Notice the shape of the graph. It definitely looks like some kind of shaping going on here.

For comparison, I have an MTN LTE account as well.
1592753936626.png
1592753949116.png
1592753957924.png

Is there any way to resolve this without having to ditch Telkom LTE? I can't get landline without moving.
 

BandwidthAddict

Expert Member
Joined
Apr 19, 2005
Messages
2,272
Spoke with Telkom call centre. They say the problem is with their servers and that they are addressing the problem. Hopefully my issue is resolved soon.
 

KingLv

Well-Known Member
Joined
Dec 12, 2007
Messages
413
I'm also having issues with LTE speeds being under 1Mbps. What's going on with Telkom. In Cape Town.
Is this a national problem?
 

ginzu

Active Member
Joined
Feb 9, 2006
Messages
36
No LTE-A signal anymore, 4G & 3G never go beyond 1 bar, speeds are dismal since last week, in Lenasia. What's going on Telkom. :crying::crying:
 
Top