Web Squad does in 3 hours what Bitco can't do in 2+ weeks

FrikVirNRuk

Member
Joined
Jul 10, 2020
Messages
12
I moved into a house with an existing Vumatel fibre line and applied for internet at Bitco.

Turns out (more than a week later) that the line was still assigned to the previous occupants' ISP (CISP), they helped me out by terminating the line with Vumatel (it did take 3 days to get the termination reference, but that's neither here nor there).

Gave the termination reference to Bitco and it has been stuck in limbo since, with me having to follow up with them daily otherwise I hear nothing, and the feedback being that they are waiting on Vumatel to sort something out.

Finally decided this morning enough of that, told Bitco to cancel the application and @websquadza got their accounts dept (Sherrelle) to call me. Sent them all of the paperwork at 10:30 this morning.

Miraculously, 2.5h later at 1pm I'm connected! This after Bitco "couldn't do anything because it is stuck at Vumatel".

So thanks @websquadza I was really dreading another weekend without internet!
 

PBCool

Cool Ideas
Company Rep
Joined
Jan 11, 2016
Messages
11,565
This happens when there is a process called premise creation required by Vumatel, just means a certain ISP wasn't following up on said process with Vumatel, either way great that you're up and running.
 
Last edited:

FrikVirNRuk

Member
Joined
Jul 10, 2020
Messages
12
This happens when there is a process called premise creation required by Vumatel, just means a certain ISP wasn't following up on the process with Vumatel, either way great that you're up and running.

Exactly, there was zero inclination from Bitco to get the matter resolved, from my perspective at least it was a response of "well we've sent it to Vumatel what more do you want us to do"?

As a consumer I can't care less about Vumatel's processes as I can't deal with them, it's up to the ISP to take ownership of the matter and get it resolved.
 

chrisc

Honorary Master
Joined
Aug 14, 2008
Messages
10,399
Friend in Claremont has Telkom fibre via Openserve
Service stopped on 12th April, Telkom say "Fibre Fault". Duly reported. Nothing fixed although they receive SMS saying it is fixed
Now been reported 9 times
So she approaches Mweb. They send along Octotel. Box is on opposite pavement, so they want R6700 to connect but must get permission from Council to dig up road
Mweb cannot get Openserve to terminate the service as Telkom maintain it is up and running
Octotel sent along a tech, there is no signal from Openserve's fibre
Octotel fellow has a big row on the phone with Telkom, who tell him he does not know what he is doing
100% fail from everybody
 

BitCo

BitCo representative
Company Rep
Joined
Sep 21, 2012
Messages
504
I moved into a house with an existing Vumatel fibre line and applied for internet at Bitco.

Turns out (more than a week later) that the line was still assigned to the previous occupants' ISP (CISP), they helped me out by terminating the line with Vumatel (it did take 3 days to get the termination reference, but that's neither here nor there).

Gave the termination reference to Bitco and it has been stuck in limbo since, with me having to follow up with them daily otherwise I hear nothing, and the feedback being that they are waiting on Vumatel to sort something out.

Finally decided this morning enough of that, told Bitco to cancel the application and @websquadza got their accounts dept (Sherrelle) to call me. Sent them all of the paperwork at 10:30 this morning.

Miraculously, 2.5h later at 1pm I'm connected! This after Bitco "couldn't do anything because it is stuck at Vumatel".

So thanks @websquadza I was really dreading another weekend without internet!

Good day,

We are following this forum and would like to investigate. We would like to fully understand what occurred so that we can provide further feedback and to clarify the situation. We are unable to determine your name and order by your forum name FrikVirNRuk. Please could you assist in providing us with your name. Thank you.

Regards,

The BitCo Team.
 

websquadza

WebSquad
Company Rep
Joined
Mar 26, 2018
Messages
2,843
I moved into a house with an existing Vumatel fibre line and applied for internet at Bitco.

Turns out (more than a week later) that the line was still assigned to the previous occupants' ISP (CISP), they helped me out by terminating the line with Vumatel (it did take 3 days to get the termination reference, but that's neither here nor there).

Gave the termination reference to Bitco and it has been stuck in limbo since, with me having to follow up with them daily otherwise I hear nothing, and the feedback being that they are waiting on Vumatel to sort something out.

Finally decided this morning enough of that, told Bitco to cancel the application and @websquadza got their accounts dept (Sherrelle) to call me. Sent them all of the paperwork at 10:30 this morning.

Miraculously, 2.5h later at 1pm I'm connected! This after Bitco "couldn't do anything because it is stuck at Vumatel".

So thanks @websquadza I was really dreading another weekend without internet!

Thank you for the great feedback, we really appreciate it. It's great to hear you're up and running before the weekend! Welcome to Web sQuad!
 

AfriNatic

Afrihost Rep
Staff member
Joined
Nov 18, 2016
Messages
6,284
Unfortunately premises creation is not a click and done in 5min thing. As Afrihost we understand the frustration and inconvenience caused by the end user but we always give our best! :) Glad you are up and running @FrikVirNRuk
 

websquadza

WebSquad
Company Rep
Joined
Mar 26, 2018
Messages
2,843
Unfortunately premises creation is not a click and done in 5min thing. As Afrihost we understand the frustration and inconvenience caused by the end user but we always give our best! :) Glad you are up and running @FrikVirNRuk
This happens when there is a process called premise creation required by Vumatel, just means a certain ISP wasn't following up on said process with Vumatel, either way great that you're up and running.

Yeah, premise creation can be an issue when it comes up - we've all got bald patches pulling our hair out with some of Vumatel's systems on that end:laugh:. But this wasn't that, it actually turned out to be an easier resolution, and a little persistence from our service delivery team had @FrikVirNRuk sorted in no time.
 
Top