'Windows cannot access the specified device, path, or file'

butc8

Well-Known Member
Joined
Dec 22, 2005
Messages
406
When I try and run most .exe files except a few programs like firefox, windows media player etc I get this error http://s597.photobucket.com/albums/tt52/cheesebreath_bucket/?action=view&current=error.jpg.

I am the administrator and could play the night before after a restart the problem showed up. I can run them in safe mode but thats pointless for running games :/


Right-clicking and clicking run as administrator doesn't help.


I seriously need help,

Thank you,
Billy
 

butc8

Well-Known Member
Joined
Dec 22, 2005
Messages
406
Spent hours googling it, nothing I could find helped.

:(
 

Amplifier

Active Member
Joined
Apr 19, 2008
Messages
63
Log on as an administrator
You must be logged on to Windows as an administrator in order to change security permissions for a file or a folder. If the computer is your personal computer, you are likely already logged on with an administrator account. If the computer is part of a network at work, you might have to ask the system administrator for help. To verify that you are logged on to Windows with a user account that is a computer administrator, visit the following Microsoft Web site:
http://support.microsoft.com/gp/admin (http://support.microsoft.com/gp/admin)
Start Windows XP Home Edition in safe mode
If you are running Windows XP Home Edition, you must start the computer in safe mode, and then log on with an account that has administrative rights in order to access the Security tab. Access to the Security tab is required in order to change security permission. If you are running Windows XP Professional, you do not have to start the computer in safe mode. For more information about how to start Windows XP in safe mode, click the following article number to view the article in the Microsoft Knowledge Base:
304449 (http://support.microsoft.com/kb/304449/ ) How to start the System Restore tool at a command prompt in Windows XP
Disable Simple File Sharing in Windows XP Professional
If you are using Windows XP Professional, you must disable Simple File Sharing. By default, Windows XP Professional uses Simple File Sharing when it is not joined to a domain. For additional information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
307874 (http://support.microsoft.com/kb/307874/ ) How to disable simplified sharing and set permissions on a shared folder in Windows XP
Back to the top
To take ownership of a file or a folder
How to take ownership of a file
You must have ownership of a protected file in order to access it. If another user has restricted access and you are the computer administrator, you can access the file by taking ownership.

To take ownership of a file, follow these steps:

1. Right-click the file that you want to take ownership of, and then click Properties.
2. Click the Security tab, and then click OK on the Security message (if one appears).
3. Click Advanced, and then click the Owner tab.
4. In the Name list, click Administrator, or click the Administrators group, and then click OK.

The administrator or the administrators group now owns the file.

To change the permissions on the file that you now own, follow these steps:

1. Click Add.
2. In the Enter the object names to select (examples) list, type the user or group account that you want to have access to the file. For example, type Administrator.
3. Click OK.
4. In the Group or user names list, click the account that you want, and then select the check boxes of the permissions that you want to assign that user.
5. When you are finished assigning permissions, click OK.
6. You can now access the file.

How to take ownership of a folder
You must have ownership of a protected folder in order to access it. If another user has restricted access and you are the computer administrator, you can access the folder by taking ownership.

To take ownership of a folder, follow these steps:

1. Right-click the folder that you want to take ownership of, and then click Properties.
2. Click the Security tab, and then click OK on the Security message (if one appears).
3. Click Advanced, and then click the Owner tab.
4. In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of the folder, select the Replace owner on subcontainers and objects check box.
5. Click OK, and then click Yes when you receive the following message:
You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
All permissions will be replaced if you click Yes.

Note folder name is the name of the folder that you want to take ownership of.
6. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

Link:http://support.microsoft.com/?kbid=308421

I too had this problem a long time ago
 

butc8

Well-Known Member
Joined
Dec 22, 2005
Messages
406
@Amplifier: Already took ownership and have permissions guess thats not the problem.
Thanks though.

@killadoob: I'll download another AV (there goes my cap :p).
The game is loaded have had it for a couple of months now, just the first random .exe I clicked on.
 

gregmcc

Honorary Master
Joined
Jun 29, 2006
Messages
23,422
If you still have the suspect EXE upload it to virustotal and see that they say.
 

butc8

Well-Known Member
Joined
Dec 22, 2005
Messages
406
I dont think there was any specific .exe that caused it..... they just the ones affected :(
 

Conradl

Expert Member
Joined
Dec 10, 2008
Messages
2,630
Working path buggered?? What is the result if you type "SET", from a command prompt (post the output here)?? Safe mode will not set the path, and could be the reason why it works in safe mode....

Does the exe work if you run it from a shortcut?
 

butc8

Well-Known Member
Joined
Dec 22, 2005
Messages
406
Thanks a lot mate, with Process Explorer I found what was killing the permissions.
A firewall that I stopped from automatically starting up on boot, it blocked everything that was not on its trusted list. :)

Thanks :D
 
Top