<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<meta property="fb:app_id" content="297975627065497"/>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mybroadband">
<meta property="og:url" content="https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html"> <meta property="og:image" content="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale.jpg">
<meta name="twitter:image" content="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale.jpg">
<meta property="og:description" content="Tech and gadget specials are running until 24 December at many local retailers, aimed at those who have not finished their Christmas shopping.">
<meta name="twitter:description" content="Tech and gadget specials are running until 24 December at many local retailers, aimed at those who have not finished their Christmas shopping.">
<meta property="og:title" content="Last-minute Christmas tech deals">
<meta property="og:type" content="article">
<meta name="twitter:title" content="Last-minute Christmas tech deals ">
<script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@type": "NewsArticle",
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html"
          },
          "headline": "Last-minute Christmas tech deals",
          "image": {
            "@type": "ImageObject",
            "url": "https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale.jpg",
            "height": 468,
            "width": 696
          },
          "datePublished": "23 December 2016",
          "dateModified": "23 December 2016",
          "author": {
            "@type": "Person",
            "name": "Staff Writer"
          },
           "publisher": {
            "@type": "Organization",
            "name": "MyBroadband",
            "logo": {
              "@type": "ImageObject",
              "url": "https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/img/logo.png"
            }
          },
          "description": "Tech and gadget specials are running until 24 December at many local retailers, aimed at those who have not finished their Christmas shopping."
        }
        </script>
<meta name="viewport" content="width=device-width, user-scalable=no">
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Last-minute Christmas tech deals</title>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Feed" href="https://mybroadband.co.za/news/feed"/>
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Comments Feed" href="https://mybroadband.co.za/news/comments/feed"/>
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Last-minute Christmas tech deals Comments Feed" href="https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html/feed"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mybroadband.co.za\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='wp-polls-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.2' type='text/css' media='all'/>
<style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background:#CC0000;border:1px solid #CC0000;}</style>
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/font-awesome/css/font-awesome.min.css?ver=3.4.1' type='text/css' media='all'/>
<link rel='stylesheet' id='cyclops-style-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/style.css?ver=4.7' type='text/css' media='all'/>
<!--[if lt IE 10]>
<link rel='stylesheet' id='cyclops-ie-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='cyclops-ie8-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='cyclops-ie7-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='slb_core-css' href='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all'/>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","top_ten_nonce":"0b777ce253","top_ten_id":"192274","top_ten_blog_id":"1","activate_counter":"11","tptn_rnd":"1440721127"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/top-10/includes/js/top-10-tracker.js?ver=4.7'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://mybroadband.co.za/news/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mybroadband.co.za/news/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mybroadband.co.za/news/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Netflix overtakes ShowMax in South Africa' href='https://mybroadband.co.za/news/broadcasting/192278-netflix-overtakes-showmax-in-south-africa.html'/>
<link rel='next' title='Lucozade SA’s groundbreaking digital refrigeration creates an exciting connection with shoppers' href='https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html'/>
<meta name="generator" content="WordPress 4.7"/>
<link rel='shortlink' href='https://mybroadband.co.za/news/?p=192274'/>
<link rel="alternate" type="application/json+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Fgadgets%2F192274-last-minute-christmas-tech-deals.html"/>
<link rel="alternate" type="text/xml+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Fgadgets%2F192274-last-minute-christmas-tech-deals.html&#038;format=xml"/>
<link rel="publisher" href="https://plus.google.com/118183820176218790541"/>
 
<meta name="keywords" content="Christmas,Headline,tech deals,Gadgets"/>
<meta name="description" content="Tech and gadget specials are running until 24 December at many local retailers, aimed at those who have not finished their Christmas shopping."/>
 
</head>
<body class="post-template-default single single-post postid-192274 single-format-standard group-blog no-sidebar">
 
 
<script type="text/javascript">
        (function() {
               var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
               em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
               var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
        })();
</script>
<noscript>
<img src="//za.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;"/>
</noscript>
  
<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
 
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
 
  return t;
}(document, "script", "twitter-wjs"));</script>
<script src="https://apis.google.com/js/platform.js" async defer></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=297975627065497";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
 <div id="page" class="site">
<div class="site-inner">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
<div class="top-bar">
<div class="top-subscribe">
<form style="float:right;" action='//newsletters.mybroadband.co.za/proc.php' method='post' accept-charset='utf-8' enctype='multipart/form-data' onsubmit="target_popup(this)">
<input type='hidden' name='f' value='1143'>
<input type='hidden' name='s' value=''>
<input type='hidden' name='c' value='0'>
<input type='hidden' name='m' value='0'>
<input type='hidden' name='act' value='sub'>
<input type='hidden' name='nlbox[]' value='11'>
<div class='_form'>
<div class='_field _type_input'>
<div class='_option'>
<input class="subscribe-text" type='email' name='email' placeholder="Email address for newsletter subscription">
<input class="subscribe-submit" type='submit' value='Subscribe'>
</div>
</div>
</div>
</form>
</div>
<div class="top-social-links">
Follow us
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://plus.google.com/+mybroadbandlive"><i class="fa fa-google-plus" aria-hidden="true"></i></a>
<a target="_blank" href="http://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
</div>
<div style="clear:both;"></div>
</div>
<div class="site-header-main">
<div class="site-branding">
<p class="site-title"><a href="https://mybroadband.co.za/news/" rel="home">MyBroadband</a></p>
<a class="logo" href="https://mybroadband.co.za/news">
<img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/img/logo.png" alt="logo"/>
</a>
<div class="header_ad">
<div class="ad"><iframe id='a06ba354' name='a06ba354' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=145&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='728' height='90'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=a348a90b&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=145&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a348a90b' border='0' alt=''/></a></iframe></div> </div>
<div style="clear:both;"></div>
</div> 
<nav class="menu">
<ul>
<li><a class="categories-menu" href="https://mybroadband.co.za/news/">News</a></li>
<li><a class="press-office-menu" href="http://companies.mybroadband.co.za/">Press office</a></li>
<li><a class="no-sub-menu" href="/vb/forumdisplay.php/131-News-and-Current-Affairs">Breaking news</a></li>
<li><a class="no-sub-menu" href="/vb">Forum</a></li>
<li><a class="no-sub-menu" href="/vb/forumdisplay.php/162-Classifieds-For-Sale">Classifieds</a></li>
<li><a class="no-sub-menu" href="/news/industrynews">Industry news</a></li>
<li><a class="no-sub-menu" href="http://deals.mybroadband.co.za/">Deals</a></li>
<li><a class="no-sub-menu" href="http://speedtest.mybroadband.co.za/">Speed test</a></li>
<li><a class="search-menu" href="#"><i class="fa fa-search" aria-hidden="true"></i></a></li>
</ul>
</nav>
<div class="categories-sub-menu sub-menu">
<ul>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/columns">Columns</a></li>
</ul>
<ul>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/gaming">Gaming</a></li>
<li><a href="/news/general">General</a></li>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/hardware">Hardware</a></li>
</ul>
<ul>
<li><a href="/news/hosting-storage">Hosting &amp; Storage</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/internet">Internet</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/quizzes">Quizzes</a></li>
<li><a href="/news/reviews">Reviews</a></li>
<li><a href="/news/science">Science</a></li>
</ul>
<ul>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/wireless">Wireless</a></li>
</ul>
</div>
<div class="press-office-sub-menu sub-menu">
<ul>
<li><a href="//companies.mybroadband.co.za/1stream/">1Stream</a></li>
<li><a href="//companies.mybroadband.co.za/arbornetworks/">Arbor Networks</a></li>
<li><a href="//companies.mybroadband.co.za/asus/">Asus</a></li>
<li><a href="//companies.mybroadband.co.za/bidvest-facilities-management/">Bidvest</a></li>
<li><a href="//companies.mybroadband.co.za/brother/">Brother</a></li>
<li><a href="//companies.mybroadband.co.za/businessconnexion/">Business Connexion</a></li>
<li><a href="//companies.mybroadband.co.za/cipherwave/">CipherWave</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/commvault/">CommVault</a></li>
<li><a href="//companies.mybroadband.co.za/connectiontelecomsgroup/">Connection Telecom</a></li>
<li><a href="//companies.mybroadband.co.za/continuitysa/">ContinuitySA</a></li>
<li><a href="//companies.mybroadband.co.za/dlink/">D-Link</a></li>
<li><a href="//companies.mybroadband.co.za/dvt/">DVT</a></li>
<li><a href="//companies.mybroadband.co.za/eoh-ns/">EOH Network Solutions</a></li>
<li><a href="//companies.mybroadband.co.za/epson/">Epson</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/euphoria/">Euphoria</a></li>
<li><a href="//companies.mybroadband.co.za/hitachidatasystems/">Hitachi Data Systems</a></li>
<li><a href="//companies.mybroadband.co.za/huawei/">Huawei</a></li>
<li><a href="//companies.mybroadband.co.za/ideco/">Ideco</a></li>
<li><a href="//companies.mybroadband.co.za/lg/">LG</a></li>
<li><a href="//companies.mybroadband.co.za/masterdatamanagement/">Master Data Management</a></li>
<li><a href="//companies.mybroadband.co.za/nebula/">Nebula</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/netshield/">Netshield</a></li>
<li><a href="//companies.mybroadband.co.za/networkplatforms/">Network Platforms</a></li>
<li><a href="//companies.mybroadband.co.za/otel/">OTEL Telecoms</a></li>
<li><a href="//companies.mybroadband.co.za/robinson-distribution/">Robinson Distribution</a></li>
<li><a href="//companies.mybroadband.co.za/sabinet/">Sabinet</a></li>
<li><a href="//companies.mybroadband.co.za/syntech/">Syntech</a></li>
<li><a href="//companies.mybroadband.co.za/telviva/">Telviva</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/touchvision/">TouchVision</a></li>
<li><a href="//companies.mybroadband.co.za/veeam/">Veeam</a></li>
<li><a href="//companies.mybroadband.co.za/vmware/">VMWare</a></li>
<li><a href="//companies.mybroadband.co.za/westcon/">Westcon</a></li>
<li><a href="//companies.mybroadband.co.za/xdsl/">XDSL</a></li>
</ul>
</div>
<div class="search-sub-menu sub-menu">
<form role="search" method="get" id="searchform" action="https://mybroadband.co.za/news/">
<div>
<input type="text" class="nav-search-bar" value="" name="s" id="s" placeholder="Search"/><input style="display:none;" type="submit" value=""/>
</div>
</form>
</div>
</div> 
<div class="mobile-site-header">
<a href="https://mybroadband.co.za/news/" class="mobile-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/img/bar-logo.png?v=1.0" alt="logo"/></a>
<div class="mobile-bar-share">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Last-minute+Christmas+tech+deals https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="googleplus-share" href="javascript:popup('https://plus.google.com/share?url=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-google-plus" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#77480402151d1214034a3b1604035a1a1e19020312524547341f051e04031a16045245470312141f5245471312161b04511518130e4a2312141f5245471619135245X0gadget%20specials%20are%20running%20until%2024%20December%20at%20many%20local%20retailers%2C%20aimed%20at%20those%20who%20have%20not%20finished%20their%20Christmas%20shopping.%0A%0Ahttps%3A%2F%2Fmybroadband.co.za%2Fnews%2Fgadgets%2F192274-last-minute-christmas-tech-deals.html">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
</div>
<div class="mobile-search-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<div class="mobile-menu-button"><i class="fa fa-bars" aria-hidden="true"></i></div>
</div>
<div class="mobile-search-bar">
<div class="search-bar-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<form action="/" method="get">
<input placeholder="What are you looking for?" type="text" name="s" id="search" value=""/>
</form>
<div class="search-bar-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
<div class="mobile-menu">
<ul>
<li><a href="https://mybroadband.co.za/news/">Home</a></li>
<li><a class="mobile-expand" href="#">
Categories
<i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i>
</a>
<ul>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/wireless">Wireless</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/internet">Internet</a></li>
</ul>
</li>
<li><a href="http://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/vb/forumdisplay.php/131-News-and-Current-Affairs">Breaking News</a></li>
<li><a href="/vb">Forum</a></li>
<li><a href="/vb/forumdisplay.php/162-Classifieds-For-Sale">Classifieds</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="http://deals.mybroadband.co.za/">Deals</a></li>
<li><a href="http://speedtest.mybroadband.co.za/">Speed Test</a></li>
<li><a class="mobile-expand" href="#">
About
<i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i>
</a>
<ul>
<li><a href="/news/about-us">About Us</a></li>
<li><a href="/news/advertising">Advertising</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/careers">Careers</a></li>
</ul>
</li>
</ul>
</div>
<div class="mobile-overlay">
<div class="mobile-menu-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
</header> 
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<div class="the-post">
<article id="post-192274" class="post-192274 post type-post status-publish format-standard has-post-thumbnail hentry category-gadgets tag-christmas tag-headline tag-tech-deals">
<header class="entry-header">
<h1 class="entry-title article-title">Last-minute Christmas tech deals</h1> <div class="article-meta"><span class="vcard author post-author"><span class="fn"><a href="https://mybroadband.co.za/news/author/staff-writer" title="Posts by Staff Writer" rel="author">Staff Writer</a></span></span><span class="post-date updated">23 December 2016</span><a id="open_disqus_thread" href="https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html#disqus_thread"></a></div>
</header> 
<a class="post-thumbnail" href="https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Last-minute Christmas tech deals" srcset="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2015/06/Deals-Sale-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<div class="social-section">
<form class="article-newsletter" action='//newsletters.mybroadband.co.za/proc.php' method='post' accept-charset='utf-8' enctype='multipart/form-data' onsubmit="target_popup(this)">
<input type='hidden' name='f' value='1143'>
<input type='hidden' name='s' value=''>
<input type='hidden' name='c' value='0'>
<input type='hidden' name='m' value='0'>
<input type='hidden' name='act' value='sub'>
<input type='hidden' name='nlbox[]' value='11'>
<div class='_form'>
<div class='_field _type_input'>
<div class='_option'>
<div style="float:right">
<input class="subscribe-submit" type='submit' value='Subscribe'>
</div>
<div style="width: auto; overflow: hidden; margin-left: 10px;">
<input class="subscribe-text" type='email' name='email' placeholder="Email address">
</div>
</div>
</div>
</div>
</form>
<div>
<div class="counter" style="color: #333; float: left; text-align: center; border-right: solid 1px #efefef; padding-right: 12px;">
<div class="number">
8 </div>
<div class="share-text">
shares
</div>
</div>
<div class="article-share-buttons" style="display:inline-block;">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Last-minute+Christmas+tech+deals https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="googleplus-share" href="javascript:popup('https://plus.google.com/share?url=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-google-plus" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#fec18d8b9c949b9d8ac3b29f8d8ad39397908b8a9bdbcccebd968c978d8a939f8ddbccce8a9b9d96dbccce9a9b9f928dd89c919a87c3aa9b9d96dbccce9f909adbccX0gadget%20specials%20are%20running%20until%2024%20December%20at%20many%20local%20retailers%2C%20aimed%20at%20those%20who%20have%20not%20finished%20their%20Christmas%20shopping.%0A%0Ahttps%3A%2F%2Fmybroadband.co.za%2Fnews%2Fgadgets%2F192274-last-minute-christmas-tech-deals.html">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
</div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
<div class="entry-content">
<p>Go visit your family, they said. It will be fun, they said.</p>
<p>They lied.</p>
<p>I am in Durban, it is about 42 degrees with 100% humidity, and doing anything besides lying next to a fan on a tiled floor is torture.</p>
<p>Why did people inhabit this area? Who stopped here, spent the summer, and said: &#8220;You know what, I enjoy my back sticking to chairs when I sit down, let&#8217;s make this place home.</p>
<p>And now I must go shopping for Christmas presents? Forget it.</p>
<p>For those living in Joburg, Cape Town, and anywhere not along the coast of KwaZulu-Natal, here are some tech deals to fill the stockings.</p>
<p>For those on the east coast, enjoy your upcoming midday nap.</p>
<hr/>
<h3>Canon Printer from Makro &#8211; R999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-printer.jpg" data-slb-active="1" data-slb-asset="304400920" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192304" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-printer.jpg" alt="Canon printer" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-printer.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-printer-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-printer-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Dell Notebook from Makro &#8211; R9,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-Notebook.jpg" data-slb-active="1" data-slb-asset="1408449044" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192306" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-Notebook.jpg" alt="Dell Notebook" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-Notebook.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-Notebook-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-Notebook-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>PlayStation 4 Pro from Makro &#8211; R6,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-Pro.jpg" data-slb-active="1" data-slb-asset="1985584712" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192308" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-Pro.jpg" alt="PS4 Pro" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-Pro.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-Pro-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-Pro-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Sinotec 55&#8243; UHD TV from Makro &#8211; R7,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Sinotec-TV.jpg" data-slb-active="1" data-slb-asset="320337963" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192310" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Sinotec-TV.jpg" alt="Sinotec TV" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sinotec-TV.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sinotec-TV-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sinotec-TV-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Canon DSLR Bundle from Game &#8211; R4,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-DSLR-bundle.jpg" data-slb-active="1" data-slb-asset="1504792961" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192314" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-DSLR-bundle.jpg" alt="Canon DSLR bundle" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-DSLR-bundle.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-DSLR-bundle-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-DSLR-bundle-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Dell 24&#8243; Monitor from Game &#8211; R2,299</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-monitor.jpg" data-slb-active="1" data-slb-asset="2033515229" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192316" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-monitor.jpg" alt="Dell monitor" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-monitor.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-monitor-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Dell-monitor-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Fitbit Bands from Game &#8211; R1,199 &#8211; R2,499</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Fitbit-bands.jpg" data-slb-active="1" data-slb-asset="47861267" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192318" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Fitbit-bands.jpg" alt="" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Fitbit-bands.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Fitbit-bands-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Fitbit-bands-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>GoPro Hero from Game &#8211; R2,299</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/GoPro.jpg" data-slb-active="1" data-slb-asset="68093499" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192320" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/GoPro.jpg" alt="GoPro" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/GoPro.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/GoPro-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/GoPro-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Samsung Tablets from Game &#8211; R1,999 &#8211; R2,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-tablets.jpg" data-slb-active="1" data-slb-asset="942095288" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192322" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-tablets.jpg" alt="Samsung tablets" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-tablets.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-tablets-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-tablets-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Seagate Drives from Game &#8211; R799 &#8211; R1,699</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Seagate-drives.jpg" data-slb-active="1" data-slb-asset="1661814967" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192324" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Seagate-drives.jpg" alt="Seagate drives" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Seagate-drives.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Seagate-drives-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Seagate-drives-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Xbox One Bundle from Game &#8211; R3,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Xbox-One-3.jpg" data-slb-active="1" data-slb-asset="972727288" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192326" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Xbox-One-3.jpg" alt="Xbox One" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Xbox-One-3.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Xbox-One-3-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Xbox-One-3-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Blackweb Tablet from Dion Wired &#8211; R990</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/BW-tablet.jpg" data-slb-active="1" data-slb-asset="335385851" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192328" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/BW-tablet.jpg" alt="BW tablet" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/BW-tablet.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/BW-tablet-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/BW-tablet-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Canon DSLR Bundle from Dion Wired &#8211; R9,990</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-Bundle-1.jpg" data-slb-active="1" data-slb-asset="959505813" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192330" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-Bundle-1.jpg" alt="Canon Bundle" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-Bundle-1.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-Bundle-1-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Canon-Bundle-1-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Lenovo Notebook from Dion Wired &#8211; R5,990</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Laptop.jpg" data-slb-active="1" data-slb-asset="1071120834" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192332" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Laptop.jpg" alt="" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Laptop.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Laptop-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Laptop-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>PlayStation 4 Slim from Dion Wired &#8211; R3,990</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-4.jpg" data-slb-active="1" data-slb-asset="1237151227" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192334" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-4.jpg" alt="PS4" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-4.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-4-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/PS4-4-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Samsung 55&#8243; UHD Curved TV from Dion Wired &#8211; R17,990</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-55-TV.jpg" data-slb-active="1" data-slb-asset="324724244" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192336" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-55-TV.jpg" alt="Samsung 55 TV" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-55-TV.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-55-TV-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-55-TV-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Samsung Earbuds from Dion Wired &#8211; R2,690</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/SWamsun-earbuds.jpg" data-slb-active="1" data-slb-asset="332020180" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192338" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/SWamsun-earbuds.jpg" alt="Samsung earbuds" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/SWamsun-earbuds.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/SWamsun-earbuds-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/SWamsun-earbuds-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Asus Notebook from HiFi Corp &#8211; R5,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Asus-notebook.jpg" data-slb-active="1" data-slb-asset="1082594118" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192340" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Asus-notebook.jpg" alt="Asus notebook" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Asus-notebook.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Asus-notebook-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Asus-notebook-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>DStv Decoders from HiFi Corp &#8211; R299 &#8211; R599</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/DStv-decoders.jpg" data-slb-active="1" data-slb-asset="1218062268" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192342" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/DStv-decoders.jpg" alt="DStv decoders" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/DStv-decoders.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/DStv-decoders-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/DStv-decoders-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Hisense Smartphone from HiFi Corp &#8211; R599</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/HiSense-smartphone.jpg" data-slb-active="1" data-slb-asset="1250295083" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192344" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/HiSense-smartphone.jpg" alt="HiSense smartphone" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/HiSense-smartphone.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/HiSense-smartphone-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/HiSense-smartphone-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>JBL Headphones from HiFi Corp &#8211; R449 &#8211; R899</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-headphones.jpg" data-slb-active="1" data-slb-asset="430288632" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192346" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-headphones.jpg" alt="JBL headphones" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-headphones.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-headphones-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-headphones-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>LG 55&#8243; FHD TV from HiFi Corp &#8211; R9,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-TV.jpg" data-slb-active="1" data-slb-asset="1071767499" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192348" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-TV.jpg" alt="LG TV" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-TV.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-TV-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-TV-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Nikon DSLR Bundle from HiFi Corp &#8211; R5,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Nikin-camera-bundle.jpg" data-slb-active="1" data-slb-asset="2114157184" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192350" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Nikin-camera-bundle.jpg" alt="Nikon camera bundle" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Nikin-camera-bundle.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Nikin-camera-bundle-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Nikin-camera-bundle-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Samsung 40&#8243; FHD TV Bundle from HiFi Corp  &#8211; R4,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-TV-decoder.jpg" data-slb-active="1" data-slb-asset="186474629" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192352" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-TV-decoder.jpg" alt="Samsung TV decoder" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-TV-decoder.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-TV-decoder-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Samsung-TV-decoder-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Sansui 40&#8243; FHD TV from HiFi Corp &#8211; R3,999</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Sansui-TV.jpg" data-slb-active="1" data-slb-asset="1094985984" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192354" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Sansui-TV.jpg" alt="Sansui TV" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sansui-TV.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sansui-TV-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Sansui-TV-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Vodacom 10&#8243; Tablet from HiFi Corp &#8211; R1,699</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Vodacom-tab.jpg" data-slb-active="1" data-slb-asset="2279467" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192356" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Vodacom-tab.jpg" alt="Vodacom tab" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Vodacom-tab.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Vodacom-tab-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Vodacom-tab-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>JBL Speaker from Incredible Connection &#8211; R399</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-speakers.jpg" data-slb-active="1" data-slb-asset="1805635363" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192358" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-speakers.jpg" alt="JBL speakers" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-speakers.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-speakers-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/JBL-speakers-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<h3>Razer Peripherals from Incredible Connection &#8211; R399 &#8211; R3,299</h3>
<p><a href="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Razer-peripherals.jpg" data-slb-active="1" data-slb-asset="991086525" data-slb-internal="0" data-slb-group="slb"><img class="aligncenter size-full wp-image-192360" src="http://mybroadband.co.za/news/wp-content/uploads/2016/12/Razer-peripherals.jpg" alt="Razer peripherals" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Razer-peripherals.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Razer-peripherals-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/Razer-peripherals-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px"/></a></p>
<hr/>
<div class="bottom-share">
<a class="bottom-facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');"><i class="fa fa-facebook-official" aria-hidden="true"></i> Share <span class="share-hide">on Facebook</span></a>
<a class="bottom-twitter-share" href="https://twitter.com/intent/tweet/?text=Last-minute+Christmas+tech+deals https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html&via=mybroadband"> <i class="fa fa-twitter" aria-hidden="true"></i> Share <span class="share-hide">on Twitter</span></a>
</div>
</div> 
<footer class="entry-footer">
<div class="tags"><p><span><a href="https://mybroadband.co.za/news/tag/christmas" rel="nofollow tag">Christmas</a> <a href="https://mybroadband.co.za/news/tag/headline" rel="nofollow tag">Headline</a> <a href="https://mybroadband.co.za/news/tag/tech-deals" rel="nofollow tag">tech deals</a></span></p></div>
</footer> 
</article> 
<a href="https://mybroadband.co.za/vb/showthread.php/862218-Last-minute-Christmas-tech-deals-23-Dec-2016" class="forum-link">
<div class="link-forum">
<span class="label"><strong>Share your thoughts: </strong></span>
<span class="forum_click">Last-minute Christmas tech deals</span> <i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
</a>
<div class="ad"><iframe id='a6bf317b' name='a6bf317b' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=1008&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='300' height='250'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=ab0f33c9&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=1008&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=ab0f33c9' border='0' alt=''/></a></iframe></div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Latest news</h2></div>
<div class="below_row_article_container">
<article id="post-191332" class="row_article">
<a href="https://mybroadband.co.za/news/broadband/191332-how-wbs-plans-to-fight-vodacom-and-mtn-in-broadband-market.html" title="How WBS plans to fight Vodacom and MTN in broadband market">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/broadband/191332-how-wbs-plans-to-fight-vodacom-and-mtn-in-broadband-market.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/11/Michael-Jordaan.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="How WBS plans to fight Vodacom and MTN in broadband market" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/broadband/191332-how-wbs-plans-to-fight-vodacom-and-mtn-in-broadband-market.html" rel="bookmark">How WBS plans to fight Vodacom and MTN in broadband market</a></h2> </header> 
</article> 
<article id="post-192252" class="row_article">
<a href="https://mybroadband.co.za/news/broadcasting/192252-how-to-fix-amazon-prime-video-in-south-africa.html" title="How to fix Amazon Prime Video in South Africa">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/broadcasting/192252-how-to-fix-amazon-prime-video-in-south-africa.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/11/Amazon-Prime-Video-on-TV.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="How to fix Amazon Prime Video in South Africa" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/broadcasting/192252-how-to-fix-amazon-prime-video-in-south-africa.html" rel="bookmark">How to fix Amazon Prime Video in South Africa</a></h2> </header> 
</article> 
<article id="post-192302" class="row_article">
<a href="https://mybroadband.co.za/news/energy/192302-eskom-welcomes-constitutional-court-victory-over-westinghouse.html" title="Eskom welcomes Constitutional Court victory over Westinghouse">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/energy/192302-eskom-welcomes-constitutional-court-victory-over-westinghouse.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2015/07/Nuclear-power-station.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Eskom welcomes Constitutional Court victory over Westinghouse" srcset="https://mybroadband.co.za/news/wp-content/uploads/2015/07/Nuclear-power-station.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2015/07/Nuclear-power-station-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/energy/192302-eskom-welcomes-constitutional-court-victory-over-westinghouse.html" rel="bookmark">Eskom welcomes Constitutional Court victory over Westinghouse</a></h2> </header> 
</article> 
<div style="clear:both;"></div>
</div>
</div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Partner Content</h2></div>
<div class="below_row_article_container">
<article id="post-192374" class="row_article">
<a href="https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html" title="Lucozade SA’s groundbreaking digital refrigeration creates an exciting connection with shoppers">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Lucozade-fridge.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Lucozade SA’s groundbreaking digital refrigeration creates an exciting connection with shoppers" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html" rel="bookmark">Lucozade SA’s groundbreaking digital refrigeration creates an exciting connection with shoppers</a></h2> </header> 
</article> 
<article id="post-192386" class="row_article">
<a href="https://mybroadband.co.za/news/industrynews/192386-save-money-when-printing-with-brothers-new-ink-refill-tank-system.html" title="Save money when printing with Brother’s new ink refill tank system">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/192386-save-money-when-printing-with-brothers-new-ink-refill-tank-system.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Brother-International-ink-refill-tank-system.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Save money when printing with Brother’s new ink refill tank system" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/192386-save-money-when-printing-with-brothers-new-ink-refill-tank-system.html" rel="bookmark">Save money when printing with Brother’s new ink refill tank system</a></h2> </header> 
</article> 
<article id="post-192368" class="row_article">
<a href="https://mybroadband.co.za/news/industrynews/192368-behind-seacoms-success-from-the-cable-to-culture.html" title="Behind SEACOM’s success – From the cable to culture">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/192368-behind-seacoms-success-from-the-cable-to-culture.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2016/12/SEACOM-culture.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Behind SEACOM’s success – From the cable to culture" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
</a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/192368-behind-seacoms-success-from-the-cable-to-culture.html" rel="bookmark">Behind SEACOM’s success – From the cable to culture</a></h2> </header> 
</article> 
<div style="clear:both;"></div>
</div>
</div>
<div class="show-comments">Show comments</div>
<div style="display:none;" class="comments">
<div class="box-title"><span class="title-line"></span><h2>Join the conversation</h2></div>
<div class="box-content">
<div id="disqus_thread"></div>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments.</a></noscript>
</div>
</div>
</div>
<div class="single-side">
<div class="ad"><iframe id='a345c73d' name='a345c73d' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=142&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='300' height='250'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=ab1766e1&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=142&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=ab1766e1' border='0' alt=''/></a></iframe></div> <div id="the_poll" class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Poll</h2></div>
<div class="box-content"><div id="polls-1574" class="wp-polls">
<form id="polls_form_1574" class="wp-polls-form" action="/news/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_1574_nonce" name="wp-polls-nonce" value="d8c974028c"/></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="1574"/></p>
<p><strong>Do you have last-minute gift shopping to do?</strong></p><div id="polls-1574-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-4578" name="poll_1574" value="4578"/> <label for="poll-answer-4578">Yes</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-4580" name="poll_1574" value="4580"/> <label for="poll-answer-4580">No</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(1574);"/></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(1574); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-1574-loading" class="wp-polls-loading"><img src="https://mybroadband.co.za/news/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image"/>&nbsp;Loading ...</div>
</div>
</div> <div class="ad"><iframe id='ac38505f' name='ac38505f' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=143&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='300' height='250'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=a6361159&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=143&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a6361159' border='0' alt=''/></a></iframe></div> <div id="the_poll" class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Follow us</h2></div>
<div class="box-content">
<div class="follow-buttons">
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://plus.google.com/+mybroadbandlive"><i class="fa fa-google-plus" aria-hidden="true"></i></a>
<a target="_blank" href="http://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
<div class="follow-subscribe">
<form action="//newsletters.mybroadband.co.za/proc.php" method="post" accept-charset="utf-8" enctype="multipart/form-data" onsubmit="target_popup(this)">
<input type="hidden" name="f" value="1143">
<input type="hidden" name="s" value="">
<input type="hidden" name="c" value="0">
<input type="hidden" name="m" value="0">
<input type="hidden" name="act" value="sub">
<input type="hidden" name="nlbox[]" value="11">
<div class="_form">
<div class="_field _type_input">
<div class="_option">
<input class="subscribe-text" type="email" name="email" placeholder="Sign up for our newsletter">
<input class="subscribe-submit" type="submit" value="Subscribe">
</div>
</div>
</div>
</form>
</div>
</div>
</div> <div class="ad"><iframe id='a12142df' name='a12142df' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=144&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='300' height='250'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=a7ea7190&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=144&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a7ea7190' border='0' alt=''/></a></iframe></div>
<div class="side_feed_article_container">
<div class="box-title"><span class="title-line"></span><h2>Recommended</h2></div>
<article id="post-192390" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/government/192390-how-hlaudi-motsoeneng-used-spies-to-grill-his-enemies-at-the-sabc.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/11/Hlaudi-Motsoeneng.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="How Hlaudi Motsoeneng used spies to grill his enemies at the SABC" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/government/192390-how-hlaudi-motsoeneng-used-spies-to-grill-his-enemies-at-the-sabc.html" rel="bookmark">How Hlaudi Motsoeneng used spies to grill his enemies at the SABC</a></h2> </header> 
<div style="clear:both;"></div>
</article> 
<article id="post-192278" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/broadcasting/192278-netflix-overtakes-showmax-in-south-africa.html" aria-hidden="true">
<img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Netflix overtakes ShowMax in South Africa" srcset="https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/broadcasting/192278-netflix-overtakes-showmax-in-south-africa.html" rel="bookmark">Netflix overtakes ShowMax in South Africa</a></h2> </header> 
<div style="clear:both;"></div>
</article> 
<article id="post-192376" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/smartphones/192376-five-lg-smartphones-launching-at-ces-2017.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-K-series-CES-2017.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Five LG smartphones launching at CES 2017" srcset="https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-K-series-CES-2017.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-K-series-CES-2017-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2016/12/LG-K-series-CES-2017-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/smartphones/192376-five-lg-smartphones-launching-at-ces-2017.html" rel="bookmark">Five LG smartphones launching at CES 2017</a></h2> </header> 
<div style="clear:both;"></div>
</article> 
<article id="post-191784" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/cellular/191784-south-africa-should-not-boast-about-its-mobile-broadband-speeds.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/09/LTE-Speed-Test.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="South Africa should not boast about its mobile broadband speeds" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/cellular/191784-south-africa-should-not-boast-about-its-mobile-broadband-speeds.html" rel="bookmark">South Africa should not boast about its mobile broadband speeds</a></h2> </header> 
<div style="clear:both;"></div>
</article> 
<article id="post-191332" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/broadband/191332-how-wbs-plans-to-fight-vodacom-and-mtn-in-broadband-market.html" aria-hidden="true">
<img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2016/11/Michael-Jordaan.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="How WBS plans to fight Vodacom and MTN in broadband market" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/broadband/191332-how-wbs-plans-to-fight-vodacom-and-mtn-in-broadband-market.html" rel="bookmark">How WBS plans to fight Vodacom and MTN in broadband market</a></h2> </header> 
<div style="clear:both;"></div>
</article> 
<div style="clear:both;"></div>
</div> <div class="ad"><iframe id='a47fddc0' name='a47fddc0' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=876&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='300' height='600'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=a97ccd1d&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=876&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a97ccd1d' border='0' alt=''/></a></iframe></div></div>
<div style="clear:both;"></div>
 
<div class="article-top-bar">
<a href="/news" class="article-top-bar-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/img/bar-logo.png" alt="logo"/></a>
<div class="article-top-bar-share">
Share this article
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#655a1610070f000611582904161148080c0b101100405755260d170c16110804164057551100060d405755010004091643070a011c583100060d405755040b014057X0gadget%20specials%20are%20running%20until%2024%20December%20at%20many%20local%20retailers%2C%20aimed%20at%20those%20who%20have%20not%20finished%20their%20Christmas%20shopping.%0A%0Ahttps%3A%2F%2Fmybroadband.co.za%2Fnews%2Fgadgets%2F192274-last-minute-christmas-tech-deals.html">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="googleplus-share" href="javascript:popup('https://plus.google.com/share?url=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-google-plus" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Last-minute+Christmas+tech+deals https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/gadgets/192274-last-minute-christmas-tech-deals.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<div style="clear:both;"></div>
</div>
<div class="article-top-bar-title">
<span class="line-end"></span>
<div>
Last-minute Christmas tech deals </div>
</div>
<div style="clear:both;"></div>
</div>
 
<div class="next-previous-article">
<div id="next-article">
<div class="next-arrow">
<i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
<div class="next-article-link">
<a class="the-image" href="https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html"><img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2016/12/Lucozade-fridge.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/></a>
<a class="the-text" href="https://mybroadband.co.za/news/industrynews/192374-lucozade-sas-groundbreaking-digital-refrigeration-creates-an-exciting-connection-with-shoppers.html">Lucozade SA’s groundbreaking digital refrigeration creates an exciting connection with shoppers</a>
<span class="next-span">Next article</span>
</div>
</div>
<div id="previous-article">
<div class="previous-arrow">
<i class="fa fa-chevron-left" aria-hidden="true"></i>
</div>
<div class="previous-article-link">
<a class="the-text" href="https://mybroadband.co.za/news/broadcasting/192278-netflix-overtakes-showmax-in-south-africa.html">Netflix overtakes ShowMax in South Africa</a>
<span class="previous-span">Previous article</span>
<a class="the-image" href="https://mybroadband.co.za/news/broadcasting/192278-netflix-overtakes-showmax-in-south-africa.html"><img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="ShowMax vs Netflix" srcset="https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2015/08/ShowMax-vs-Netflix-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px"/></a>
</div>
</div>
</div>
 
</main> 
</div> 
</div> 
</div> 
</div> 
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<div class="footer-sub-menu">
<ul>
<li class="footer-header"><span></span><a href="">Categories</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/motoring">Motoring</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Sections</a></li>
<li><a href="http://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/vb/forumdisplay.php/131-News-and-Current-Affairs">Breaking News</a></li>
<li><a href="/vb/">Forum</a></li>
<li><a href="/vb/search.php?do=getnew&contenttype=vBForum_Post">What's New</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/vb/forumdisplay.php/162-Classifieds">Classifieds</a></li>
<li><a href="http://deals.mybroadband.co.za/">Deals</a></li>
<li><a href="http://speedtest.mybroadband.co.za/">Speed Test</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Information</a></li>
<li><a href="/news/about-us">About</a></li>
<li><a href="/news/advertising">Advertise with us</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/rss-feeds">RSS</a></li>
<li><a href="/MyBroadband-Terms-and-Conditions.pdf">Terms &amp; Conditions</a></li>
<li><a href="/news/notification-of-infringements">Notification of Infringements</a></li>
<li><a href="/news/careers">Careers</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Follow Us</a></li>
<li><a target="_blank" href="https://www.facebook.com/mybroadband/">Facebook</a></li>
<li><a target="_blank" href="http://twitter.com/mybroadband">Twitter</a></li>
<li><a target="_blank" href="https://plus.google.com/+mybroadbandlive">Google+</a></li>
<li><a target="_blank" href="https://www.youtube.com/user/mybroadbandlive">YouTube</a></li>
<li><a target="_blank" href="https://www.instagram.com/mybroadband/">Instagram</a></li>
</ul>
</div>
<div class="mobile-footer-menu">
<ul>
<li class="footer-header"><span></span><a href="">Follow us</a></li>
</ul>
<div class="follow-buttons">
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://plus.google.com/+mybroadbandlive"><i class="fa fa-google-plus" aria-hidden="true"></i></a>
<a target="_blank" href="http://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&amp;hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
</div>
</div> 
</footer> 
<div id="wallpaper_ad" style="position:fixed;overflow:hidden;z-index:8;width:100%;margin-left:auto;margin-right:auto;left:0;right:0;top:0px;height:1080px;">
<div style="position: absolute;left:50%;">
<div style="position: relative;left:-50%;">
<div class="ad"><iframe id='a1b7531c' name='a1b7531c' src='https://display.mybroadband.co.za/31/www/delivery/afr.php?zoneid=146&amp;cb=INSERT_RANDOM_NUMBER_HERE' frameborder='0' scrolling='no' width='1920' height='2000'><a href='https://display.mybroadband.co.za/31/www/delivery/ck.php?n=a51397a2&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='https://display.mybroadband.co.za/31/www/delivery/avw.php?zoneid=146&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a51397a2' border='0' alt=''/></a></iframe></div> </div>
</div>
</div>
<div class="float-newsletter-bar">
<form action='//newsletters.mybroadband.co.za/proc.php' method='post' accept-charset='utf-8' enctype='multipart/form-data' onsubmit="target_popup(this)">
<input type='hidden' name='f' value='1143'>
<input type='hidden' name='s' value=''>
<input type='hidden' name='c' value='0'>
<input type='hidden' name='m' value='0'>
<input type='hidden' name='act' value='sub'>
<input type='hidden' name='nlbox[]' value='11'>
<div class='_form'>
<div class='_field _type_input'>
<div class='_option'>
<div class="newsletter-caption">Free MyBroadband Newsletter</div>
<div class="newsletter-input"><input class="subscribe-submit" type='submit' value='Subscribe'></div>
<div class="newsletter-submit"><input class="subscribe-text" type='email' name='email' placeholder="Enter email address"></div>
<span class="close-newsletter"><i class="fa fa-times" aria-hidden="true"></i></span>
<div style="clear: both;"></div>
</div>
</div>
</div>
</form>
</div><script type="text/javascript">
  /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
  var disqus_shortname = 'mybroadband'; // required: replace example with your forum shortname

  /* * * DON'T EDIT BELOW THIS LINE * * */
  (function () {
    var s = document.createElement('script'); s.async = true;
    s.type = 'text/javascript';
    s.src = '//' + disqus_shortname + '.disqus.com/count.js';
    (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
  }());
</script>
<script type="text/javascript">
      /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
      var disqus_shortname = 'mybroadband'; // required: replace example with your forum shortname

      /* * * DON'T EDIT BELOW THIS LINE * * */
      (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
      })();
    </script>
 
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-558103-1', 'auto');
  ga('send', 'pageview');

</script>
 
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.2'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-cyclops/js/custom.js?ver=20160816'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/comment-reply.min.js?ver=4.7'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/wp-embed.min.js?ver=4.7'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.6.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.6.0'></script>
<script type="text/javascript" id="slb_footer">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</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript">/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>
