<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel="dns-prefetch" href="//platform.twitter.com">


<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
<script>
      googletag.cmd.push(function() {
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });
    </script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-5PTGM93');</script>



<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff" type="font/woff2" crossorigin="anonymous">

<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff" type="font/woff2" crossorigin="anonymous">

<meta property="fb:app_id" content="297975627065497" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html" />
<meta property="og:title" content="Twitter ordered to give Musk former executive&#8217;s bot files" />
<meta property="og:description" content="Twitter Inc. was ordered to hand over files from its former consumer product head to Elon Musk on spam and bot accounts the billionaire has cited in seeking to abandon his $44 billion purchase of the social media company. " />
<meta property="og:image" content="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg" />
<meta property="og:image:secure_url" content="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="430" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mybroadband">
<meta name="twitter:image" content="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg">
<meta name="twitter:description" content="Twitter Inc. was ordered to hand over files from its former consumer product head to Elon Musk on spam and bot accounts the billionaire has cited in seeking to abandon his $44 billion purchase of the social media company. ">
<meta name="twitter:title" content="Twitter ordered to give Musk former executive&#8217;s bot files ">
<meta property="article:publisher" content="https://www.facebook.com/mybroadband" />
<meta property="article:author" content="https://www.facebook.com/mybroadband" />
<meta property="article:section" content="Internet" />
<script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@graph": [
            {
              "@type": "NewsArticle",
              "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html"
              },
              "headline": "Twitter ordered to give Musk former executive&#8217;s bot files",
              "image": {
                "@type": "ImageObject",
                "url": "https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg",
                "height": 468,
                "width": 696
              },
              "datePublished": "16 August 2022",
              "dateModified": "16 August 2022",
              "author": {
                "@type": "Person",
                "name": "Bloomberg"
              },
               "publisher": {
                "@type": "Organization",
                "name": "MyBroadband",
                "logo": {
                  "@type": "ImageObject",
                  "url": "https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.png"
                }
              },
              "description": "Twitter Inc. was ordered to hand over files from its former consumer product head to Elon Musk on spam and bot accounts the billionaire has cited in seeking to abandon his $44 billion purchase of the social media company. "
            },
            {
              "@type": "BreadcrumbList",
              "itemListElement": [{
                "@type": "ListItem",
                "position": 1,
                "item": {
                  "@id": "https://mybroadband.co.za/news/",
                  "name": "News"
                }
              },{
                "@type": "ListItem",
                "position": 2,
                "item": {
                  "@id": "https://mybroadband.co.za/news/category/internet",
                  "name": "Internet"
                }
              }]
            }
          ]
        }
        </script>
<meta name="viewport" content="width=device-width, user-scalable=no">
<meta name="theme-color" content="#2e3339">
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent">
<link rel="manifest" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/manifest.json">
<script>   
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/service-worker.js').then(function(registration) {
              // Registration was successful
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }).catch(function(err) {
              // registration failed :(
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        }
    </script>
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Twitter ordered to give Musk former executive&#8217;s bot files</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Feed" href="https://mybroadband.co.za/news/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Comments Feed" href="https://mybroadband.co.za/news/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Twitter ordered to give Musk former executive&#8217;s bot files Comments Feed" href="https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html/feed" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mybroadband.co.za\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://mybroadband.co.za/news/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='lazysizes-css' href='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/css/build/lazysizes.fadein.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-css.css?ver=2.76.0' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #CC0000;
	border: 1px solid #CC0000;
}

</style>
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/font-awesome/css/font-awesome.min.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='cyclops-style-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/style.css?ver=4.9.8.5' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='cyclops-ie-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='cyclops-ie8-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='cyclops-ie7-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='lightbox-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/lightbox/lightbox.css?ver=4.3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/js/build/lazysizes.js?ver=5.2.2' id='lazysizes-js'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/html5.js?ver=3.7.3' id='cyclops-html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://mybroadband.co.za/news/wp-json/" /><link rel="alternate" type="application/json" href="https://mybroadband.co.za/news/wp-json/wp/v2/posts/456685" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mybroadband.co.za/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mybroadband.co.za/news/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<link rel='shortlink' href='https://mybroadband.co.za/news/?p=456685' />
<link rel="alternate" type="application/json+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Finternet%2F456685-twitter-ordered-to-give-musk-former-executives-bot-files.html" />
<link rel="alternate" type="text/xml+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Finternet%2F456685-twitter-ordered-to-give-musk-former-executives-bot-files.html&#038;format=xml" />
<noscript><style>.lazyload { display: none !important; }</style></noscript>

<meta name="keywords" content="Elon Musk,Kayvon Beykpour,Parag Agrawal,Twitter,Twitter bots,Internet" />
<meta name="description" content="Twitter Inc. was ordered to hand over files from its former consumer product head to Elon Musk on spam and bot accounts the billionaire has cited in seeking to&#8230;" />

<link rel="amphtml" href="https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html/amp"><link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-180x180.png" />
<meta name="msapplication-TileImage" content="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-270x270.png" />
</head>
<body class="post-template-default single single-post postid-456685 single-format-standard group-blog no-sidebar">


<script type="text/javascript">
        (function() {
               var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
               em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
               var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
        })();
</script>
<noscript>
        <img src="//za.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;" />
</noscript>

<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
 
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
 
  return t;
}(document, "script", "twitter-wjs"));</script>

<script type="text/javascript">
_linkedin_partner_id = "485162";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=485162&fmt=gif" />
</noscript>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5PTGM93"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="page" class="site">
<div class="site-inner">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
<div class="site-branding">
<div class="header_ad">
<div class="ad"><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_internet_article/mybroadband_internet_article_leaderboard', [728, 90], 'div-gpt-ad-1517032294173-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517032294173-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517032294173-0'); });
</script>
</div></div> </div>
<div style="clear:both;"></div>
</div>
<div class="top-bar">
<div class="top-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<p class="site-title"><a href="https://mybroadband.co.za/news/" rel="home">MyBroadband</a></p>
<div class="magazine-top-link">
<a href="https://whatsnext.mybroadband.co.za/" target="_blank">What&apos;s Next</a>
</div>
<div class="top-social-links">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://www.linkedin.com/company/mybroadband"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
</div>
<a class="logo" href="https://mybroadband.co.za/news">
<img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.svg" alt="MyBroadband Logo">
</a>
<div style="clear:both;"></div>
</div>
<div class="site-header-main">
<nav class="menu">
<ul>
<li><a class="categories-menu" href="https://mybroadband.co.za/news/">News</a></li>
<li><a class="press-office-menu" href="http://companies.mybroadband.co.za/">Press office</a></li>
<li><a class="no-sub-menu" href="/forum/forums/news-and-current-affairs.131/">Breaking news</a></li>
<li><a class="no-sub-menu" href="/forum">Forum</a></li>
<li><a class="no-sub-menu" href="/news/industrynews">Industry news</a></li>
<li><a class="company-hub-menu" href="https://mybroadband.co.za/news/">Company hub</a></li>
<li><a class="no-sub-menu" href="http://speedtest.mybroadband.co.za/">Speed test</a></li>
<li><a class="search-menu" href="#"><i class="fa fa-search" aria-hidden="true"></i></a></li>
</ul>
</nav>
<div class="categories-sub-menu sub-menu">
<ul>
<li><a href="/news/5g">5G</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cellular">Cellular</a></li>
</ul>
<ul>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/enterprise">Enterprise</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/gaming">Gaming</a></li>
</ul>
<ul>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/internet">Internet</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/reviews">Reviews</a></li>
</ul>
<ul>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/trending">Trending</a></li>
<li><a href="/news/wireless">Wireless</a></li>
</ul>
</div>
<div class="press-office-sub-menu sub-menu">
<ul>
<li><a href="//companies.mybroadband.co.za/adumo/">Adumo</a></li>
<li><a href="//companies.mybroadband.co.za/axiz/">Axiz</a></li>
<li><a href="//companies.mybroadband.co.za/bbd/">BBD</a></li>
<li><a href="//companies.mybroadband.co.za/bui/">BUI</a></li>
<li><a href="//companies.mybroadband.co.za/crs/">CRS</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/domains/">Domains</a></li>
<li><a href="//companies.mybroadband.co.za/exclusive-networks-africa/">Exclusive Networks Africa</a></li>
<li><a href="//companies.mybroadband.co.za/first-digital/">First Digital</a></li>
<li><a href="//companies.mybroadband.co.za/iotnxt/">IoT.nxt</a></li>
<li><a href="//companies.mybroadband.co.za/masterdatamanagement/">Master Data Management</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/miro/">MiRO</a></li>
<li><a href="//companies.mybroadband.co.za/mix-telematics/">MiX Telematics</a></li>
<li><a href="//companies.mybroadband.co.za/mybroadband/">MyBroadband</a></li>
<li><a href="//companies.mybroadband.co.za/paratus-africa/">Paratus Africa</a></li>
<li><a href="//companies.mybroadband.co.za/sabinet/">Sabinet</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/schneider-electric/">Schneider Electric</a></li>
<li><a href="//companies.mybroadband.co.za/synology/">Synology</a></li>
<li><a href="//companies.mybroadband.co.za/tecno/">TECNO</a></li>
<li><a href="//companies.mybroadband.co.za/zte/">ZTE</a></li>
</ul>
</div>
<div class="company-hub-sub-menu sub-menu">
<ul>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/axiz-micro-focus/">Axiz | Micro Focus</a></li>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/huawei-360/">Huawei 360</a></li>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/istore/">iStore</a></li>
 <li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/liquid-intelligent-technologies/">Liquid Intelligent Technologies</a></li>
</ul>
</div>
<div class="search-sub-menu sub-menu">
<form role="search" method="get" id="searchform" action="https://mybroadband.co.za/news/">
<div>
<input type="text" class="nav-search-bar" value="" name="s" id="s" placeholder="Search" /><input style="display:none;" type="submit" value="" />
</div>
</form>
</div>
</div>
<div class="mobile-site-header">
<a href="https://mybroadband.co.za/news/" class="mobile-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png?v=1.0" alt="logo" /></a>
<div class="mobile-bar-share">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Twitter+ordered+to+give+Musk+former+executive%E2%80%99s+bot+files https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="#" onclick="webShare(event,'https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-share-alt" aria-hidden="true"></i>
</a>
</div>
<div class="mobile-search-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<div class="mobile-menu-button"><i class="fa fa-bars" aria-hidden="true"></i></div>
</div>
<div class="mobile-search-bar">
<div class="search-bar-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<form action="/" method="get">
<input placeholder="What are you looking for?" type="text" name="s" id="search" value="" />
</form>
<div class="search-bar-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
<div class="mobile-menu">
<ul>
<li><a href="https://mybroadband.co.za/news/">Home</a></li>
<li>
<a class="mobile-expand" href="#">Categories <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/wireless">Wireless</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/internet">Internet</a></li>
<li>
<a class="mobile-expand" href="#">More <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/5G">5G</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/enterprise">Enterprise</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gaming">Gaming</a></li>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/reviews">Reviews</a></li>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/trending">Trending</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="https://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum">Forum</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li>
<a class="mobile-expand" href="#">Company Hub <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/axiz-micro-focus/">Axiz | Micro Focus</a></li>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/huawei-360/">Huawei 360</a></li>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/istore/">iStore</a></li>
<li><a target="_blank" href="//companies.mybroadband.co.za/company-hub/liquid-intelligent-technologies/">Liquid Intelligent Technologies</a></li>
</ul>
</li>
<li><a href="http://speedtest.mybroadband.co.za/">Speed Test</a></li>
<li><a class="mobile-expand" href="#">
About
<i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i>
</a>
<ul>
<li><a href="/news/about-us">About Us</a></li>
<li><a href="/news/advertising">Advertising</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/careers">Careers</a></li>
</ul>
</li>
</ul>
</div>
<div class="mobile-overlay">
<div class="mobile-menu-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
</header>
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<div class="the-post">
<article id="post-456685" class="post-456685 post type-post status-publish format-standard has-post-thumbnail hentry category-internet tag-elon-musk tag-kayvon-beykpour tag-parag-agrawal tag-twitter tag-twitter-bots">
<header class="entry-header">
<h1 class="entry-title article-title">Twitter ordered to give Musk former executive&#8217;s bot files</h1> <div class="article-meta"><span class="vcard author post-author"><span class="fn"><a href="https://mybroadband.co.za/news/author/bloomberg" title="Posts by Bloomberg" rel="author">Bloomberg</a></span></span><span class="post-date updated">16 August 2022</span></div>
</header>
<a class="post-thumbnail" href="https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html" aria-hidden="true">
<img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="Twitter ordered to give Musk former executive&#8217;s bot files" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-640x426.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Twitter ordered to give Musk former executive&#8217;s bot files" srcset="https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-640x426.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2021/05/Elon-Musk-4-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript> </a>
<div class="social-section">
<div id="el-content-wrapper" class="el-content-wrapper container">
<div id="el-content" class="el-content row">
<div>
<div class="article-top-newsletter">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div>
</div>
<div>
<div class="article-share-buttons" style="display:inline-block;">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Twitter+ordered+to+give+Musk+former+executive%E2%80%99s+bot+files https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#4f703c3a2d252a2c3b721b38263b3b2a3d6a7d7f203d2b2a3d2a2b6a7d7f3b206a7d7f2826392a6a7d7f023a3c246a7d7f29203d222a3d6a7d7f2a372a2c3a3b26392a6a7d796a7d7c777d7e786a7c0d3c6a7d7f2d203b6a7d7f2926232a3c692d202b36721b38263b3b2a3d6a7d7f06212c616a7d7f382e3c6a7d7f203d2b2a3d2a2b6a7d7f3b206a7d7f272e212b6a7d7f20392a3d6a7d7f2926232a3c6a7d7f293d20226a7d7f263b3c6a7d7f29203d222a3d6a7d7f2c20213c3a222a3d6a7d7f3f3d202b3a2c3b6a7d7f272a2e2b6a7d7f3b206a7d7f0a2320216a7d7f023a3c246a7d7f20216a7d7f3c3f2e226a7d7f2e212b6a7d7f2d203b6a7d7f2e2c2c203a213b3c6a7d7f3b272a6a7d7f2d2623232620212e263d2a6a7d7f272e3c6a7d7f2c263b2a2b6a7d7f26216a7d7f3c2a2a242621286a7d7f3b206a7d7f2e2d2e212b20216a7d7f27263c6a7d7f6a7d7b7b7b6a7d7f2d2623232620216a7d7f3f3a3d2c272e3c2a6a7d7f20296a7d7f3b272a6a7d7f3c202c262e236a7d7f222a2b262e6a7d7f2c20223f2e2136616a0c7d6a0e7f6a7f0e6a7f0e273b3b3f3c6a7c0e6a7d096a7d0922362d3d202e2b2d2e212b612c2061352e6a7d09212a383c6a7d0926213b2a3d212a3b6a7d097b7a7979777a623b38263b3b2a3d62203d2b2a3d2a2b623b20622826392a62223a3c246229203d222a3d622a372a2c3a3b26392a3c622d203b622926232a3c61273b2223">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
</div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
<div class="entry-content">
<p>Twitter Inc. was ordered to hand over files from its former consumer product head to Elon Musk on spam and bot accounts the billionaire has cited in seeking to abandon his $44 billion purchase of the social media company.</p>
<p>But Twitter was spared from producing documents for most of the employees Musk says are key witnesses on the bots issue.</p>
<p>Musk, whom Twitter sued to make him complete the deal, accused the company this month of hiding the names of workers specifically responsible for evaluating how much of the platform’s customer base is made up of spam and robot accounts.</p>
<p>He asked the judge to force Twitter to identify them. So far Twitter has given up the names of “records custodians,” who aren’t as familiar with the data in question.</p>
<p>On Monday, Delaware Chancery Court Judge Kathaleen St. J. McCormick mostly denied Musk’s request in a one-page ruling, ordering that Twitter needn’t “collect, review, or produce documents” from any of the other 21 additional custodians Musk asked for.</p>
<p>The exception is Kayvon Beykpour, former head of consumer product, who was <strong><a href="https://www.bloomberg.com/news/articles/2022-05-12/twitter-to-freeze-hiring-rescind-some-offers-and-cut-costs" target="_blank" rel="noopener noreferrer">fired in May</a></strong>.</p>
<p>Beykpour was the top product executive at Twitter for years before he was unexpectedly dismissed by new chief executive officer Parag Agrawal.</p>
<p>It was his product team that was most directly responsible for expanding Twitter’s user base — and it is the quality of that base Musk has questioned in seeking to walk away from the deal.</p>
<p>Beykpour joined Twitter in 2015 when the company acquired his live video app, Periscope, and quickly climbed the ranks under former CEO Jack Dorsey.</p>
<p>He was pushing Twitter into new product areas, like live audio spaces and newsletters, before he was ousted.</p>
<p>The departures of Beykpour and Bruce Falck, formerly in charge of revenue product, reflected Twitter’s state of limbo while it awaited a new owner, a state now intensified by the litigation.</p>
<p>Meanwhile a hiring freeze and other cost-cutting efforts have left some employees unsure of whether the projects or teams they are working on will be prioritized under new leadership.</p>
<p>Lawyers for Twitter and Musk have issued a flurry of subpoenas to banks, investors and attorneys involved in the deal, as the two sides prepare for an Oct. 17 trial in Wilmington.</p>
<p>Twitter claims that Musk, the world’s richest person and the CEO of Tesla Inc., is using the concerns about spam and bot accounts as an excuse to get out of the transaction.</p>
<p>Musk argues the company has failed to show that spam bots account for fewer than 5% of its active users, as it has said in regulatory filings.</p>
<h3>Now read: <a href="https://mybroadband.co.za/news/internet/456567-copyright-scammers-stole-r374-million-in-youtube-music-royalties.html" rel="bookmark">Copyright scammers stole R374 million in YouTube music royalties</a></h3>
</div>
<footer class="entry-footer">
<div class="tags"><p><span><a href="https://mybroadband.co.za/news/tag/elon-musk" rel="nofollow tag">Elon Musk</a> <a href="https://mybroadband.co.za/news/tag/kayvon-beykpour" rel="nofollow tag">Kayvon Beykpour</a> <a href="https://mybroadband.co.za/news/tag/parag-agrawal" rel="nofollow tag">Parag Agrawal</a> <a href="https://mybroadband.co.za/news/tag/twitter" rel="nofollow tag">Twitter</a> <a href="https://mybroadband.co.za/news/tag/twitter-bots" rel="nofollow tag">Twitter bots</a></span></p></div>
</footer>
</article>
<div class="bottom-share">
<a class="bottom-facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');"><i class="fa fa-facebook-official" aria-hidden="true"></i> Share <span class="share-hide">on Facebook</span></a>
<a class="bottom-twitter-share" href="https://twitter.com/intent/tweet/?text=Twitter+ordered+to+give+Musk+former+executive%E2%80%99s+bot+files https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html&via=mybroadband"> <i class="fa fa-twitter" aria-hidden="true"></i> Share <span class="share-hide">on Twitter</span></a>
</div>
<a href="https://mybroadband.co.za/forum/threads/twitter-must-give-elon-musk-former-product-heads-files-on-bot-accounts.1200413/" class="forum-link">
<div class="link-forum">
<span class="label"><strong>Share your thoughts: </strong></span>
<span class="forum_click">Twitter ordered to give Musk former &hellip;</span> <i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
</a>
<div class="article-bottom-newsletter">
<div class="title">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Latest news</h2></div>
<div class="below_row_article_container">
<article id="post-456697" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/software/456697-snapchat-adds-four-new-features-as-it-hits-1-million-subscribers.html">
<img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone.jpg" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/06/Snapchat-log-in-logo-on-iphone-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/software/456697-snapchat-adds-four-new-features-as-it-hits-1-million-subscribers.html" rel="bookmark">Snapchat+ adds four new features as it hits 1 million subscribers</a></h2> </header>
</article>
<article id="post-456723" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/cellular/456723-rain-retracts-telkom-merger-offer-announcement.html">
<img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO.jpg" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/07/Brandon-Leigh-rain-CEO-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/cellular/456723-rain-retracts-telkom-merger-offer-announcement.html" rel="bookmark">Rain retracts Telkom merger offer announcement</a></h2> </header>
</article>
<article id="post-456707" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/security/456707-microsoft-warns-secure-boot-update-might-fail-to-install.html">
<img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error.jpg" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windows-error-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/security/456707-microsoft-warns-secure-boot-update-might-fail-to-install.html" rel="bookmark">Microsoft warns Secure Boot update might fail to install</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Partner Content</h2></div>
<div class="below_row_article_container">
<article id="post-456543" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/456543-5g-your-life-for-faster-more-connected-and-more-reliable-home-or-mobile-connectivity.html">
<img data-aspectratio="640/430" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image.jpg" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/MTN-Headline-Image-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/456543-5g-your-life-for-faster-more-connected-and-more-reliable-home-or-mobile-connectivity.html" rel="bookmark">5G your life for faster and more reliable home or mobile connectivity</a></h2> </header>
</article>
<article id="post-456225" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/456225-adumo-consolidates-brand-and-unveils-3-new-point-of-sale-devices.html">
 <img data-aspectratio="640/430" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image.png" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image.png 640w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image-595x400.png 595w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image-300x202.png 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image.png" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image.png 640w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image-595x400.png 595w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Adumo-Headline-Image-300x202.png 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/456225-adumo-consolidates-brand-and-unveils-3-new-point-of-sale-devices.html" rel="bookmark">Adumo consolidates brand and unveils 3 new point-of-sale devices</a></h2> </header>
</article>
<article id="post-456499" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/456499-reach-the-inbox-of-south-africas-ict-community.html">
<img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager.jpg" class="attachment-small size-small wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager-600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/IT-Manager-768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/456499-reach-the-inbox-of-south-africas-ict-community.html" rel="bookmark">Reach the inbox of South Africa&#8217;s ICT community</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="show-comments">Show comments</div>
<div style="display:none;" class="comments">
<div class="box-title"><span class="title-line"></span>
<h2>
Join the conversation
<span class="auto-load-label">
Autoload comments
<span class="switch"><span class="toggle"></span></span>
</span>
</h2>
</div>
<p class="comments-policy" style="font-size:11pt;"><span>Comments section policy:</span> MyBroadband has a <a target="_blank" href="https://mybroadband.co.za/news/mybroadband-comment-policy">new article comments policy</a> which aims to encourage constructive discussions. To get your comments published, make sure it is civil and adds value to the discussion.</p>
<div class="box-content">
<div class="disqus" data-uid="456685" data-title="Twitter ordered to give Musk former executive&#8217;s bot files" data-url="https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html"></div>
</div>
</div>
</div>
<div class="single-side">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_internet_article/mybroadband_internet_article_island_1', [[300, 600], [300, 250]], 'div-gpt-ad-1620293464605-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1620293464605-0'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1620293464605-0'); });
  </script>
</div></div> <div class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Follow us</h2></div>
<div class="box-content">
<div class="follow-buttons">
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
<div class="follow-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div> <div class="ad"><script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_internet_article/mybroadband_internet_article_island_2', [[300, 600], [300, 250]], 'div-gpt-ad-1620293563758-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1620293563758-0'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1620293563758-0'); });
  </script>
</div></div> <div id="the_poll" class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Poll</h2></div>
<div class="box-content"><div id="polls-5341" class="wp-polls">
<form id="polls_form_5341" class="wp-polls-form" action="/news/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_5341_nonce" name="wp-polls-nonce" value="b9af3742c3" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="5341" /></p>
<p><strong>Which tracking system is installed on your car?</strong></p><div id="polls-5341-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24893" name="poll_5341" value="24893" /> <label for="poll-answer-24893">Tracker</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24895" name="poll_5341" value="24895" /> <label for="poll-answer-24895">Ctrack</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24897" name="poll_5341" value="24897" /> <label for="poll-answer-24897">Matrix</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24899" name="poll_5341" value="24899" /> <label for="poll-answer-24899">Cartrack</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24901" name="poll_5341" value="24901" /> <label for="poll-answer-24901">Netstar</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24903" name="poll_5341" value="24903" /> <label for="poll-answer-24903">Other</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-24905" name="poll_5341" value="24905" /> <label for="poll-answer-24905">None</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(5341);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(5341); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-5341-loading" class="wp-polls-loading"><img src="https://mybroadband.co.za/news/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div>
</div> <div class="side_feed_article_container">
<div class="box-title"><span class="title-line"></span><h2>Recommended</h2></div>
<article id="post-456621" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/energy/456621-audi-launches-south-africas-first-150kw-ultra-fast-charging-stations-340km-range-in-30-minutes.html">
<img data-aspectratio="300/202" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Audi-ultra-fast-charger-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" loading="lazy" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Audi-ultra-fast-charger-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/energy/456621-audi-launches-south-africas-first-150kw-ultra-fast-charging-stations-340km-range-in-30-minutes.html" rel="bookmark">Audi launches South Africa&#8217;s first 150kW ultra-fast charging stations — 340km range in 30 minutes</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-456699" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/cryptocurrency/456699-whats-next-binance-ceo-cz-changpeng-zhao-discusses-south-african-plans-cryptocurrency-benefits-risks-and-regulations.html">
<img data-aspectratio="300/202" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Changpeng-Zhao-22CZ22-Binance-thumbnail-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" loading="lazy" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Changpeng-Zhao-22CZ22-Binance-thumbnail-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/cryptocurrency/456699-whats-next-binance-ceo-cz-changpeng-zhao-discusses-south-african-plans-cryptocurrency-benefits-risks-and-regulations.html" rel="bookmark">What&#8217;s Next — Binance CEO &#8220;CZ&#8221; Changpeng Zhao discusses South African plans, cryptocurrency benefits, risks, and regulations</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-456683" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/energy/456683-major-eskom-coal-supplier-acquiring-wind-power-company-for-r904-million.html">
<img data-aspectratio="300/202" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" loading="lazy" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/energy/456683-major-eskom-coal-supplier-acquiring-wind-power-company-for-r904-million.html" rel="bookmark">Major Eskom coal supplier acquiring wind power company for R904 million</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-456679" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/motoring/456679-big-strike-over-petrol-prices-and-load-shedding.html">
<img data-aspectratio="300/202" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-300x202.webp" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" loading="lazy" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-300x202.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/motoring/456679-big-strike-over-petrol-prices-and-load-shedding.html" rel="bookmark">Big strike over petrol prices and load-shedding</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-456637" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/cryptocurrency/456637-worlds-biggest-cryptocurrency-exchange-looking-for-south-african-bank-partner.html">
<img data-aspectratio="300/202" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Changpeng-Zhao-22CZ22-Binance-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" loading="lazy" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Changpeng-Zhao-22CZ22-Binance-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/cryptocurrency/456637-worlds-biggest-cryptocurrency-exchange-looking-for-south-african-bank-partner.html" rel="bookmark">World&#8217;s biggest cryptocurrency exchange wants to open South African bank account</a></h2> </header>
<div style="clear:both;"></div>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div style="clear:both;"></div>

<div class="article-top-bar">
<a href="/news" class="article-top-bar-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png" alt="logo" /></a>
<div class="article-top-bar-share">
Share this article
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#bf80cccaddd5dadccb82ebc8d6cbcbdacd9a8d8fd0cddbdacddadb9a8d8fcbd09a8d8fd8d6c9da9a8d8ff2caccd49a8d8fd9d0cdd2dacd9a8d8fdac7dadccacbd6c9da9a8d899a8d8c878d8e889a8cfdcc9a8d8fddd0cb9a8d8fd9d6d3dacc99ddd0dbc682ebc8d6cbcbdacd9a8d8ff6d1dc919a8d8fc8decc9a8d8fd0cddbdacddadb9a8d8fcbd09a8d8fd7ded1db9a8d8fd0c9dacd9a8d8fd9d6d3dacc9a8d8fd9cdd0d29a8d8fd6cbcc9a8d8fd9d0cdd2dacd9a8d8fdcd0d1cccad2dacd9a8d8fcfcdd0dbcadccb9a8d8fd7dadedb9a8d8fcbd09a8d8ffad3d0d19a8d8ff2caccd49a8d8fd0d19a8d8fcccfded29a8d8fded1db9a8d8fddd0cb9a8d8fdedcdcd0cad1cbcc9a8d8fcbd7da9a8d8fddd6d3d3d6d0d1ded6cdda9a8d8fd7decc9a8d8fdcd6cbdadb9a8d8fd6d19a8d8fccdadad4d6d1d89a8d8fcbd09a8d8fdeddded1dbd0d19a8d8fd7d6cc9a8d8f9a8d8b8b8b9a8d8fddd6d3d3d6d0d19a8d8fcfcacddcd7deccda9a8d8fd0d99a8d8fcbd7da9a8d8fccd0dcd6ded39a8d8fd2dadbd6de9a8d8fdcd0d2cfded1c6919afc8d9afe8f9a8ffe9a8ffed7cbcbcfcc9a8cfe9a8df99a8df9d2c6ddcdd0dedbddded1db91dcd091c5de9a8df9d1dac8cc9a8df9d6d1cbdacdd1dacb9a8df98b8a8989878a92cbc8d6cbcbdacd92d0cddbdacddadb92cbd092d8d6c9da92d2caccd492d9d0cdd2dacd92dac7dadccacbd6c9dacc92ddd0cb92d9d6d3dacc91d7cbd2d3">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Twitter+ordered+to+give+Musk+former+executive%E2%80%99s+bot+files https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/internet/456685-twitter-ordered-to-give-musk-former-executives-bot-files.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<div style="clear:both;"></div>
</div>
<div class="article-top-bar-title">
<span class="line-end"></span>
<div>
Twitter ordered to give Musk former executive&#8217;s bot files </div>
</div>
<div style="clear:both;"></div>
</div>

<div class="next-previous-article">
<div id="next-article">
<div class="next-arrow">
<i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
<div class="next-article-link">
<a class="the-image" href="https://mybroadband.co.za/news/energy/456683-major-eskom-coal-supplier-acquiring-wind-power-company-for-r904-million.html"><img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline-.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline-.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline-.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline-.jpg 800w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--600x400.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2022/08/Windlab-Africa-headline--768x512.jpg 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
<a class="the-text" href="https://mybroadband.co.za/news/energy/456683-major-eskom-coal-supplier-acquiring-wind-power-company-for-r904-million.html">Major Eskom coal supplier acquiring wind power company for R904 million</a>
<span class="next-span">Next article</span>
</div>
</div>
<div id="previous-article">
<div class="previous-arrow">
<i class="fa fa-chevron-left" aria-hidden="true"></i>
</div>
<div class="previous-article-link">
<a class="the-text" href="https://mybroadband.co.za/news/motoring/456679-big-strike-over-petrol-prices-and-load-shedding.html">Big strike over petrol prices and load-shedding</a>
<span class="previous-span">Previous article</span>
<a class="the-image" href="https://mybroadband.co.za/news/motoring/456679-big-strike-over-petrol-prices-and-load-shedding.html"><img data-aspectratio="800/533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="800" height="533" data-src="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock.webp" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" loading="lazy" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock.webp 800w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-600x400.webp 600w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-640x426.webp 640w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-768x512.webp 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="800" height="533" src="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock.webp" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock.webp 800w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-600x400.webp 600w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-640x426.webp 640w, https://mybroadband.co.za/news/wp-content/uploads/2021/12/Petrol-fuel-rand-new-Shutterstock-768x512.webp 768w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
</div>
</div>
</div>

</main>
</div>
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<div class="footer-sub-menu">
<ul>
<li class="footer-header"><span></span><a href="">Categories</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/motoring">Motoring</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Sections</a></li>
<li><a href="http://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum/">Forum</a></li>
<li><a href="/forum/whats-new/">What's New</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/forum/forums/classifieds-for-sale.162/">Classifieds</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Information</a></li>
<li><a href="/news/about-us">About</a></li>
<li><a href="/news/advertising">Advertise with us</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/rss-feeds">RSS</a></li>
<li><a href="/MyBroadband-Terms-and-Conditions.pdf">Terms &amp; Conditions</a></li>
<li><a href="/news/careers">Careers</a></li>
<li><a href="/news/notification-of-infringements">Notification of Infringements</a></li>
<li><a target="_blank" href="https://ispa.org.za/code-of-conduct/"><img style="width: 100px;" src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/ispa.png" alt="ISPA" /></a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Follow Us</a></li>
<li><a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/">Facebook</a></li>
<li><a target="_blank" rel="noopener" href="https://twitter.com/mybroadband">Twitter</a></li>
<li><a target="_blank" rel="noopener" href="https://www.youtube.com/user/mybroadbandlive">YouTube</a></li>
<li><a target="_blank" rel="noopener" href="https://www.instagram.com/mybroadband/">Instagram</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.co.za/">Internet Speed Test</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.mybroadband.co.za/">MyBroadband Speed Test</a></li>
<li><a target="_blank" rel="noopener" href="https://networkstatus.co.za/">Network Status</a></li>
<li><a target="_blank" rel="noopener" href="https://sacoronavirus.co.za/">sacoronavirus.co.za</a></li>
</ul>
</div>
<div class="mobile-footer-menu">
<ul>
<li class="footer-header"><span></span><a href="">Follow us</a></li>
</ul>
<div class="follow-buttons">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&amp;hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
 <a target="_blank" rel="noopener" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
</div>
</div>
<div class="footer-logos footer-logos-inner clearfix" style="-webkit-filter: grayscale(100%); filter: grayscale(100%); max-width: 500px; padding: 14px 0px;">
<div class="footer-logos-three-columns clearfix">
<div class="footer-logos-three-columns-inner">
<div class="footer-logos-column">
<div class="logo-column-inner">
<div class="logo-column-1">
<a href="https://mybroadband.co.za/news/" target="_blank" rel="nofollow"><img src="https://mybroadband.co.za/news/wp-content/uploads/2021/01/mybroadband-logo.png" style="max-height: 35px; margin: 0 auto; display: block;"></a>
</div>
</div>
</div>
<div class="footer-logos-column">
<div class="logo-column-inner">
<div class="logo-column-inner">
<div class="logo-column-1">
<a href="https://businesstech.co.za/news/" target="_blank" rel="nofollow"><img src="https://mybroadband.co.za/news/wp-content/uploads/2021/01/businesstech-logo.png" style="max-height: 35px; margin: 0 auto; display: block;"></a>
</div>
</div>
</div>
</div>
<div class="footer-logos-column">
<div class="logo-column-inner">
<div class="logo-column-inner">
<div class="logo-column-1">
<a href="https://topauto.co.za/" target="_blank" rel="nofollow"><img src="https://mybroadband.co.za/news/wp-content/uploads/2021/01/topauto-logo.png" style="max-height: 35px; margin: 0 auto; display: block;"></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</footer>
<div id="wallpaper_ad" style="position:fixed;overflow:hidden;z-index:8;width:100%;margin-left:auto;margin-right:auto;left:0;right:0;top:0px;height:1080px;">
<div style="position: absolute;left:50%;">
<div style="position: relative;left:-50%;">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_internet_article/mybroadband_internet_article_wallpaper', [1920, 1080], 'div-gpt-ad-1517032268810-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517032268810-0' style='height:1080px; width:1920px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517032268810-0'); });
</script>
</div></div> </div>
</div>
</div>
<div class="float-newsletter-bar">
<div class="newsletter-form">
<div class="newsletter-caption">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> <span class="close-newsletter"><i class="fa fa-times"></i></span>
</div>
</div>
<script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","postID":"456685","nonce":"71daa5da12","requestURL":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/js/frontend.js?ver=1.3.11' id='post-views-counter-frontend-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-js.js?ver=2.76.0' id='wp-polls-js'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/skip-link-focus-fix.js?ver=20160816' id='cyclops-skip-link-focus-fix-js'></script>
<script type='text/javascript' id='cyclops-script-js-extra'>
/* <![CDATA[ */
var directory_uri = {"stylesheet_directory_uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/themes\/mybroadband-nightcrawler"};
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/custom.js?ver=20160819' id='cyclops-script-js'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/lightbox/lightbox.js?ver=3.3.0' id='lightbox-js'></script>
</body>
</html>
