<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
      (adsbygoogle = window.adsbygoogle || []).push({
        google_ad_client: "ca-pub-6024413815386492",
        enable_page_level_ads: true
      });
    </script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
<script>
      googletag.cmd.push(function() {
        googletag.pubads().enableSingleRequest();
        googletag.pubads().enableLazyLoad();
        googletag.enableServices();
      });
    </script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-5PTGM93');</script>



<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff" type="font/woff2" crossorigin="anonymous">

<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff" type="font/woff2" crossorigin="anonymous">

<meta property="fb:app_id" content="297975627065497" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html" />
<meta property="og:title" content="Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks" />
<meta property="og:description" content="HMD Global has unveiled its first 5G smartphone &#8211; The Nokia 8.3 5G." />
<meta property="og:image" content="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg" />
<meta property="og:image:secure_url" content="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="430" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mybroadband">
<meta name="twitter:image" content="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg">
<meta name="twitter:description" content="HMD Global has unveiled its first 5G smartphone &#8211; The Nokia 8.3 5G.">
<meta name="twitter:title" content="Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks ">
<meta property="article:publisher" content="https://www.facebook.com/mybroadband" />
<meta property="article:author" content="https://www.facebook.com/mybroadband" />
<meta property="article:section" content="Smartphones" />
<script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@graph": [
            {
              "@type": "NewsArticle",
              "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html"
              },
              "headline": "Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks",
              "image": {
                "@type": "ImageObject",
                "url": "https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg",
                "height": 468,
                "width": 696
              },
              "datePublished": "23 March 2020",
              "dateModified": "23 March 2020",
              "author": {
                "@type": "Person",
                "name": "Hanno Labuschagne"
              },
               "publisher": {
                "@type": "Organization",
                "name": "MyBroadband",
                "logo": {
                  "@type": "ImageObject",
                  "url": "https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.png"
                }
              },
              "description": "HMD Global has unveiled its first 5G smartphone &#8211; The Nokia 8.3 5G."
            },
            {
              "@type": "BreadcrumbList",
              "itemListElement": [{
                "@type": "ListItem",
                "position": 1,
                "item": {
                  "@id": "https://mybroadband.co.za/news/",
                  "name": "News"
                }
              },{
                "@type": "ListItem",
                "position": 2,
                "item": {
                  "@id": "https://mybroadband.co.za/news/category/smartphones",
                  "name": "Smartphones"
                }
              }]
            }
          ]
        }
        </script>
<meta name="viewport" content="width=device-width, user-scalable=no">
<meta name="theme-color" content="#2e3339">
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent">
<link rel="manifest" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/manifest.json">
<script>   
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/service-worker.js').then(function(registration) {
              // Registration was successful
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }).catch(function(err) {
              // registration failed :(
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        }
    </script>
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Feed" href="https://mybroadband.co.za/news/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Comments Feed" href="https://mybroadband.co.za/news/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks Comments Feed" href="https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mybroadband.co.za\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://mybroadband.co.za/news/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='lazysizes-fadein-style-css' href='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/css/lazysizes.fadein.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.4' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #CC0000;
	border: 1px solid #CC0000;
}

</style>
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/font-awesome/css/font-awesome.min.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='cyclops-style-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/style.css?ver=4.9.8.5' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='cyclops-ie-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='cyclops-ie8-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='cyclops-ie7-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='slb_core-css' href='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/js/lazysizes.js?ver=5.2.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://mybroadband.co.za/news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mybroadband.co.za/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mybroadband.co.za/news/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Important stats about the coronavirus outbreak in South Africa' href='https://mybroadband.co.za/news/science/344065-important-stats-about-the-coronavirus-outbreak-in-south-africa.html' />
<link rel='next' title='21-day nationwide lockdown for South Africa' href='https://mybroadband.co.za/news/government/344121-21-day-nationwide-lockdown-for-south-africa.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://mybroadband.co.za/news/?p=344097' />
<link rel="alternate" type="application/json+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Fsmartphones%2F344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html" />
<link rel="alternate" type="text/xml+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Fsmartphones%2F344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html&#038;format=xml" />
<noscript><style>.lazyload { display: none !important; }</style></noscript>

<meta name="keywords" content="HMD Global,Nokia,Nokia 1.3,Nokia 5.3,Nokia 8.3,Smartphones" />
<meta name="description" content="HMD Global has unveiled its first 5G smartphone &#8211; The Nokia 8.3 5G." />

<link rel="amphtml" href="https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html/amp"><link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-180x180.png" />
<meta name="msapplication-TileImage" content="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-270x270.png" />
</head>
<body class="post-template-default single single-post postid-344097 single-format-standard group-blog no-sidebar">


<script type="text/javascript">
        (function() {
               var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
               em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
               var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
        })();
</script>
<noscript>
        <img src="//za.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;" />
</noscript>

<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
 
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
 
  return t;
}(document, "script", "twitter-wjs"));</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=297975627065497";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<script type="text/javascript">
_linkedin_partner_id = "485162";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=485162&fmt=gif" />
</noscript>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5PTGM93"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="page" class="site">
<div class="site-inner">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
<div class="site-branding">
<div class="header_ad">
<div class="ad"><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_smartphones_article/mybroadband_smartphones_article_leaderboard', [728, 90], 'div-gpt-ad-1516691429388-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1516691429388-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1516691429388-0'); });
</script>
</div></div> </div>
<div style="clear:both;"></div>
</div>
<div class="top-bar">
<div class="top-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<p class="site-title"><a href="https://mybroadband.co.za/news/" rel="home">MyBroadband</a></p>
<div class="magazine-top-link">
<a href="https://mybroadband.co.za/news//mybroadband-magazine-2019">Magazine</a>
</div>
<div class="top-social-links">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
</div>
<a class="logo" href="https://mybroadband.co.za/news">
<img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.svg" onerror="this.src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.png'" alt="MyBroadband Logo">
</a>
<div style="clear:both;"></div>
</div>
<div class="site-header-main">
<nav class="menu">
<ul>
<li><a class="categories-menu" href="https://mybroadband.co.za/news/">News</a></li>
<li><a class="press-office-menu" href="http://companies.mybroadband.co.za/">Press office</a></li>
<li><a class="no-sub-menu" href="/forum/forums/news-and-current-affairs.131/">Breaking news</a></li>
<li><a class="no-sub-menu" href="/forum">Forum</a></li>
<li><a class="no-sub-menu" href="/news/industrynews">Industry news</a></li>
<li><a class="no-sub-menu" href="https://deals.mybroadband.co.za/">Deals</a></li>
<li><a class="no-sub-menu" href="http://speedtest.mybroadband.co.za/">Speed test</a></li>
<li><a class="search-menu" href="#"><i class="fa fa-search" aria-hidden="true"></i></a></li>
</ul>
</nav>
<div class="categories-sub-menu sub-menu">
<ul>
<li><a href="/news/5g">5G</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cellular">Cellular</a></li>
</ul>
<ul>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/enterprise">Enterprise</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/gaming">Gaming</a></li>
</ul>
<ul>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/internet">Internet</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/reviews">Reviews</a></li>
</ul>
<ul>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/trending">Trending</a></li>
<li><a href="/news/wireless">Wireless</a></li>
</ul>
</div>
<div class="press-office-sub-menu sub-menu">
<ul>
<li><a href="//companies.mybroadband.co.za/aigs/">AIGS</a></li>
<li><a href="//companies.mybroadband.co.za/aigsinsights/">AIGS Insights</a></li>
<li><a href="//companies.mybroadband.co.za/asus/">Asus</a></li>
<li><a href="//companies.mybroadband.co.za/bbd/">BBD</a></li>
<li><a href="//companies.mybroadband.co.za/cipherwave/">CipherWave</a></li>
<li><a href="//companies.mybroadband.co.za/cloudgate/">CloudGate</a></li>
<li><a href="//companies.mybroadband.co.za/commvault/">CommVault</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/connection-telecom/">Connection Telecom</a></li>
<li><a href="//companies.mybroadband.co.za/continuitysa/">ContinuitySA</a></li>
<li><a href="//companies.mybroadband.co.za/crs/">CRS</a></li>
<li><a href="//companies.mybroadband.co.za/dvt/">DVT</a></li>
<li><a href="//companies.mybroadband.co.za/first-digital/">First Digital</a></li>
<li><a href="//companies.mybroadband.co.za/huawei-network-carrier/">Huawei Network Carrier</a></li>
<li><a href="//companies.mybroadband.co.za/iidentifii/">iiDENTIFii</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/itec/">ITEC</a></li>
<li><a href="//companies.mybroadband.co.za/masterdatamanagement/">Master Data Management</a></li>
<li><a href="//companies.mybroadband.co.za/mybroadband/">MyBroadband</a></li>
<li><a href="//companies.mybroadband.co.za/netshield/">Netshield</a></li>
<li><a href="//companies.mybroadband.co.za/networks-unlimited/">Networks Unlimited</a></li>
<li><a href="//companies.mybroadband.co.za/nutanix/">Nutanix</a></li>
<li><a href="//companies.mybroadband.co.za/redstor/">Redstor</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/sabinet/">Sabinet</a></li>
<li><a href="//companies.mybroadband.co.za/supersonic/">Supersonic</a></li>
<li><a href="//companies.mybroadband.co.za/syntech/">Syntech</a></li>
<li><a href="//companies.mybroadband.co.za/tecno/">TECNO</a></li>
<li><a href="//companies.mybroadband.co.za/turrito/">Turrito</a></li>
<li><a href="//companies.mybroadband.co.za/ul/">UL</a></li>
<li><a href="//companies.mybroadband.co.za/zte/">ZTE</a></li>
</ul>
</div>
<div class="search-sub-menu sub-menu">
<form role="search" method="get" id="searchform" action="https://mybroadband.co.za/news/">
<div>
<input type="text" class="nav-search-bar" value="" name="s" id="s" placeholder="Search" /><input style="display:none;" type="submit" value="" />
</div>
</form>
</div>
</div>
<div class="mobile-site-header">
<a href="https://mybroadband.co.za/news/" class="mobile-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png?v=1.0" alt="logo" /></a>
<div class="mobile-bar-share">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Nokia+8.3+launched+%E2%80%93+First+phone+that+can+roam+on+all+5G+networks https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#dde2aea8bfb7b8bea9e093b2b6b4bcf8efede5f3eef8efedb1bca8b3beb5b8b9f8efedf8efebf8efeee5efececf8ee9ff8efed9bb4afaea9f8efedadb5b2b3b8f8efeda9b5bca9f8efedbebcb3f8efedafb2bcb0f8efedb2b3f8efedbcb1b1f8efede89af8efedb3b8a9aab2afb6aefbbfb2b9a4e0959099f8efed9ab1b2bfbcb1f8efedb5bcaef8efeda8b3abb8b4b1b8b9f8efedb4a9aef8efedbbb4afaea9f8efede89af8efedaeb0bcafa9adb5b2b3b8f8efedf0f8efed89b5b8f8efed93b2b6b4bcf8efede5f3eef8efede89af3f8ed9cf8ed9cb5a9a9adaef8ee9cf8ef9bf8ef9bb0a4bfafb2bcb9bfbcb3b9f3beb2f3a7bcf8ef9bb3b8aaaef8ef9baeb0bcafa9adb5b2b3b8aef8ef9beee9e9ede4eaf0b3b2b6b4bcf0e5f0eef0b1bca8b3beb5b8b9f0bbb4afaea9f0adb5b2b3b8f0a9b5bca9f0bebcb3f0afb2bcb0f0b2b3f0bcb1b1f0e8baf0b3b8a9aab2afb6aef3b5a9b0b1">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
</div>
<div class="mobile-search-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<div class="mobile-menu-button"><i class="fa fa-bars" aria-hidden="true"></i></div>
</div>
<div class="mobile-search-bar">
<div class="search-bar-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<form action="/" method="get">
<input placeholder="What are you looking for?" type="text" name="s" id="search" value="" />
</form>
<div class="search-bar-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
<div class="mobile-menu">
<ul>
<li><a href="https://mybroadband.co.za/news/">Home</a></li>
<li>
<a class="mobile-expand" href="#">Categories <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/wireless">Wireless</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/internet">Internet</a></li>
<li>
<a class="mobile-expand" href="#">More <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gaming">Gaming</a></li>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/quizzes">Quizzes</a></li>
<li><a href="/news/reviews">Reviews</a></li>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/trending">Trending</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="https://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum">Forum</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="https://events.mybroadband.co.za/">Events</a></li>
<li><a href="https://deals.mybroadband.co.za/">Deals</a></li>
<li><a href="http://speedtest.mybroadband.co.za/">Speed Test</a></li>
<li><a href="/news/mybroadband-magazine-2019">Magazine</a></li>
<li><a class="mobile-expand" href="#">
About
<i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i>
</a>
<ul>
<li><a href="/news/about-us">About Us</a></li>
<li><a href="/news/advertising">Advertising</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/careers">Careers</a></li>
</ul>
</li>
</ul>
</div>
<div class="mobile-overlay">
<div class="mobile-menu-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
</header>
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<div class="the-post">
<article id="post-344097" class="post-344097 post type-post status-publish format-standard has-post-thumbnail hentry category-smartphones tag-hmd-global tag-nokia tag-nokia-1-3 tag-nokia-5-3 tag-nokia-8-3">
<header class="entry-header">
<h1 class="entry-title article-title">Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks</h1> <div class="article-meta"><span class="vcard author post-author"><span class="fn"><a href="https://mybroadband.co.za/news/author/hanno-labuschagne" title="Posts by Hanno Labuschagne" rel="author">Hanno Labuschagne</a></span></span><span class="post-date updated">23 March 2020</span></div>
</header>
<a class="post-thumbnail" href="https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html" aria-hidden="true">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript> </a>
<div class="social-section">
<div id="el-content-wrapper" class="el-content-wrapper container">
<div id="el-content" class="el-content row">
<div>
<div class="article-top-newsletter">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div>
</div>
<div>
<div class="article-share-buttons" style="display:inline-block;">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Nokia+8.3+launched+%E2%80%93+First+phone+that+can+roam+on+all+5G+networks https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#be81cdcbdcd4dbddca83f0d1d5d7df9b8c8e86908d9b8c8ed2dfcbd0ddd6dbda9b8c8e9b8c889b8c8d868c8f8f9b8dfc9b8c8ef8d7cccdca9b8c8eced6d1d0db9b8c8ecad6dfca9b8c8edddfd09b8c8eccd1dfd39b8c8ed1d09b8c8edfd2d29b8c8e8bf99b8c8ed0dbcac9d1ccd5cd98dcd1dac783f6f3fa9b8c8ef9d2d1dcdfd29b8c8ed6dfcd9b8c8ecbd0c8dbd7d2dbda9b8c8ed7cacd9b8c8ed8d7cccdca9b8c8e8bf99b8c8ecdd3dfcccaced6d1d0db9b8c8e939b8c8eead6db9b8c8ef0d1d5d7df9b8c8e86908d9b8c8e8bf9909b8eff9b8effd6cacacecd9b8dff9b8cf89b8cf8d3c7dcccd1dfdadcdfd0da90ddd190c4df9b8cf8d0dbc9cd9b8cf8cdd3dfcccaced6d1d0dbcd9b8cf88d8a8a8e878993d0d1d5d7df9386938d93d2dfcbd0ddd6dbda93d8d7cccdca93ced6d1d0db93cad6dfca93dddfd093ccd1dfd393d1d093dfd2d2938bd993d0dbcac9d1ccd5cd90d6cad3d2">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
</div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
<div class="entry-content">
<p>HMD Global has <a href="https://www.hmdglobal.com/press-releases/three-new-nokia-smartphones" target="_blank" rel="noopener noreferrer"><strong>unveiled</strong></a> its first 5G smartphone &#8211; The Nokia 8.3 5G.</p>
<p>The smartphone headlined a line-up of new HMD Global products &#8211; which included two other new Nokia smartphones, one feature phone, and a new global roaming service.</p>
<p>The company called the Nokia 8.3 5G a &#8220;truly-global, future-proof&#8221; smartphone, as it is designed to support multiple evolving 5G network deployments which are being rolled out by operators around the world.</p>
<p>&#8220;Being the first smartphone to use the Qualcomm 5G RF front-end module solution, as part of its Qualcomm Modular Platform, the Nokia 8.3 5G condenses more than 40 different RF components into a single module,&#8221; HMD Global said.</p>
<h3>Specifications</h3>
<p>The Nokia 8.3 5G is powered by a Snapdragon 765G processor with either 6GB or 8GB RAM.</p>
<p>Storage starts at 64GB and maxes out at 128GB, with the option to expand by microSD to up to 400GB.</p>
<p>On the rear, it sports a ZEISS optics quad-camera setup with a 64MP wide, 12 MP ultrawide, 2MP depth sensor, and 2MP macro lens, while the front sports a 24MP lens.</p>
<p>The smartphone is powered by a 4,500mAh battery which can be charged via the smartphone&#8217;s USB-C port.</p>
<p>For biometrics, it employs a side-mounted fingerprint sensor in the power button. The 8.3 will only be available in a blue Polar Night colour.</p>
<h3>Pricing and availability</h3>
<p>In addition to the 5G handset, two other smartphones &#8211; the mid-range Nokia 5.3 and budget Nokia 1.3 were unveiled.</p>
<p>HMD Global said that the availability, pricing, and exact variants which will be available in South Africa will be shared at a later stage.</p>
<p>Below are the specifications of the Nokia 8.3 5G.</p>
<div class="mybb_table">
<table style="width: 100%;" width="100%" cellpadding="7">
<thead>
<tr>
<th style="text-align: center;" colspan="2">Nokia 8.3 5G</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>OS</strong></td>
<td>Android 10</td>
</tr>
<tr>
<td><strong>Display</strong></td>
<td>6.81-inch 1,080 x 2,400</td>
</tr>
<tr>
<td><strong>Processor</strong></td>
<td>Qualcomm Snapdragon 765G</td>
</tr>
<tr>
<td><strong>RAM</strong></td>
<td>6GB / 8GB</td>
</tr>
<tr>
<td><strong>Storage</strong></td>
<td>64GB / 128GB, MicroSD up to 400GB</td>
</tr>
<tr>
<td><strong>Rear camera</strong></td>
<td>64MP + 12MP + 2MP + 2MP</td>
</tr>
<tr>
<td><strong>Front camera</strong></td>
<td>24MP</td>
</tr>
<tr>
<td><strong>Connectivity</strong></td>
<td>802.11ac Wi-Fi, Bluetooth 5.0</td>
</tr>
<tr>
<td><strong>Cellular</strong></td>
<td>5G</td>
</tr>
<tr>
<td width="32%"><strong>Battery</strong></td>
<td width="68%">4,500mAh</td>
</tr>
</tbody>
</table>
<p><a href="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1.jpg" data-slb-active="1" data-slb-asset="1982865549" data-slb-internal="0" data-slb-group="344097"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="aligncenter size-large wp-image-344109 lazyload" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-640x430.jpg" alt="Nokia 8.3 5G_1" data-aspectratio="640/430" width="640" height="430" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img class="aligncenter size-large wp-image-344109" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-640x430.jpg" alt="Nokia 8.3 5G_1" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Nokia-8.3-5G_1-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript></a></p>
</div>
<hr />
<h3>Now read: <a href="https://mybroadband.co.za/news/smartphones/343917-huawei-p40-pro-specifications-leaked-5g-with-50x-zoom.html" rel="bookmark">Huawei P40 Pro specifications leaked – 5G with 50x zoom</a></h3>
</div>
<footer class="entry-footer">
<div class="tags"><p><span><a href="https://mybroadband.co.za/news/tag/hmd-global" rel="nofollow tag">HMD Global</a> <a href="https://mybroadband.co.za/news/tag/nokia" rel="nofollow tag">Nokia</a> <a href="https://mybroadband.co.za/news/tag/nokia-1-3" rel="nofollow tag">Nokia 1.3</a> <a href="https://mybroadband.co.za/news/tag/nokia-5-3" rel="nofollow tag">Nokia 5.3</a> <a href="https://mybroadband.co.za/news/tag/nokia-8-3" rel="nofollow tag">Nokia 8.3</a></span></p></div>
</footer>
</article>
<div class="bottom-share">
<a class="bottom-facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');"><i class="fa fa-facebook-official" aria-hidden="true"></i> Share <span class="share-hide">on Facebook</span></a>
<a class="bottom-twitter-share" href="https://twitter.com/intent/tweet/?text=Nokia+8.3+launched+%E2%80%93+First+phone+that+can+roam+on+all+5G+networks https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html&via=mybroadband"> <i class="fa fa-twitter" aria-hidden="true"></i> Share <span class="share-hide">on Twitter</span></a>
</div>
<a href="https://mybroadband.co.za/forum/threads/nokia-8-3-launched-first-smartphone-that-can-roam-on-all-5g-networks.1075697/" class="forum-link">
<div class="link-forum">
<span class="label"><strong>Share your thoughts: </strong></span>
<span class="forum_click">Nokia 8.3 launched - First phone tha&hellip;</span> <i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
</a>
<div class="article-bottom-newsletter">
<div class="title">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Latest news</h2></div>
<div class="below_row_article_container">
<article id="post-344121" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/government/344121-21-day-nationwide-lockdown-for-south-africa.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg" class="attachment-small size-small wp-post-image lazyload" alt="President Cyril Ramaphosa" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg" class="attachment-small size-small wp-post-image" alt="President Cyril Ramaphosa" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/government/344121-21-day-nationwide-lockdown-for-south-africa.html" rel="bookmark">21-day nationwide lockdown for South Africa</a></h2> </header>
</article>
<article id="post-344065" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/science/344065-important-stats-about-the-coronavirus-outbreak-in-south-africa.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/science/344065-important-stats-about-the-coronavirus-outbreak-in-south-africa.html" rel="bookmark">Important stats about the coronavirus outbreak in South Africa</a></h2> </header>
</article>
<article id="post-344041" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/telecoms/344041-cell-c-winding-down-its-radio-access-network.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Cellphone-Tower-1-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/telecoms/344041-cell-c-winding-down-its-radio-access-network.html" rel="bookmark">Cell C winding down its radio access network</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Partner Content</h2></div>
<div class="below_row_article_container">
<article id="post-344021" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/344021-setting-up-to-work-from-home-what-you-need-to-know.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/woman-on-the-phone-P72Y3GW-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/344021-setting-up-to-work-from-home-what-you-need-to-know.html" rel="bookmark">Setting up to work from home &#8211; What you need to know</a></h2> </header>
</article>
<article id="post-343975" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/343975-microsoft-teams-work-remotely-without-feeling-remote.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header.jpg" class="attachment-small size-small wp-post-image lazyload" alt="Teams Header" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header.jpg" class="attachment-small size-small wp-post-image" alt="Teams Header" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Teams-Header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/343975-microsoft-teams-work-remotely-without-feeling-remote.html" rel="bookmark">Microsoft Teams &#8211; Work remotely without feeling remote</a></h2> </header>
</article>
<article id="post-343939" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/343939-4ir-stuck-in-measuring-your-digital-maturity.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/bcx-2-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/343939-4ir-stuck-in-measuring-your-digital-maturity.html" rel="bookmark">4IR – Stuck in measuring your digital maturity?</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="show-comments">Show comments</div>
<div style="display:none;" class="comments">
<div class="box-title"><span class="title-line"></span>
<h2>
Join the conversation
<span class="auto-load-label">
Autoload comments
<span class="switch"><span class="toggle"></span></span>
</span>
</h2>
</div>
<p class="comments-policy" style="font-size:11pt;"><span>Comments section policy:</span> MyBroadband has a <a target="_blank" href="https://mybroadband.co.za/news/mybroadband-comment-policy">new article comments policy</a> which aims to encourage constructive discussions. To get your comments published, make sure it is civil and adds value to the discussion.</p>
<div class="box-content">
<div class="disqus" data-uid="344097" data-title="Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks" data-url="https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html"></div>
</div>
</div>
</div>
<div class="single-side">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_smartphones_article/mybroadband_smartphones_article_island_1', [300, 250], 'div-gpt-ad-1516692106337-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1516692106337-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1516692106337-0'); });
</script>
</div></div> <div class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Follow us</h2></div>
<div class="box-content">
<div class="follow-buttons">
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
<div class="follow-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div> <div class="ad"><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_smartphones_article/mybroadband_smartphones_article_island_2', [300, 250], 'div-gpt-ad-1516692063787-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1516692063787-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1516692063787-0'); });
</script>
</div></div> <div id="the_poll" class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Poll</h2></div>
<div class="box-content"><div id="polls-3721" class="wp-polls">
<form id="polls_form_3721" class="wp-polls-form" action="/news/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_3721_nonce" name="wp-polls-nonce" value="50b91df390" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="3721" /></p>
<p><strong>Which South African web hosting company do you think offers the best value for money?</strong></p><div id="polls-3721-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-12739" name="poll_3721" value="12739" /> <label for="poll-answer-12739">Afrihost</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-12741" name="poll_3721" value="12741" /> <label for="poll-answer-12741">Axxess</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-12743" name="poll_3721" value="12743" /> <label for="poll-answer-12743">RSAWEB</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-12745" name="poll_3721" value="12745" /> <label for="poll-answer-12745">Xneelo</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(3721);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(3721); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-3721-loading" class="wp-polls-loading"><img src="https://mybroadband.co.za/news/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div>
</div> <div class="side_feed_article_container">
<div class="box-title"><span class="title-line"></span><h2>Recommended</h2></div>
<article id="post-344047" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/trending/344047-402-confirmed-cases-of-coronavirus-in-south-africa.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Coronavirus model" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Coronavirus model" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-model.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/trending/344047-402-confirmed-cases-of-coronavirus-in-south-africa.html" rel="bookmark">402 confirmed cases of coronavirus in South Africa</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-344043" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/business/344043-tech-companies-that-will-thrive-during-the-coronavirus-outbreak.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-300x202.png" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Google" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-300x202.png 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-594x400.png 594w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-639x430.png 639w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google.png 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-300x202.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Google" srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-300x202.png 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-594x400.png 594w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google-639x430.png 639w, https://mybroadband.co.za/news/wp-content/uploads/2018/12/Google.png 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/business/344043-tech-companies-that-will-thrive-during-the-coronavirus-outbreak.html" rel="bookmark">Tech companies that will thrive during the coronavirus outbreak</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-344035" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/trending/344035-south-african-army-prepares-to-help-fight-coronavirus.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Army Header" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Army Header" srcset="https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2017/07/Army-Header.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/trending/344035-south-african-army-prepares-to-help-fight-coronavirus.html" rel="bookmark">South African army prepares to help fight coronavirus</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-343729" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/cellular/343729-new-telkom-freeme-prices-this-is-how-they-compare-with-old-packages.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="120/86" width="120" height="86" data-src="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Telkom-logo-phone-in-hand-120x86.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Telkom logo phone in hand" /><noscript><img width="120" height="86" src="https://mybroadband.co.za/news/wp-content/uploads/2015/06/Telkom-logo-phone-in-hand-120x86.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Telkom logo phone in hand" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/cellular/343729-new-telkom-freeme-prices-this-is-how-they-compare-with-old-packages.html" rel="bookmark">New Telkom FreeMe prices &#8211; This is how they compare with old packages</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-343981" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/business-telecoms/343981-cell-c-makes-r3-9-billion-loss.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Cell C logo on iPhone" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Cell C logo on iPhone" srcset="https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2018/05/Cell-C-logo-on-iPhone.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/business-telecoms/343981-cell-c-makes-r3-9-billion-loss.html" rel="bookmark">Cell C makes R3.9-billion loss</a></h2> </header>
<div style="clear:both;"></div>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div style="clear:both;"></div>

<div class="article-top-bar">
<a href="/news" class="article-top-bar-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png" alt="logo" /></a>
<div class="article-top-bar-share">
Share this article
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#516e2224333b3432256c1f3e3a3830746361697f627463613d30243f3239343574636174636774636269636060746213746361173823222574636121393e3f347463612539302574636132303f746361233e303c7463613e3f746361303d3d74636164167463613f3425263e233a2277333e35286c191c15746361163d3e33303d746361393022746361243f2734383d343574636138252274636137382322257463616416746361223c30232521393e3f347463617c7463610539347463611f3e3a3830746361697f6274636164167f74611074611039252521227462107463177463173c2833233e303533303f357f323e7f2b307463173f342622746317223c30232521393e3f34227463176265656168667c3f3e3a38307c697c627c3d30243f323934357c37382322257c21393e3f347c253930257c32303f7c233e303c7c3e3f7c303d3d7c64367c3f3425263e233a227f39253c3d">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Nokia+8.3+launched+%E2%80%93+First+phone+that+can+roam+on+all+5G+networks https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/smartphones/344097-nokia-8-3-launched-first-phone-that-can-roam-on-all-5g-networks.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<div style="clear:both;"></div>
</div>
<div class="article-top-bar-title">
<span class="line-end"></span>
<div>
Nokia 8.3 launched &#8211; First phone that can roam on all 5G networks </div>
</div>
<div style="clear:both;"></div>
</div>

<div class="next-previous-article">
<div id="next-article">
<div class="next-arrow">
<i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
<div class="next-article-link">
<a class="the-image" href="https://mybroadband.co.za/news/government/344121-21-day-nationwide-lockdown-for-south-africa.html"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="President Cyril Ramaphosa" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="President Cyril Ramaphosa" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/President-Cyril-Ramaphosa-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
<a class="the-text" href="https://mybroadband.co.za/news/government/344121-21-day-nationwide-lockdown-for-south-africa.html">21-day nationwide lockdown for South Africa</a>
<span class="next-span">Next article</span>
</div>
</div>
<div id="previous-article">
<div class="previous-arrow">
<i class="fa fa-chevron-left" aria-hidden="true"></i>
</div>
<div class="previous-article-link">
<a class="the-text" href="https://mybroadband.co.za/news/science/344065-important-stats-about-the-coronavirus-outbreak-in-south-africa.html">Important stats about the coronavirus outbreak in South Africa</a>
<span class="previous-span">Previous article</span>
<a class="the-image" href="https://mybroadband.co.za/news/science/344065-important-stats-about-the-coronavirus-outbreak-in-south-africa.html"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/03/Coronavirus-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
</div>
</div>
</div>

</main>
</div>
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<div class="footer-sub-menu">
<ul>
<li class="footer-header"><span></span><a href="">Categories</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/motoring">Motoring</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Sections</a></li>
<li><a href="http://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum/">Forum</a></li>
<li><a href="/forum/whats-new/">What's New</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/forum/forums/classifieds-for-sale.162/">Classifieds</a></li>
<li><a href="https://deals.mybroadband.co.za/">Deals</a></li>
<li><a href="https://speedtest.mybroadband.co.za/">Speed Test</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Information</a></li>
<li><a href="/news/about-us">About</a></li>
<li><a href="/news/advertising">Advertise with us</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/rss-feeds">RSS</a></li>
<li><a href="/MyBroadband-Terms-and-Conditions.pdf">Terms &amp; Conditions</a></li>
<li><a href="/news/careers">Careers</a></li>
<li><a href="/news/notification-of-infringements">Notification of Infringements</a></li>
<li><a target="_blank" href="https://ispa.org.za/code-of-conduct/"><img style="width: 100px;" src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/ispa.png" alt="ISPA" /></a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Follow Us</a></li>
<li><a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/">Facebook</a></li>
<li><a target="_blank" rel="noopener" href="https://twitter.com/mybroadband">Twitter</a></li>
<li><a target="_blank" rel="noopener" href="https://www.youtube.com/user/mybroadbandlive">YouTube</a></li>
<li><a target="_blank" rel="noopener" href="https://www.instagram.com/mybroadband/">Instagram</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.co.za/">Internet Speed Test</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.mybroadband.co.za/">MyBroadband Speed Test</a></li>
</ul>
</div>
<div class="mobile-footer-menu">
<ul>
<li class="footer-header"><span></span><a href="">Follow us</a></li>
</ul>
<div class="follow-buttons">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&amp;hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
</div>
</div>
</footer>
<div id="wallpaper_ad" style="position:fixed;overflow:hidden;z-index:8;width:100%;margin-left:auto;margin-right:auto;left:0;right:0;top:0px;height:1080px;">
<div style="position: absolute;left:50%;">
<div style="position: relative;left:-50%;">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_smartphones_article/mybroadband_smartphones_article_wallpaper', [1920, 1080], 'div-gpt-ad-1516691377281-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1516691377281-0' style='height:1080px; width:1920px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1516691377281-0'); });
</script>
</div></div> </div>
</div>
</div>
<div class="float-newsletter-bar">
<div class="newsletter-form">
<div class="newsletter-caption">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> <span class="close-newsletter"><i class="fa fa-times"></i></span>
</div>
</div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","requestURL":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","postID":"344097","nonce":"46069d21f1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/js/frontend.js?ver=1.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.4'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var directory_uri = {"stylesheet_directory_uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/themes\/mybroadband-nightcrawler"};
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/custom.js?ver=20160819'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.8.1'></script>
<script type="text/javascript" id="slb_footer">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"1982865549":{"id":344109,"type":"image","internal":true,"source":"https:\/\/mybroadband.co.za\/news\/wp-content\/uploads\/2020\/03\/Nokia-8.3-5G_1.jpg","title":"Nokia 8.3 5G_1","caption":"","description":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
</body>
</html>
