<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
      (adsbygoogle = window.adsbygoogle || []).push({
        google_ad_client: "ca-pub-6024413815386492",
        enable_page_level_ads: true
      });
    </script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
<script>
      googletag.cmd.push(function() {
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });
    </script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-5PTGM93');</script>



<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/Montserrat-Bold.woff" type="font/woff2" crossorigin="anonymous">

<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Light.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Regular.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-SemiBold.woff" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff2" type="font/woff2" crossorigin="anonymous">
<link rel="preload" as="font" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/fonts/OpenSans-Bold.woff" type="font/woff2" crossorigin="anonymous">

<meta property="fb:app_id" content="297975627065497" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html" />
<meta property="og:title" content="Telkom CEO Sipho Maseko&#8217;s R21.8-million payday" />
<meta property="og:description" content="Telkom CEO Sipho Maseko earned a total of R21.8 million for the 2020 financial year." />
<meta property="og:image" content="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg" />
<meta property="og:image:secure_url" content="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="430" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@mybroadband">
<meta name="twitter:image" content="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg">
<meta name="twitter:description" content="Telkom CEO Sipho Maseko earned a total of R21.8 million for the 2020 financial year.">
<meta name="twitter:title" content="Telkom CEO Sipho Maseko&#8217;s R21.8-million payday ">
<meta property="article:publisher" content="https://www.facebook.com/mybroadband" />
<meta property="article:author" content="https://www.facebook.com/mybroadband" />
<meta property="article:section" content="Telecoms" />
<script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@graph": [
            {
              "@type": "NewsArticle",
              "mainEntityOfPage": {
                "@type": "WebPage",
                "@id": "https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html"
              },
              "headline": "Telkom CEO Sipho Maseko&#8217;s R21.8-million payday",
              "image": {
                "@type": "ImageObject",
                "url": "https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg",
                "height": 468,
                "width": 696
              },
              "datePublished": "7 August 2020",
              "dateModified": "7 August 2020",
              "author": {
                "@type": "Person",
                "name": "Bradley Prior"
              },
               "publisher": {
                "@type": "Organization",
                "name": "MyBroadband",
                "logo": {
                  "@type": "ImageObject",
                  "url": "https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.png"
                }
              },
              "description": "Telkom CEO Sipho Maseko earned a total of R21.8 million for the 2020 financial year."
            },
            {
              "@type": "BreadcrumbList",
              "itemListElement": [{
                "@type": "ListItem",
                "position": 1,
                "item": {
                  "@id": "https://mybroadband.co.za/news/",
                  "name": "News"
                }
              },{
                "@type": "ListItem",
                "position": 2,
                "item": {
                  "@id": "https://mybroadband.co.za/news/category/telecoms",
                  "name": "Telecoms"
                }
              }]
            }
          ]
        }
        </script>
<meta name="viewport" content="width=device-width, user-scalable=no">
<meta name="theme-color" content="#2e3339">
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent">
<link rel="manifest" href="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/manifest.json">
<script>   
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/service-worker.js').then(function(registration) {
              // Registration was successful
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }).catch(function(err) {
              // registration failed :(
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        }
    </script>
<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Telkom CEO Sipho Maseko&#8217;s R21.8-million payday</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Feed" href="https://mybroadband.co.za/news/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Comments Feed" href="https://mybroadband.co.za/news/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="MyBroadband &raquo; Telkom CEO Sipho Maseko&#8217;s R21.8-million payday Comments Feed" href="https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mybroadband.co.za\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://mybroadband.co.za/news/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='lazysizes-fadein-style-css' href='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/css/lazysizes.fadein.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #CC0000;
	border: 1px solid #CC0000;
}

</style>
<link rel='stylesheet' id='wpProQuiz_front_style-css' href='https://mybroadband.co.za/news/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/font-awesome/css/font-awesome.min.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='cyclops-style-css' href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/style.css?ver=4.9.8.5' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='cyclops-ie-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='cyclops-ie8-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='cyclops-ie7-css'  href='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='slb_core-css' href='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/lazysizes/js/lazysizes.js?ver=5.2.0'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://mybroadband.co.za/news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mybroadband.co.za/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mybroadband.co.za/news/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How COVID-19 and the lockdown impacted IT equipment sales in South Africa' href='https://mybroadband.co.za/news/hardware/362328-how-covid-19-and-the-lockdown-impacted-it-equipment-sales-in-south-africa.html' />
<link rel='next' title='What to watch on Netflix, Showmax, and Video Play this weekend' href='https://mybroadband.co.za/news/broadcasting/363152-what-to-watch-on-netflix-showmax-and-video-play-this-weekend-60.html' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://mybroadband.co.za/news/?p=363150' />
<link rel="alternate" type="application/json+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Ftelecoms%2F363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html" />
<link rel="alternate" type="text/xml+oembed" href="https://mybroadband.co.za/news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmybroadband.co.za%2Fnews%2Ftelecoms%2F363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html&#038;format=xml" />
<noscript><style>.lazyload { display: none !important; }</style></noscript>

<meta name="keywords" content="Headline,Sipho Maseko,Telkom,Telecoms" />
<meta name="description" content="Telkom CEO Sipho Maseko earned a total of R21.8 million for the 2020 financial year." />

<link rel="amphtml" href="https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html/amp"><link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-32x32.png" sizes="32x32" />
<link rel="icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-180x180.png" />
<meta name="msapplication-TileImage" content="https://mybroadband.co.za/news/wp-content/uploads/2017/07/cropped-Facebook-Profile-Picture-270x270.png" />
</head>
<body class="post-template-default single single-post postid-363150 single-format-standard group-blog no-sidebar">


<script type="text/javascript">
        (function() {
               var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
               em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
               var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
        })();
</script>
<noscript>
        <img src="//za.effectivemeasure.net/em_image" alt="" style="position:absolute; left:-5px;" />
</noscript>

<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
 
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
 
  return t;
}(document, "script", "twitter-wjs"));</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=297975627065497";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<script type="text/javascript">
_linkedin_partner_id = "485162";
window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
window._linkedin_data_partner_ids.push(_linkedin_partner_id);
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=485162&fmt=gif" />
</noscript>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5PTGM93"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="page" class="site">
<div class="site-inner">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
<div class="site-branding">
<div class="header_ad">
<div class="ad"><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_telecoms_article/mybroadband_telecoms_article_leaderboard', [728, 90], 'div-gpt-ad-1517036229482-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517036229482-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517036229482-0'); });
</script>
</div></div> </div>
<div style="clear:both;"></div>
</div>
<div class="top-bar">
<div class="top-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<p class="site-title"><a href="https://mybroadband.co.za/news/" rel="home">MyBroadband</a></p>
<div class="magazine-top-link">
<a href="https://mybroadband.co.za/news//mybroadband-magazine-2019">Magazine</a>
</div>
<div class="top-social-links">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://www.linkedin.com/company/mybroadband"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
</div>
<a class="logo" href="https://mybroadband.co.za/news">
<img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.svg" onerror="this.src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/logo.png'" alt="MyBroadband Logo">
</a>
<div style="clear:both;"></div>
</div>
<div class="site-header-main">
<nav class="menu">
<ul>
<li><a class="categories-menu" href="https://mybroadband.co.za/news/">News</a></li>
<li><a class="press-office-menu" href="http://companies.mybroadband.co.za/">Press office</a></li>
<li><a class="no-sub-menu" href="/forum/forums/news-and-current-affairs.131/">Breaking news</a></li>
<li><a class="no-sub-menu" href="/forum">Forum</a></li>
<li><a class="no-sub-menu" href="/news/industrynews">Industry news</a></li>
<li><a class="no-sub-menu" target="_blank" href="https://networkstatus.co.za/">Network Status</a></li>
<li><a class="no-sub-menu" href="http://speedtest.mybroadband.co.za/">Speed test</a></li>
<li><a class="search-menu" href="#"><i class="fa fa-search" aria-hidden="true"></i></a></li>
</ul>
</nav>
<div class="categories-sub-menu sub-menu">
<ul>
<li><a href="/news/5g">5G</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cellular">Cellular</a></li>
</ul>
<ul>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/enterprise">Enterprise</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/gaming">Gaming</a></li>
</ul>
<ul>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/internet">Internet</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/reviews">Reviews</a></li>
</ul>
<ul>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/trending">Trending</a></li>
<li><a href="/news/wireless">Wireless</a></li>
</ul>
</div>
<div class="press-office-sub-menu sub-menu">
<ul>
<li><a href="//companies.mybroadband.co.za/aigs/">AIGS</a></li>
<li><a href="//companies.mybroadband.co.za/aigsinsights/">AIGS Insights</a></li>
<li><a href="//companies.mybroadband.co.za/asus/">Asus</a></li>
<li><a href="//companies.mybroadband.co.za/bbd/">BBD</a></li>
<li><a href="//companies.mybroadband.co.za/cipherwave/">CipherWave</a></li>
<li><a href="//companies.mybroadband.co.za/cloudgate/">CloudGate</a></li>
<li><a href="//companies.mybroadband.co.za/commvault/">CommVault</a></li>
<li><a href="//companies.mybroadband.co.za/connection-telecom/">Connection Telecom</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/continuitysa/">ContinuitySA</a></li>
<li><a href="//companies.mybroadband.co.za/crs/">CRS</a></li>
<li><a href="//companies.mybroadband.co.za/dvt/">DVT</a></li>
<li><a href="//companies.mybroadband.co.za/euphoria/">Euphoria Telecom</a></li>
<li><a href="//companies.mybroadband.co.za/eset/">ESET</a></li>
<li><a href="//companies.mybroadband.co.za/first-digital/">First Digital</a></li>
<li><a href="//companies.mybroadband.co.za/headset-solutions/">Headset Solutions</a></li>
<li><a href="//companies.mybroadband.co.za/huawei-network-carrier/">Huawei Network Carrier</a></li>
</ul>
<ul>
 <li><a href="//companies.mybroadband.co.za/iidentifii/">iiDENTIFii</a></li>
<li><a href="//companies.mybroadband.co.za/itec/">ITEC</a></li>
<li><a href="//companies.mybroadband.co.za/masterdatamanagement/">Master Data Management</a></li>
<li><a href="//companies.mybroadband.co.za/mybroadband/">MyBroadband</a></li>
<li><a href="//companies.mybroadband.co.za/netshield/">Netshield</a></li>
<li><a href="//companies.mybroadband.co.za/networks-unlimited/">Networks Unlimited</a></li>
<li><a href="//companies.mybroadband.co.za/nutanix/">Nutanix</a></li>
<li><a href="//companies.mybroadband.co.za/redstor/">Redstor</a></li>
</ul>
<ul>
<li><a href="//companies.mybroadband.co.za/sabinet/">Sabinet</a></li>
<li><a href="//companies.mybroadband.co.za/supersonic/">Supersonic</a></li>
<li><a href="//companies.mybroadband.co.za/syntech/">Syntech</a></li>
<li><a href="//companies.mybroadband.co.za/tecno/">TECNO</a></li>
<li><a href="//companies.mybroadband.co.za/turrito/">Turrito</a></li>
<li><a href="//companies.mybroadband.co.za/ul/">UL</a></li>
<li><a href="//companies.mybroadband.co.za/zte/">ZTE</a></li>
</ul>
</div>
<div class="search-sub-menu sub-menu">
<form role="search" method="get" id="searchform" action="https://mybroadband.co.za/news/">
<div>
<input type="text" class="nav-search-bar" value="" name="s" id="s" placeholder="Search" /><input style="display:none;" type="submit" value="" />
</div>
</form>
</div>
</div>
<div class="mobile-site-header">
<a href="https://mybroadband.co.za/news/" class="mobile-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png?v=1.0" alt="logo" /></a>
<div class="mobile-bar-share">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Telkom+CEO+Sipho+Maseko%E2%80%99s+R21.8-million+payday https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="#" onclick="webShare(event,'https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-share-alt" aria-hidden="true"></i>
</a>
</div>
<div class="mobile-search-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<div class="mobile-menu-button"><i class="fa fa-bars" aria-hidden="true"></i></div>
</div>
<div class="mobile-search-bar">
<div class="search-bar-button"><i class="fa fa-search" aria-hidden="true"></i></div>
<form action="/" method="get">
<input placeholder="What are you looking for?" type="text" name="s" id="search" value="" />
</form>
<div class="search-bar-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
<div class="mobile-menu">
<ul>
<li><a href="https://mybroadband.co.za/news/">Home</a></li>
<li>
<a class="mobile-expand" href="#">Categories <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/wireless">Wireless</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/internet">Internet</a></li>
<li>
<a class="mobile-expand" href="#">More <i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i></a>
<ul>
<li><a href="/news/5G">5G</a></li>
<li><a href="/news/banking">Banking</a></li>
<li><a href="/news/broadcasting">Broadcasting</a></li>
<li><a href="/news/business">Business</a></li>
<li><a href="/news/business-telecoms">Business Telecoms</a></li>
<li><a href="/news/cloud-hosting">Cloud &amp; Hosting</a></li>
<li><a href="/news/columns">Columns</a></li>
<li><a href="/news/cryptocurrency">Cryptocurrency</a></li>
<li><a href="/news/energy">Energy</a></li>
<li><a href="/news/fibre">Fibre</a></li>
<li><a href="/news/gaming">Gaming</a></li>
<li><a href="/news/government">Government</a></li>
<li><a href="/news/internet-of-things">Internet of Things</a></li>
<li><a href="/news/it-services">IT Services</a></li>
<li><a href="/news/motoring">Motoring</a></li>
<li><a href="/news/quizzes">Quizzes</a></li>
<li><a href="/news/reviews">Reviews</a></li>
<li><a href="/news/science">Science</a></li>
<li><a href="/news/security">Security</a></li>
<li><a href="/news/smartphones">Smartphones</a></li>
<li><a href="/news/technology">Technology</a></li>
<li><a href="/news/trending">Trending</a></li>
</ul>
</li>
</ul>
</li>
<li><a href="https://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum">Forum</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="https://events.mybroadband.co.za/">Events</a></li>
 <li><a target="_blank" href="https://networkstatus.co.za/">Network Status</a></li>
<li><a href="http://speedtest.mybroadband.co.za/">Speed Test</a></li>
<li><a href="/news/mybroadband-magazine-2019">Magazine</a></li>
<li><a class="mobile-expand" href="#">
About
<i class="fa fa-chevron-down rotate-0" aria-hidden="true"></i>
</a>
<ul>
<li><a href="/news/about-us">About Us</a></li>
<li><a href="/news/advertising">Advertising</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/careers">Careers</a></li>
</ul>
</li>
</ul>
</div>
<div class="mobile-overlay">
<div class="mobile-menu-close"><i class="fa fa-close" aria-hidden="true"></i></div>
</div>
</header>
<div id="content" class="site-content">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<div class="the-post">
<article id="post-363150" class="post-363150 post type-post status-publish format-standard has-post-thumbnail hentry category-telecoms tag-headline tag-sipho-maseko tag-telkom">
<header class="entry-header">
<h1 class="entry-title article-title">Telkom CEO Sipho Maseko&#8217;s R21.8-million payday</h1> <div class="article-meta"><span class="vcard author post-author"><span class="fn"><a href="https://mybroadband.co.za/news/author/bradley-prior" title="Posts by Bradley Prior" rel="author">Bradley Prior</a></span></span><span class="post-date updated">7 August 2020</span></div>
</header>
<a class="post-thumbnail" href="https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html" aria-hidden="true">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="600/400" width="600" height="400" data-src="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="Telkom CEO Sipho Maseko&#8217;s R21.8-million payday" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="600" height="400" src="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Telkom CEO Sipho Maseko&#8217;s R21.8-million payday" srcset="https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko.jpg 600w, https://mybroadband.co.za/news/wp-content/uploads/2013/07/Sipho-Maseko-250x166.jpg 250w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript> </a>
<div class="social-section">
<div id="el-content-wrapper" class="el-content-wrapper container">
<div id="el-content" class="el-content row">
<div>
<div class="article-top-newsletter">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div>
</div>
<div>
<div class="article-share-buttons" style="display:inline-block;">
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Telkom+CEO+Sipho+Maseko%E2%80%99s+R21.8-million+payday https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#9fa0eceafdf5fafceba2cbfaf3f4f0f2baadafdcdad0baadafccf6eff7f0baadafd2feecfaf4f0baada9baadaca7adaea8baacddecbaadafcdadaeb1a7b2f2f6f3f3f6f0f1baadafeffee6fbfee6b9fdf0fbe6a2cbfaf3f4f0f2baadafdcdad0baadafccf6eff7f0baadafd2feecfaf4f0baadaffafeedf1fafbbaadaffebaadafebf0ebfef3baadaff0f9baadafcdadaeb1a7baadaff2f6f3f3f6f0f1baadaff9f0edbaadafebf7fabaadafadafadafbaadaff9f6f1fef1fcf6fef3baadafe6fafeedb1baafdebaafdef7ebebefecbaacdebaadd9baadd9f2e6fdedf0fefbfdfef1fbb1fcf0b1e5febaadd9f1fae8ecbaadd9ebfaf3fafcf0f2ecbaadd9aca9acaeaaafb2ebfaf3f4f0f2b2fcfaf0b2ecf6eff7f0b2f2feecfaf4f0ecb2edadaeb2a7b2f2f6f3f3f6f0f1b2effee6fbfee6b1f7ebf2f3">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
</div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
<div class="entry-content">
<p>Telkom CEO Sipho Maseko earned a total of R21.8 million for the 2020 financial year.</p>
<p>This is a reduction of more than R1 million compared to the R23.2 million he earned over the 2019 period.</p>
<p>His 2020 financial year remuneration included:</p>
<ul>
<li>A guaranteed salary of R8.83 million</li>
<li>Vested shares totalling R10.53 million</li>
<li>Unvested shares totalling R2.4 million</li>
</ul>
<p>The remainder of his remuneration includes pension, motor insurance, and funeral benefits.</p>
<p>While Maseko&#8217;s guaranteed salary and unvested shares only saw minor changes, he received over R5 million more in vested shares.</p>
<p>This was countered, however, by him not receiving a bonus this year &#8211; as was the case with all Telkom executive directors and prescribed officers.</p>
<p>Other big earners at Telkom included Deon Fredericks &#8211; who retired as CIO and took home R26.1 million &#8211; and retired Openserve CEO Alphonzo Samuels, who took home R19.5 million.</p>
<p>These two former C-level executives earned R5.7 million and R6.1 million in severance pay respectively, as well as substantial vested share payouts.</p>
<p>In total, Telkom paid its prescribed officers a total of R76.8 million for the year, which combined with executive director pay of R27.2 million, means the group paid a total of R104 million to its top executives.</p>
<p>Below are the salaries earned by Telkom executive directors and prescribed officers, including CEO Sipho Maseko.</p>
<p>The figures below include guaranteed pay (GP), short term incentives (STIs), long term incentives (LTIs), and total remuneration.</p>
<p>Other contributors to total remuneration such as motor vehicle insurance and dividends paid on unvested shares were not included in the comparison.</p>
<h3>Telkom Executive Salaries</h3>
<p><a href="https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation.jpg" data-slb-active="1" data-slb-asset="323219222" data-slb-internal="0" data-slb-group="363150"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="aligncenter size-full wp-image-307598 lazyload" data-src="https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation.jpg" alt="Telkom logo presentation" data-aspectratio="640/430" width="640" height="430" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img class="aligncenter size-full wp-image-307598" src="https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation.jpg" alt="Telkom logo presentation" width="640" height="430" srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/05/Telkom-logo-presentation-595x400.jpg 595w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript></a></p>
<div class="mybb_table">
<table style="width: 100%;" border="0" cellpadding="7">
<thead>
<tr style="background-color: #003366; font-weight: bold; color: #fff;">
<th style="text-align: center;" colspan="5">Telkom Executive Directors</th>
</tr>
</thead>
<tbody>
<tr bgcolor="CCCCCC">
<td><strong>Executive</strong></td>
<td><strong>GP</strong></td>
<td><strong>LTI</strong></td>
<td><strong>Total</strong></td>
</tr>
<tr>
<td width="40%">Sipho Maseko (CEO)</td>
<td width="20%">8,830,449</td>
<td width="20%">10,531,129</td>
<td width="20%">21,817,046</td>
</tr>
<tr>
<td>Tsholofelo Molefe (CFO)</td>
<td>4,712,456</td>
<td>&#8211;</td>
<td>5,430,087</td>
</tr>
<tr style="background-color: #003366; font-weight: bold; color: #fff;">
<th style="text-align: center;" colspan="5">Telkom Prescribed Officers</th>
</tr>
<tr bgcolor="CCCCCC">
<td><strong>Officer</strong></td>
<td><strong>GP</strong></td>
<td><strong>LTI</strong></td>
<td><strong>Total</strong></td>
</tr>
<tr>
<td>AN Samuels</td>
<td>5,407,500</td>
<td>7,510,337</td>
<td>19,474,991</td>
</tr>
<tr>
<td>DJ Fredericks</td>
<td>3,510,819</td>
<td>16,468,616</td>
<td>26,075,319</td>
</tr>
<tr>
<td>NM Lekota</td>
<td>3,766,273</td>
<td>&#8211;</td>
<td>3,766,569</td>
</tr>
<tr>
<td>AC Beukes</td>
<td>4,240,000</td>
<td>205,528</td>
<td>4,457,820</td>
</tr>
<tr>
<td>S Taukobong</td>
<td>6,300,000</td>
<td>&#8211;</td>
<td>6,312,292</td>
</tr>
<tr>
<td>PJ Bogoshi</td>
<td>5,123,000</td>
<td>&#8211;</td>
<td>5,123,296</td>
</tr>
<tr>
<td>CJ Moganwa</td>
<td>3,750,000</td>
<td>&#8211;</td>
<td>3,769,452</td>
</tr>
<tr>
<td>L Siyo</td>
<td>3,891,111</td>
<td>&#8211;</td>
<td>3,903,354</td>
</tr>
<tr>
<td>LTS Maloba</td>
<td>3,915,963</td>
<td>&#8211;</td>
<td>3,925,256</td>
</tr>
</tbody>
</table>
</div>
<h3>Now read: <a href="https://mybroadband.co.za/news/telecoms/363014-all-cell-c-network-traffic-will-move-to-mtn-but-not-until-it-can-pay-its-bills.html" rel="bookmark">All Cell C network traffic will move to MTN – But not until it can pay its bills</a></h3>
</div>
<footer class="entry-footer">
<div class="tags"><p><span><a href="https://mybroadband.co.za/news/tag/headline" rel="nofollow tag">Headline</a> <a href="https://mybroadband.co.za/news/tag/sipho-maseko" rel="nofollow tag">Sipho Maseko</a> <a href="https://mybroadband.co.za/news/tag/telkom" rel="nofollow tag">Telkom</a></span></p></div>
</footer>
</article>
<div class="bottom-share">
<a class="bottom-facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');"><i class="fa fa-facebook-official" aria-hidden="true"></i> Share <span class="share-hide">on Facebook</span></a>
<a class="bottom-twitter-share" href="https://twitter.com/intent/tweet/?text=Telkom+CEO+Sipho+Maseko%E2%80%99s+R21.8-million+payday https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html&via=mybroadband"> <i class="fa fa-twitter" aria-hidden="true"></i> Share <span class="share-hide">on Twitter</span></a>
</div>
<a href="https://mybroadband.co.za/forum/threads/telkom-ceo-sipho-masekos-reduced-r21-8-million-payday.1097056/" class="forum-link">
<div class="link-forum">
<span class="label"><strong>Share your thoughts: </strong></span>
<span class="forum_click">Telkom CEO Sipho Maseko's R21.8-mill&hellip;</span> <i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
</a>
<div class="article-bottom-newsletter">
<div class="title">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Latest news</h2></div>
<div class="below_row_article_container">
<article id="post-363152" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/broadcasting/363152-what-to-watch-on-netflix-showmax-and-video-play-this-weekend-60.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/broadcasting/363152-what-to-watch-on-netflix-showmax-and-video-play-this-weekend-60.html" rel="bookmark">What to watch on Netflix, Showmax, and Video Play this weekend</a></h2> </header>
</article>
<article id="post-362328" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/hardware/362328-how-covid-19-and-the-lockdown-impacted-it-equipment-sales-in-south-africa.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/hardware/362328-how-covid-19-and-the-lockdown-impacted-it-equipment-sales-in-south-africa.html" rel="bookmark">How COVID-19 and the lockdown impacted IT equipment sales in South Africa</a></h2> </header>
</article>
<article id="post-363090" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/gaming/363090-new-ps4-and-ps5-games-unveiled-including-star-wars-and-hitman-in-vr.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal.jpg" class="attachment-small size-small wp-post-image lazyload" alt="Vader Immortal" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal.jpg" class="attachment-small size-small wp-post-image" alt="Vader Immortal" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Vader-Immortal-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/gaming/363090-new-ps4-and-ps5-games-unveiled-including-star-wars-and-hitman-in-vr.html" rel="bookmark">New PS4 and PS5 games unveiled &#8211; Including Star Wars and Hitman in VR</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="below_article_feed">
<div class="box-title"><span class="title-line"></span><h2>Partner Content</h2></div>
<div class="below_row_article_container">
<article id="post-363110" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/363110-5-reasons-why-you-need-to-rethink-your-backup-solution.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor.png" class="attachment-small size-small wp-post-image lazyload" alt="Redstor" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor.png 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor-595x400.png 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor-300x202.png 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor.png" class="attachment-small size-small wp-post-image" alt="Redstor" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor.png 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor-595x400.png 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Redstor-300x202.png 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/363110-5-reasons-why-you-need-to-rethink-your-backup-solution.html" rel="bookmark">5 reasons why you need to rethink your backup solution</a></h2> </header>
</article>
<article id="post-363098" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/363098-why-going-digital-is-key-to-the-success-of-your-business.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Syspro-Header-Digital-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/363098-why-going-digital-is-key-to-the-success-of-your-business.html" rel="bookmark">Why going digital is key to the success of your business</a></h2> </header>
</article>
<article id="post-363060" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/industrynews/363060-hisense-2020-4k-uled-range-launched-top-tvs-at-the-best-prices.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range.jpg" class="attachment-small size-small wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range.jpg" class="attachment-small size-small wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Hisense-ULED-TV-range-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 61vw, (max-width: 1362px) 45vw, 600px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/industrynews/363060-hisense-2020-4k-uled-range-launched-top-tvs-at-the-best-prices.html" rel="bookmark">Hisense 2020 4K ULED range launched – Top TVs at the best prices</a></h2> </header>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div class="show-comments">Show comments</div>
<div style="display:none;" class="comments">
<div class="box-title"><span class="title-line"></span>
<h2>
Join the conversation
<span class="auto-load-label">
Autoload comments
<span class="switch"><span class="toggle"></span></span>
</span>
</h2>
</div>
<p class="comments-policy" style="font-size:11pt;"><span>Comments section policy:</span> MyBroadband has a <a target="_blank" href="https://mybroadband.co.za/news/mybroadband-comment-policy">new article comments policy</a> which aims to encourage constructive discussions. To get your comments published, make sure it is civil and adds value to the discussion.</p>
<div class="box-content">
<div class="disqus" data-uid="363150" data-title="Telkom CEO Sipho Maseko&#8217;s R21.8-million payday" data-url="https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html"></div>
</div>
</div>
</div>
<div class="single-side">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_telecoms_article/mybroadband_telecoms_article_island_1', [300, 250], 'div-gpt-ad-1517036289436-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517036289436-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517036289436-0'); });
</script>
</div></div> <div class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Follow us</h2></div>
<div class="box-content">
<div class="follow-buttons">
<a target="_blank" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
<div class="follow-subscribe">
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> </div>
</div>
</div> <div class="ad"><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_telecoms_article/mybroadband_telecoms_article_island_2', [300, 250], 'div-gpt-ad-1517036269296-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517036269296-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517036269296-0'); });
</script>
</div></div> <div id="the_poll" class="side-box box-poll">
<div class="box-title"><span class="title-line"></span><h2>Poll</h2></div>
<div class="box-content"><div id="polls-3990" class="wp-polls">
<form id="polls_form_3990" class="wp-polls-form" action="/news/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_3990_nonce" name="wp-polls-nonce" value="ea954650d9" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="3990" /></p>
<p><strong>Which 5G smartphone do you think is the best?</strong></p><div id="polls-3990-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14432" name="poll_3990" value="14432" /> <label for="poll-answer-14432">Huawei P40</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14434" name="poll_3990" value="14434" /> <label for="poll-answer-14434">Huawei P40 Pro</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14436" name="poll_3990" value="14436" /> <label for="poll-answer-14436">Samsung Galaxy Note 20 5G</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14438" name="poll_3990" value="14438" /> <label for="poll-answer-14438">Samsung Galaxy Note 20 Ultra 5G</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14440" name="poll_3990" value="14440" /> <label for="poll-answer-14440">Huawei P40 Lite 5G</label></li>
<li style="border-bottom: 1px solid #E1E1E1; margin-bottom: 0.5em; padding-bottom: 0.5em;"><input type="radio" id="poll-answer-14442" name="poll_3990" value="14442" /> <label for="poll-answer-14442">LG Velvet</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(3990);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(3990); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-3990-loading" class="wp-polls-loading"><img src="https://mybroadband.co.za/news/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
</div>
</div> <div class="side_feed_article_container">
<div class="box-title"><span class="title-line"></span><h2>Recommended</h2></div>
<article id="post-363014" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/telecoms/363014-all-cell-c-network-traffic-will-move-to-mtn-but-not-until-it-can-pay-its-bills.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="120/86" width="120" height="86" data-src="https://mybroadband.co.za/news/wp-content/uploads/2016/06/Robert-Rob-Shuter-MTN-CEO-120x86.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Robert Rob Shuter MTN CEO" /><noscript><img width="120" height="86" src="https://mybroadband.co.za/news/wp-content/uploads/2016/06/Robert-Rob-Shuter-MTN-CEO-120x86.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Robert Rob Shuter MTN CEO" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/telecoms/363014-all-cell-c-network-traffic-will-move-to-mtn-but-not-until-it-can-pay-its-bills.html" rel="bookmark">All Cell C network traffic will move to MTN &#8211; But not until it can pay its bills</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-363086" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/hardware/363086-intel-11th-gen-cpu-launch-date-revealed.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-300x202.png" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Intel-9th-Gen-Core-2" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-300x202.png 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-596x400.png 596w, https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554.png 639w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-300x202.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Intel-9th-Gen-Core-2" srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-300x202.png 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554-596x400.png 596w, https://mybroadband.co.za/news/wp-content/uploads/2019/01/Intel-9th-Gen-Core-2-e1572359433554.png 639w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/hardware/363086-intel-11th-gen-cpu-launch-date-revealed.html" rel="bookmark">Intel 11th-gen CPU launch date revealed</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-363084" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/software/363084-new-features-coming-to-whatsapp-for-iphone-2.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline-.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline--595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2019/11/WhatsApp-headline-.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/software/363084-new-features-coming-to-whatsapp-for-iphone-2.html" rel="bookmark">New features coming to WhatsApp for iPhone</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-363080" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/gaming/363080-nintendo-profit-smashes-estimates.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="Nintendo Switch Joy-Con neon" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Nintendo Switch Joy-Con neon" srcset="https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2017/02/Nintendo-Switch-Joy-Con-neon.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/gaming/363080-nintendo-profit-smashes-estimates.html" rel="bookmark">Nintendo profit smashes estimates</a></h2> </header>
<div style="clear:both;"></div>
</article>
<article id="post-363070" class="row_article">
<a class="post-thumbnail" href="https://mybroadband.co.za/news/trending/363070-south-africa-starts-covid-19-plasma-treatment-study.html">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="300/202" width="300" height="202" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /><noscript><img width="300" height="202" src="https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-300x202.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-300x202.jpg 300w, https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/04/Covid-19-Coronavirus.jpg 640w" sizes="(max-width: 300px) 85vw, 300px" /></noscript> </a>
<header class="entry-header">
<h2 class="entry-title"><a href="https://mybroadband.co.za/news/trending/363070-south-africa-starts-covid-19-plasma-treatment-study.html" rel="bookmark">South Africa starts COVID-19 plasma treatment study</a></h2> </header>
<div style="clear:both;"></div>
</article>
<div style="clear:both;"></div>
</div>
</div>
<div style="clear:both;"></div>

<div class="article-top-bar">
<a href="/news" class="article-top-bar-logo"><img src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/bar-logo.png" alt="logo" /></a>
<div class="article-top-bar-share">
Share this article
<a class="linkedin-share" href="javascript:popup('https://www.linkedin.com/shareArticle?mini=true&url=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-linkedin" aria-hidden="true"></i>
</a>
<a class="email-share" target="_blank" href="/cdn-cgi/l/email-protection#3e014d4b5c545b5d4a036a5b525551531b0c0e7d7b711b0c0e6d574e56511b0c0e735f4d5b55511b0c081b0c0d060c0f091b0d7c4d1b0c0e6c0c0f100613535752525751501b0c0e4e5f475a5f47185c515a47036a5b525551531b0c0e7d7b711b0c0e6d574e56511b0c0e735f4d5b55511b0c0e5b5f4c505b5a1b0c0e5f1b0c0e4a514a5f521b0c0e51581b0c0e6c0c0f10061b0c0e535752525751501b0c0e58514c1b0c0e4a565b1b0c0e0c0e0c0e1b0c0e5857505f505d575f521b0c0e475b5f4c101b0e7f1b0e7f564a4a4e4d1b0d7f1b0c781b0c7853475c4c515f5a5c5f505a105d5110445f1b0c78505b494d1b0c784a5b525b5d51534d1b0c780d080d0f0b0e134a5b52555153135d5b51134d574e565113535f4d5b55514d134c0c0f13061353575252575150134e5f475a5f4710564a5352">
<i class="fa fa-envelope" aria-hidden="true"></i>
</a>
<a class="whatsapp-share" href="javascript:popup('https://wa.me/?text=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</a>
<a class="twitter-share" href="https://twitter.com/intent/tweet/?text=Telkom+CEO+Sipho+Maseko%E2%80%99s+R21.8-million+payday https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html&via=mybroadband">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a class="facebook-share" href="javascript:popup('https://www.facebook.com/sharer/sharer.php?u=https://mybroadband.co.za/news/telecoms/363150-telkom-ceo-sipho-masekos-r21-8-million-payday.html');">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<div style="clear:both;"></div>
</div>
<div class="article-top-bar-title">
<span class="line-end"></span>
<div>
Telkom CEO Sipho Maseko&#8217;s R21.8-million payday </div>
</div>
<div style="clear:both;"></div>
</div>

<div class="next-previous-article">
<div id="next-article">
<div class="next-arrow">
<i class="fa fa-chevron-right" aria-hidden="true"></i>
</div>
<div class="next-article-link">
<a class="the-image" href="https://mybroadband.co.za/news/broadcasting/363152-what-to-watch-on-netflix-showmax-and-video-play-this-weekend-60.html"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/On-the-Basis-of-Sex-header-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
<a class="the-text" href="https://mybroadband.co.za/news/broadcasting/363152-what-to-watch-on-netflix-showmax-and-video-play-this-weekend-60.html">What to watch on Netflix, Showmax, and Video Play this weekend</a>
<span class="next-span">Next article</span>
</div>
</div>
<div id="previous-article">
<div class="previous-arrow">
<i class="fa fa-chevron-left" aria-hidden="true"></i>
</div>
<div class="previous-article-link">
<a class="the-text" href="https://mybroadband.co.za/news/hardware/362328-how-covid-19-and-the-lockdown-impacted-it-equipment-sales-in-south-africa.html">How COVID-19 and the lockdown impacted IT equipment sales in South Africa</a>
<span class="previous-span">Previous article</span>
<a class="the-image" href="https://mybroadband.co.za/news/hardware/362328-how-covid-19-and-the-lockdown-impacted-it-equipment-sales-in-south-africa.html"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-aspectratio="640/430" width="640" height="430" data-src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" alt="" data-srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /><noscript><img width="640" height="430" src="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline.jpg 640w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-595x400.jpg 595w, https://mybroadband.co.za/news/wp-content/uploads/2020/08/Work-from-home-headline-300x202.jpg 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 88vw, 1200px" /></noscript></a>
</div>
</div>
</div>

</main>
</div>
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<div class="footer-sub-menu">
<ul>
<li class="footer-header"><span></span><a href="">Categories</a></li>
<li><a href="/news/telecoms">Telecoms</a></li>
<li><a href="/news/broadband">Broadband</a></li>
<li><a href="/news/adsl">ADSL</a></li>
<li><a href="/news/cellular">Cellular</a></li>
<li><a href="/news/hardware">Hardware</a></li>
<li><a href="/news/software">Software</a></li>
<li><a href="/news/gadgets">Gadgets</a></li>
<li><a href="/news/motoring">Motoring</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Sections</a></li>
<li><a href="http://companies.mybroadband.co.za/">Press Office</a></li>
<li><a href="/forum/forums/news-and-current-affairs.131/">Breaking News</a></li>
<li><a href="/forum/">Forum</a></li>
<li><a href="/forum/whats-new/">What's New</a></li>
<li><a href="/news/industrynews">Industry News</a></li>
<li><a href="/forum/forums/classifieds-for-sale.162/">Classifieds</a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Information</a></li>
<li><a href="/news/about-us">About</a></li>
<li><a href="/news/advertising">Advertise with us</a></li>
<li><a href="/news/contact">Contact</a></li>
<li><a href="/news/rss-feeds">RSS</a></li>
<li><a href="/MyBroadband-Terms-and-Conditions.pdf">Terms &amp; Conditions</a></li>
<li><a href="/news/careers">Careers</a></li>
<li><a href="/news/notification-of-infringements">Notification of Infringements</a></li>
<li><a target="_blank" href="https://ispa.org.za/code-of-conduct/"><img style="width: 100px;" src="https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/img/ispa.png" alt="ISPA" /></a></li>
</ul>
<ul>
<li class="footer-header"><span></span><a href="">Follow Us</a></li>
<li><a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/">Facebook</a></li>
<li><a target="_blank" rel="noopener" href="https://twitter.com/mybroadband">Twitter</a></li>
<li><a target="_blank" rel="noopener" href="https://www.youtube.com/user/mybroadbandlive">YouTube</a></li>
<li><a target="_blank" rel="noopener" href="https://www.instagram.com/mybroadband/">Instagram</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.co.za/">Internet Speed Test</a></li>
<li><a target="_blank" rel="noopener" href="http://speedtest.mybroadband.co.za/">MyBroadband Speed Test</a></li>
<li><a target="_blank" rel="noopener" href="https://networkstatus.co.za/">Network Status</a></li>
</ul>
</div>
<div class="mobile-footer-menu">
<ul>
<li class="footer-header"><span></span><a href="">Follow us</a></li>
</ul>
<div class="follow-buttons">
<a target="_blank" rel="noopener" href="https://www.facebook.com/mybroadband/"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://twitter.com/mybroadband"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://mybroadband.co.za/news/rss-feeds"><i class="fa fa-rss" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://play.google.com/store/apps/details?id=com.tapatalk.mybroadbandcozavb&amp;hl=en"><i class="fa fa-android" aria-hidden="true"></i></a>
<a target="_blank" rel="noopener" href="https://itunes.apple.com/us/app/mybroadband/id399206336?mt=8"><i class="fa fa-apple" aria-hidden="true"></i></a>
</div>
</div>
</div>
</footer>
<div id="wallpaper_ad" style="position:fixed;overflow:hidden;z-index:8;width:100%;margin-left:auto;margin-right:auto;left:0;right:0;top:0px;height:1080px;">
<div style="position: absolute;left:50%;">
<div style="position: relative;left:-50%;">
<div class="ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/21673219652/mybroadband_telecoms_article/mybroadband_telecoms_article_wallpaper', [1920, 1080], 'div-gpt-ad-1517036212163-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1517036212163-0' style='height:1080px; width:1920px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1517036212163-0'); });
</script>
</div></div> </div>
</div>
</div>
<div class="float-newsletter-bar">
<div class="newsletter-form">
<div class="newsletter-caption">Subscribe to our daily newsletter</div>
<form class="subscribe-form" action="" method="post">
<input type="email" name="email" class="newsletter-subscribe" placeholder="Your email address">
<button name="subscribe" class="subscribe-class">Subscribe</button>
<div style="clear:both;"></div>
<span class="newsletter-response"></span>
</form> <span class="close-newsletter"><i class="fa fa-times"></i></span>
</div>
</div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","requestURL":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","postID":"363150","nonce":"571f987300"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/post-views-counter/js/frontend.js?ver=1.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/mybroadband.co.za\/news\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var directory_uri = {"stylesheet_directory_uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/themes\/mybroadband-nightcrawler"};
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/themes/mybroadband-nightcrawler/js/custom.js?ver=20160819'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.core.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/client/js/prod/lib.view.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/baseline/js/prod/client.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/themes/default/js/prod/client.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/item/js/prod/tag.item.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/template-tags/ui/js/prod/tag.ui.js?ver=2.8.1'></script>
<script type='text/javascript' src='https://mybroadband.co.za/news/wp-content/plugins/simple-lightbox/content-handlers/image/js/prod/handler.image.js?ver=2.8.1'></script>
<script type="text/javascript" id="slb_footer">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"323219222":{"id":307598,"type":"image","internal":true,"source":"https:\/\/mybroadband.co.za\/news\/wp-content\/uploads\/2019\/05\/Telkom-logo-presentation.jpg","title":"Telkom logo presentation","caption":"","description":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/mybroadband.co.za\/news\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
</body>
</html>
