Join us now. It is free, and it takes less than 1 minute to register.
Register now
Subscribe to our daily newsletter. It is free, and it comes with many benefits.

+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 24

Thread: Mega 105WR Firmware bug

  1. #1

    Default Mega 105WR Firmware bug

    I am currently on my third Mega 105WR router from Telkom that I use in my office. I got this new one from them yesterday. Each one has had the same problem, so I am beginning to think it is a firmware fault or similar.

    I am trying to change the WPA TKIP Pre-Shared Key from the default which is printed on the bottom of the router to my own custom one which contains numbers & letters. When I click the Apply button, the key does not change and I get a notice in red towards the top of the page that says: “Error found on page”.

    If I choose a password that only has numbers (eg: 1234567890), it is accepted and I don’t get the error. Of course, this kind of password is not safe, so in order to change it back to anything else, I've got to do a factory reset on it to get back to the default key.

    It's got the initial firmware version 99.70.4 on it. Telkomphones haven't responded to a request for assistance.

    I use a Mega 200VWR at home and have had no problem what so ever in changing the WPA pre-shard key.

    Can anyone else comment if they experience the same thing?

  2. #2


    I have just experienced exactly the same problem. As above, only numerical passwords are accepted. There are also no firmware updates available for the 105WR (

  3. #3


    I've also owned the Mega 100WR2 router. It worked fine and came with 99.70.1 firmware on it. I noticed that there was another firmware available (99.70.2) so I installed that. Worked fine. Then, 99.70.4 was available and I installed that. That's when I had the password problem on that model router - it then would not accept downgrading the firmware back to 99.70.2. It was returned to Telkom and that's when they gave me my first Mega in actual fact I'm on my 4th router because of the same issue which definitely appears to be a firmware bug.

    Would be nice if 2csolutions would respond in any way.

  4. #4


    Exactly the same thing happened to me last night. Mine I think was more of an electricity thing - because it never did it before.

    If I have the same problem - anything you change on that security page will not stick - not just the key.

    I upgraded firmware from - worked straight away.

    Hope that helps

  5. #5


    Hey retromodcoza
    Thanks for the feedback.
    Did you upgrade with the 99.70.4 firmware that is available for the Mega 105WR?

  6. #6


    Hey, I got a reply from 2ctelecoms:

    Good day

    We are aware that there is a problem with changing of the WPA key on the Mega 105WR. Unfortunately our engineers are still currently attending to the problem and they assure me that they will soon have a solution to the problem.
    We have found that you are able to change the WPA key but it has to be 10 characters long and in hexadecimal i.e. numbers will run from 0 to 9 and letters from a to f.

    As soon as we have the solution we will let you know.


  7. #7


    Just to let you know, I got sent a new firmware file that sorted out the WPA key encryption bug described here. It now works fine. I notice it's not posted on the website so if anyone wants it, leave your email and I'll send it to you.

  8. #8


    I'm glad this finally got sorted out. Would have been nice if they'd posted it on the website though... Please could you email it to me (my email address is my forum username at Gmail). Thanks :-)
    Last edited by michael003; 04-04-2008 at 06:07 PM.

  9. #9
    Super Grandmaster
    Join Date
    Jul 2004


    Thanks for informing us, I'll rather wait for telkom to release an official update.

  10. #10


    Hi, please send me the firmware update. [email protected]

  11. #11


    please send updated firmware to [email protected], thx

  12. #12

  13. #13


    have switched off AP and attached Zyxel AP working nicely because encryption is easy managed, I am going to take this c**p router back to Telkom.

  14. #14


    more good news on this 'wonderful' piece of equipment, the access control does not work either - goodbye piece of junk router

  15. #15

    Default My woderfull "@" 105WR

    Gamer , would you mind mailing me the fix you have? My username at
    Other wise i think my jack russel would love a new toy

+ Reply to Thread
Page 1 of 2 12 LastLast

Tags for this Thread



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts