Join us now. It is free, and it takes less than 1 minute to register.
Register now
Subscribe to our daily newsletter. It is free, and it comes with many benefits.

+ Reply to Thread
Results 1 to 6 of 6

Thread: Problems? with the Linksys WRT54G? advice needed!!!!

  1. #1

    Default Problems? with the Linksys WRT54G? advice needed!!!!

    Hi all

    I have found plenty of topics on a google search about the Linksys (the same one we are using in the kit) Router dropping the connection when doing big file transfers over the wireless side of the link.

    Apparently when copying a 50 mb and bigger file the Linksys drops the wireless connection...

    Have any of the Guru's picked up this problem?

    Does this problem only affect routers on the Std.. Firmware?

    or is this a Hardware problem...

    I am in the process of saving money to by 2 routers and 2 grids but I don't want to spend the money if I am going to have problems like this...

    Any light shed on this would be greatly appreciated!


  2. #2


    As I recall, Linksys themselves fixed this with a flash upgrade that overclocked the board ever so slightly ...

    TheRodent may be able to provide more insights than I ever could on this unit ....

  3. #3


    I think with the latest Linksys beta firmware, the problem gets fixed. Otherwise use one of the alternative firmwares like HyperWRT or OpenWRT (more advanced)

  4. #4


    i run alchemy on my two wrt's, they run flawlessly bridgeing my two networks!

  5. #5


    ...and I run DD-WRT, no problems here either.

  6. #6


    The problem is very specific to the Linksys WRT54G version 2.2. Check the underside of your router, the version 2.2 should be printed next to the "Model:WRT54G" on the barcoded sticker.

    A memory bus design problem in these models causes a fatal memory access error, when there is a large amount of data transferred across the wireless/ethernet interfaces, or when data with specific byte patterns are transferred.

    The fix, is to slightly overclock the router, which changes the memory bus speed and makes the problem disappear. Linksys has released a "beta" official firmware release now, which supposedly fixes this problem. It's available at

    If you are using third party firmware, such as sveasoft, dd-wrt, or openwrt, you can fix the issue by getting a shell on your router via telnet/ssh, and typing in the following commands:

    nvram set clkfreq=216
    nvram commit
    This does essentially the same as what Linksys's beta firmware does.

    Hope it helps.

+ Reply to Thread



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts