Join us now. It is free, and it takes less than 1 minute to register.
Register now
Subscribe to our daily newsletter. It is free, and it comes with many benefits.

+ Reply to Thread
Results 1 to 11 of 11

Thread: D-Link DAP-1360 Wireless N Range Extender - Problems

  1. #1

    Default D-Link DAP-1360 Wireless N Range Extender - Problems

    Hi guys,
    I decided to go for a full wireless N range setup at home and got the following D-Link devices:
    D-link DSL-2760U rangebooster N ADSLmodem
    D-Link DAP-1360 Wireless N Range Extender

    The DSL-2760U ADSLmodem router work like a bomb! Excellent piece of hardware! My adsl has never been this fast and working 100%..

    My issue is with the DAP-1360 Range extender.. I connected the device and used the setup wizard to set it to repeater mode and is working until you connect something to it!! My laptop and 2 others(one laptop is N enabled) and my phone(also N enabled) will stay connected for about 2min's +- then the connection gets dropped and throughput is very slow! Sometimes after it has been dropped the connection just never returns and it keeps on trying to connect until i reset the AP. It does not matter if one device or all is connected, all connections gets dropped after a few minutes...

    My DAP-1360 is Hardware: 1A, Firmware 1.01. There is no update available on the firmware..

    On the D-Link forums i found numerous complaints about this device and dropped connections and some that got it working..

    I spent hours resetting the device and trying all the different configs i could get, only using b+g only using g, manual settings, wizard settings.. And so on.. But to no avail will it work properly when in repeater mode..

    For the last week or so i had the AP set to access point mode with a different SSID and so far so good but its not the way i want it to work.. Some recommend RMA to get the B1 hardware version with Firmware 2.xx.

    Does anyone have the DAP-1360 setup in repeater mode and work 100%?! Please save your config and upload it for me!?! PLEASE!
    Anyone else got an idea i can try to get it working in repeater mode!?
    Also how do i setup my wifi to move from one AP to the next AP without losing connection or manually reconnecting to the closest AP, cant seem to find any info on how to set this up on the D-Link devices i have..??
    ~*!Needle in my mind!*~

  2. #2



    Did you manage to get it working?

  3. #3


    You need to upgrade the firmware to rev B, then your problem goes away. See thread

  4. #4


    same problem here, it works for a while...after that I have to reset the thing...downloading the new firmware now to see if it works!

  5. #5


    Interesting thread that was one I have been recommended but chose to get the planet WNAP-3000PE, I have the same router but cannot get it to work in any modes! I also tried the D-Link DAP 1155 in both AP and bridge but not the configuration I need. I need a network expert in CT to now advise me before I buy any more hardware! Any suggestions?

  6. #6


    Currently have 2 access points, 1 netgear (ADSL wireless router,upstairs) downstairs i have the d-link dap-1360. Running the 2.1 firmware which i see is the latest on the d-linkR SA website. Find that the d-link can be ridiculously slow at times when browsing the internet (using Ipad) at times it takes so long for video's to load but if i connect to the netgear router the videos stream perfectly.


  7. #7


    Bought this AP a few days ago and wow, it's so crap..

    Using it as a repeater and it just randomly disconnects from my network - have to reboot but then it's reset to default username/password for some inexplicable reason, but kept all the other settings.

    Hardware version C1 latest firmware 3.02

  8. #8

    Default D-Link DAP-1360 Wireless N Range Extender - Problems

    Thanks for the heads up, I need a range extender and it seems this is one to avoid.

  9. #9
    Senior Member
    Join Date
    Aug 2010
    Parklands, Western Cape


    I made the mistake of buying this without properly researching it. It's still junk, so avoid at all costs!

  10. #10

    Unhappy D-Link DAP-1360 VS Lenovo

    Hi all, this is my first time writing on this site.

    We have exactly the same issue with our D-Link access point, but only with Lenovo devices. My stolen Samsung and our Dell laptops and various cellphones have no problem connecting and staying connected. Has someone else maybe encountered this problem just between D-Link and Lenovo?
    Last edited by dspaul; 01-09-2016 at 03:42 PM.

  11. #11


    Hi Guys

    Hi have spent 3 weeks only to find that the DAP-1360 is not compatible with the DLINK DSL 2750U router (HW T1).

    I have bought the DAP-1360 extender with the false promise that it will work with any Dlink router as a wifi repeater. I could set it up easily to repeat the wifi signal from my 2750U router, but then it disconnects and refuses any more wifi connections after a few hours. I upgraded the firmware of all devices with no luck. Then took my whole setup to Dlink Support in Centurion (thanks Roger for the friendly service). They also could not get it working, even with other firmware versions. I was advised to change my router, which I did by borrowing the same Dlink model from a friend, which also showed the same disconnect symptoms. Eventually I got the setup working with an old billion router. Therefore if you still own the Dlink DSL 2750U T1 router, do not buy the DAP 1360 extender as it is not compatible and will disconnect all wifi devices after a few hours. IN fact, I've tried another wifi extender brand (Totolink) which also did not work with my 2750U router which let me suspect that the router is not compatible with any wifi extender.

+ Reply to Thread



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts