--Story--
So my line got struck by lightning about 5 times. The last time was around November. After each strike, my internet was fine, but my router got burnt. Though the last time it got struck my internet was off. I phoned telkom and the technician said the fibre guys plugged out my port? This was delivered to me via 3rd person, since I didn't talk to him/her, so I'm unsure if this is true

--Speed problems--
Since then my line has been pure garbage. I'd phone telkom and say my line is synced at 2mbs, then they'll do a port reset and sometimes it goes back to 4mbs. 2-4 weeks later it's sitting at 2mbs speed again and the cycle continues

--Ping Problems--
Sometimes my ping will sit at 18 ping(I check my ping via Teamspeak3 on the nag server, which is hosted by my ISP, Afrihost), but other times it'll be 200-600. At night(anywhere between 8pm and 6am) my ping is anywhere from 1000-5000, but it stays between 1500-2500 at most times. It reads 2000+-2000, meaning my ping can be anywhere from 0 - 4000(when it reads 5000 ping it reads as 5000+- 4000 or something btw). I have done numerous tests on my side. The problem lies with telkom 100%. My device is the only one connected and I have netlimiter, so I can see nothing is downloading
TL;DR My line is very unstable with abnormally high ping and it is telkom

--Technician Problems--
Ever since this happened, I opened a a few faults. there's been 4 technicians that I've spoken to. None of them can find the problem, or try. The 2nd technician was from a company called "something" wireless. Can't remember the 1st bit of the name. Regardless. She came here and said the problem is my fault. She did a few tests and said she can't do anything and closed the fault. So I opened another one on the 22nd of February and my line is still garbage.

--Desperation Problem--
Is there anybody that might know what the problem is? I saw people installing fibre in 2014/2015 and we still can't get fibre, even though the black box on my pole was installed about 10 months ago, so fibre is out of the question.


TL;DR
My ping is bad, line speed goes down every 2-4 weeks or so, 4 Technicians can't find the problem

PLEASE HELP