Join us now. It is free, and it takes less than 1 minute to register.
Register now
Subscribe to our daily newsletter. It is free, and it comes with many benefits.


+ Reply to Thread
Results 1 to 7 of 7

Thread: *180# not working – Connection problem or invalid MMI code

  1. #1
    Admin rpm's Avatar
    Join Date
    Jul 2003
    Location
    Johannesburg
    Posts
    63,462
    Blog Entries
    17
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)

    Question *180# not working – Connection problem or invalid MMI code

    I am on Telkom and am trying to convert airtime into a data bundle.

    However, when I use the *180# USSD code, I get the error “Connection problem or invalid MMI code”.

    I am out of data – can that be the problem?

  2. #2
    The Legend Pho3nix's Avatar
    Join Date
    Jul 2009
    Location
    On the toilet
    Posts
    26,631
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Nah, it happens from time to time lately. You can buy Data either from the telkom app or going to telkom.co.za and signing in via simcard.
    Disclaimer:All posts are personal opinion and not the opinion of anyone else or any other entity.

    Quote Originally Posted by YingYang View Post
    Jesus christ how ugly are you?

  3. #3
    Admin rpm's Avatar
    Join Date
    Jul 2003
    Location
    Johannesburg
    Posts
    63,462
    Blog Entries
    17
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Pho3nix View Post
    Nah, it happens from time to time lately. You can buy Data either from the telkom app or going to telkom.co.za and signing in via simcard.
    Thanks for the feedback. So basically the USSD system gives problems from time to time?

  4. #4
    Super Grandmaster DanDango's Avatar
    Join Date
    Sep 2013
    Location
    Amanzimtoti
    Posts
    6,146
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by rpm View Post
    I am on Telkom and am trying to convert airtime into a data bundle.

    However, when I use the *180# USSD code, I get the error “Connection problem or invalid MMI code”.

    I am out of data – can that be the problem?
    I'm getting the same error on both *180# and *123# . I have 3gb mobile data remaining, not a data problem maybe telkom server problem.
    I’m not anti-social; I’m just not user friendly.

  5. #5
    The Legend Pho3nix's Avatar
    Join Date
    Jul 2009
    Location
    On the toilet
    Posts
    26,631
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by rpm View Post
    Thanks for the feedback. So basically the USSD system gives problems from time to time?
    Yeah. Experienced it on two different sims. Been a week since I saw the error though. Some people been asking Telkom about it since June



    Link to tweet : https://twitter.com/trinitymolobi/st...726068736?s=21
    Disclaimer:All posts are personal opinion and not the opinion of anyone else or any other entity.

    Quote Originally Posted by YingYang View Post
    Jesus christ how ugly are you?

  6. #6
    Admin rpm's Avatar
    Join Date
    Jul 2003
    Location
    Johannesburg
    Posts
    63,462
    Blog Entries
    17
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Pho3nix View Post
    Yeah. Experienced it on two different sims. Been a week since I saw the error though. Some people been asking Telkom about it since June.
    Thanks for the info. It is quite astonishing that an operator would not be very concerned about a sales channel giving problems.

  7. #7
    Admin rpm's Avatar
    Join Date
    Jul 2003
    Location
    Johannesburg
    Posts
    63,462
    Blog Entries
    17
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)

    Default

    An update: This morning *180# worked perfectly, and I was able to load a data bundle as expected.

+ Reply to Thread

Similar Threads

  1. Connection failed. The profile is invalid.
    By DamianS in forum Telkom Mobile Data
    Replies: 2
    Last Post: 08-02-2018, 11:20 AM
  2. invalid mmi error code
    By stormchaser in forum Android
    Replies: 3
    Last Post: 16-10-2011, 11:28 PM
  3. Yesterday my internet connection stopped working | Very wierd problem
    By AthenianOwl in forum ADSL and VDSL Discussions
    Replies: 7
    Last Post: 07-09-2010, 09:14 PM
  4. "INVALID PHONE NUMBER" problem
    By spiff in forum MTN Mobile Data
    Replies: 11
    Last Post: 09-04-2010, 01:21 PM
  5. Problem loging in to mxit - invalid pin
    By BrokenLink in forum Cellular: Mobile Phones, Call Contracts, Content, MMS and SMS
    Replies: 0
    Last Post: 11-10-2009, 07:33 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •