Block all incoming calls on data sim (Android 10)

Mister 45

Executive Member
Joined
Nov 10, 2011
Messages
6,500
I'm probably being an idiot, but how would I go about blocking all incoming calls on my data sim? It seems the previous owner had a very casual attitude towards paying his debts.
Bonus points if the solution blocks sms as well.
I'm on Android 10, Poco X3.
 

ld13

Honorary Master
Joined
Oct 28, 2005
Messages
12,549
Forward/divert all calls to voicemail?

Kill the SMS centre number? Although you are probably using the sim in a router that might not have these specific settings.
 

Mister 45

Executive Member
Joined
Nov 10, 2011
Messages
6,500
Forward/divert all calls to voicemail?

Kill the SMS centre number? Although you are probably using the sim in a router that might not have these specific settings.
The forward trick might work, I'll give it a go. I'm using the as a second sim in my phone, that's why it's a pain in the lower intestine.
 

AntennaMan

Expert Member
Joined
Apr 17, 2014
Messages
1,965
I'm probably being an idiot, but how would I go about blocking all incoming calls on my data sim? It seems the previous owner had a very casual attitude towards paying his debts.
Bonus points if the solution blocks sms as well.
I'm on Android 10, Poco X3.
I'll have a look a bit later. We had to do something similar on my wife's phone.
 

ld13

Honorary Master
Joined
Oct 28, 2005
Messages
12,549
The forward trick might work, I'll give it a go. I'm using the as a second sim in my phone, that's why it's a pain in the lower intestine.
Yep, forwarding will work 100% as it is done network side and the call never reaches the phone afaik. Just check that your voicemail is disabled or somthing. Alternatively you could bar incoming calls.

As you are using the sim in a phone, you should also be able to butcher its SMS settings. On my phone it is called the 'message centre' number, and changing that should kill incoming SMS messages.
 
Last edited:

Mister 45

Executive Member
Joined
Nov 10, 2011
Messages
6,500
Yep, forwarding will work 100% as it is done network side and the call never reaches the phone afaik. Just check that your voicemail is disabled or somthing. Alternatively you could bar incoming calls.

As you are using the sim in a phone, you should also be able to butcher its SMS settings. On my phone it is called the 'message centre' number, and changing that should kill incoming SMS messages.
Ok, I'll have a look. How do I bar incoming calls? I've searched for the setting but can't find it.
 

dusi

Senior Member
Joined
Nov 11, 2017
Messages
811
How do you bar incoming calls on android? I'm getting several telemarketing calls a week, super annoying when they call in the morning or weekend.
 
Top