Microsoft Reportviewer issue

Solarion

Honorary Master
Joined
Nov 14, 2012
Messages
19,174
I've not used this in a while so things have changed a bit.

I'm having to quickly doctor up a WinForm app with a report. In VS2017 the reportviewer is no longer available so you pretty much have to add it:


Anyway after doing that, I get the option to Design New Report however nothing happens when clicking it. Is there a better way to do this? :unsure:

 

schuits

Expert Member
Joined
Mar 7, 2013
Messages
1,522
Something must be wrong.

Design new report opens two windows. Data Source Configuration Wizard and Report Wizard, stepping through those allows you to create a new report.

Try restart VS.
 

Solarion

Honorary Master
Joined
Nov 14, 2012
Messages
19,174
Something must be wrong.

Design new report opens two windows. Data Source Configuration Wizard and Report Wizard, stepping through those allows you to create a new report.

Try restart VS.
I think there may be something wrong with my visual studio. Some component missing to make it work.

Seems to be a fix. A missing component which I left off during installation.

Visual studio - Extension installation “Cannot find setup engine instance.”

 
Last edited:

Solarion

Honorary Master
Joined
Nov 14, 2012
Messages
19,174
Suspect @Solarion is seriously hungover.. possibly requiring medical intervention.
I am very glad that is NOT the reason! Just the thought of a hangover makes me feel ill really :sick:

Anyway it's the highlighted bit, forget that and you will not be able to make reports eod.

 
Top