Mweb range extender

Pseudonym

Senior Member
Joined
Sep 5, 2009
Messages
717
I used the revised geniass method coupled with the EDIMAX firmware to turn this complete POS into a functional piece of hardware. I'm using it to get internet to my Explora without having to do another cable run. Many thanks to all those who posted advice and guides.
 

Kaine

Expert Member
Joined
Nov 4, 2009
Messages
1,376
sorry to revive this thread. first off, thanks for the all the info. I successfully flashed one of these stupid mweb things yesterday with the zyxel firmware. barring a few mishaps, it went very easily.

now to the matter, the extender works for all of about 7 seconds, and then disappears from the wifi scan page. how do I get it stable? I've done the googling, and dont think Im searching the correct terminology

thanks in advance
 

yatiya

Active Member
Joined
Sep 13, 2012
Messages
70
Getting rid of Mweb's rubbish

NOTE: I run Linux and have not tested any of this on Windows, but it shouldn't really matter. Anyway I don't take responsibilty for unusable (as if it wasn't already) devices after following this procedure.
To get rid of Mweb's 'firmware', we need to
  • Copy the stock fw_upgrade binary and the firmware binary to the device
  • Run the new binary
The device has a built-in tftp client which works (surprisingly) so we can use that.
  1. Connect the repeater to your pc using the ethernet port, and make sure you can access its webpage (192.168.2.2)
  2. Install a tftp server on pc
    On Linux, I used tftpd-hpa. On Windows it looks like you can use tftpd32. This seems like a decent tutorial.
  3. Download the latest firmware from Zyxel's website. Make sure it's for the correct hardware version (probably wre2205v2) and extract the zip file
  4. Either download the stock fw_upgrade from https://www.dropbox.com/s/zp21r8ijm2dpdph/fw_upgrade?dl=0 or use a program such as binwalk (Google for a tutorial) to extract the .bin file. In that case, fw_upgrade is in /sbin relative to the squash-fs file system you just extracted.
  5. Put fw_upgrade as well as the .bin file into the base directory of the tftp server
  6. Now go to 192.168.2.2/mp.asp
    You should see a basic webpage with a textbox and a button. This will allow you to enter commands as root [GASP]
  7. Enter this command:
    Code:
    ; echo "`tftp -g -l /etc/fw_upgrade -r fw_upgrade 192.168.2.100; tftp -g -l /etc/fw.bin -r [name of .bin file].bin 192.168.2.100`"
    This copies both files over to the repeater. They are being copied to /etc because the rest of the file system is read-only.
    192.168.2.100 is your pc's IP address. It should be this.
  8. Now enter
    Code:
    ; echo "`chmod +x /etc/fw_upgrade; ls -al /etc`"
    This makes it executable. In the output list you should see fw_upgrade and fw.bin
  9. Enter
    Code:
    /etc/fw_upgrade upg /etc/fw.bin
    This begins the update. The standard warnings apply: don't switch off the device etc... and wait about 5 minutes.
    Eventually the address 192.168.2.2 will stop working. The stock firmware uses 192.168.2.254 instead. Keep trying this address until it works.

That should be it. The repeater should now be ready to go with stock firmware.
If using TFTPD64 for windows, the following is how to setup the server:
Run the app as an admin
Click settings, click tftp tab. Select following options: 1) security: none 2) option negotiation off, 3) PXE, show progress translate Unix names and allow "\" ON 4) Select "Bind TFTP as ON, and select 192.168.2.100 as the binding"
Click DHCP tab. Set IP pool address as 192.168.2.3, size of pool 10. Boot file, blank.
Set Mask (opt 1) as 255.255.255.0 (leave Def router blank)

Restart the app, again as admin.

When performing the commands above, the following needs to be borne in mind:
TFTPD64 does not do multiple file writes it seems. The first command must therefore be split, as follows:
; echo "`tftp -g -l /etc/fw_upgrade -r fw_upgrade 192.168.2.100`"
; echo "`tftp -g -l /etc/fw.bin -r [name of .bin file].bin 192.168.2.100`"

For name of bin file, choose either the default name of the extracted bin, OR rename it to something simple. I used zyxel.bin, because it's just easier than typing out a string of numbers and letters.

In the last command, you actually need to use quotations, thus:
; echo "`/etc/fw_upgrade upg /etc/fw.bin`"
Also, the bin file name should be what you uploaded earlier (at least, that is what worked for me - using fw.bin in that command did not work.

Lastly, the repeater's stock IP is 192.168.1.2, NOT 192.168.2.254 (you can check this by clicking the network properties in Windows)

Hope this helps someone. Took me a couple hours to figure it all out, not being familiar with TFTP servers and all that.
 

nemo415

Well-Known Member
Joined
May 22, 2011
Messages
370
@corpsegrinder62 I managed to do it.

instead of using /etc/fw_upgrade upg /etc/fw.bin i used this

; echo "`/etc/fw_upgrade upg /etc/fw.bin`"

I than waited 4 minuted tried to log back on and and the IP address changed, I than changed it back to DHCP, logged onto my Zyxel(192.168.1.2)and guess what I was on stock Standard Firmware.

Thanks Geniass
You people rock!

Managed to flash mine using the above
 
Top