OPEN NAT TYPE mikrotik

Aubrey Smith

Active Member
Joined
Jan 1, 2018
Messages
57
Hey Guy's I am having so much trouble with getting my NAT TYPE from strict to open or atleast moderate..
I am using the mikrotik app to do the configuration..
I have already activated upnp and enabled it towards my xbox one consel..

So please go gentle on me I am a new be and literally know the basics but that is it...


Thanks alot!!!
 

krieg

Expert Member
Joined
Mar 31, 2010
Messages
1,136
Is the Mikrotik App you're using named Winbox or something else?
 

krieg

Expert Member
Joined
Mar 31, 2010
Messages
1,136
Okay, it seems that your WAN port (port1) has to be internet facing for it to work. So do you only use the Mikrotik or something else as well in-between? If yes it seems you need to forward from that device back to the Mikrotik.

reddit
 

Aubrey Smith

Active Member
Joined
Jan 1, 2018
Messages
57
Okay, it seems that your WAN port (port1) has to be internet facing for it to work. So do you only use the Mikrotik or something else as well in-between? If yes it seems you need to forward from that device back to the Mikrotik.

reddit
Okay, I only use mikrotik nothing in between only mikrotik.
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
40,812
Post a screenshot of your uPNP setup.

Also of your interfaces.
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
40,812
Okay the app doesn't seem to say which interface the uPNP is attached to, unlike Winbox. You want it on the external interface (PPPoE) as well as the internal interfaces and marked as such.

Maybe the App is the problem, not giving you enough options.

Also, it's a little weird your pppoe-out1 interface is considered internal instead of external, but I don't remember this stuff exactly.

*****

Oh I see now your interfaces screenshot is of UPnP, I actually meant your global interfaces screen to see what your config looks like. If you change your PPPoE interface there to be EXTERNAL I think that should solve your issue.

Also assuming Ethernet1 is a bridged interface with other ports, or you aren't using other ports at all. Otherwise you want to add the bridged port there as your internal.
 
Last edited:

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
40,812
If using the PPPoE interface directly as the external doesn't work, try using the Ethernet the PPPoE is attached to.

But I'm pretty sure the PPPoE should do the job.
 

krieg

Expert Member
Joined
Mar 31, 2010
Messages
1,136
Im still struggling with it did as you said no luck... maybe something else ?

upnp tutorial

It seems you need to add a firewall rule also for the NAT to work. If you google mikrotik nat type open xbox one you'll see a lot of posts with firewall rules, you need to adapt those and try it on your network. Use Winbox it's easier.
 
Top