Port 80 blocked

Grep

Senior Member
Joined
Nov 21, 2006
Messages
905
Hi guys

I am turning here because I have tried everywhere else and no go. I have a client with a dynalias.com alias tied to a netgear DG834 which works 100%. I have portforwarded ports like 80/81/22/3389 etc etc and EVERYTHING works except port 80 which died last week for some reason.

Port 80 is port forwarded to an exchange server and it is definitely listening on 80, I also enabled 81 and the client is able to use http://client.dnsalias.com:81/exchange but just not 80. If I telnet locally on the exchange server to port 80 its fine. I have recreated the firewall rules, I have changed ADSL accounts and even changed ADSL routers and just no go.

I then installed IIS onto another server, pointed 80 to that box and still no go. I have run tcptraceroute and this is what I get:

su-2.05b# tcptraceroute **client**.dnsalias.com 80
Selected device xl0, address 196.25.42.234, port 1839 for outgoing packets
Tracing the path to kanteysvpn.dnsalias.com (165.145.240.249) on TCP port 80, 30 hops max
1 196.25.42.233 (196.25.42.233) 9.280 ms 9.699 ms 9.724 ms
2 196.25.165.53 (196.25.165.53) 9.905 ms 8.549 ms 9.729 ms
3 wfor-ip-esr-2-pos-1-0-0.telkom-ipnet.co.za (196.43.24.214) 9.875 ms 9.573 ms 9.710 ms
4 * wfor-ip-esr-2-pos-1-0-0.telkom-ipnet.co.za (196.43.24.214) 23.467 ms !A *


su-2.05b# tcptraceroute **client**.dnsalias.com 81
Selected device xl0, address 196.25.42.234, port 4206 for outgoing packets
Tracing the path to kanteysvpn.dnsalias.com (165.145.240.249) on TCP port 81, 30 hops max
1 196.25.42.233 (196.25.42.233) 6.900 ms 9.122 ms 9.734 ms
2 196.25.165.53 (196.25.165.53) 9.866 ms 7.827 ms 6.995 ms
3 wfor-ip-esr-2-pos-1-0-0.telkom-ipnet.co.za (196.43.24.214) 8.079 ms 14.157 ms 7.565 ms
4 * * *
5 dsl-145-240-249.telkomadsl.co.za (165.145.240.249) [open] 14.492 ms * 33.484 ms

Is it at all possible that telkom blocks ports? I am just stumped.
 

xrapidx

Honorary Master
Joined
Feb 16, 2007
Messages
37,410
Unlikely that they'd block port 80.....

What type of message do you get when trying to connect from the external connection?
 

xrapidx

Honorary Master
Joined
Feb 16, 2007
Messages
37,410
And if you try connect directly to the exteral IP address and not using Dynamic DNS?
 

xrapidx

Honorary Master
Joined
Feb 16, 2007
Messages
37,410
Hmm... not sure then considering you've changed routers and accounts..... could be something internal?
 

Grep

Senior Member
Joined
Nov 21, 2006
Messages
905
Problem resolved *important for Mweb users*

Okay guise, I think this is probably an issue where many other people could face the same problem in the future. After many fights and escalations withe "third line support" I spoke to my buddy at Mweb who knows people who had a look at this.

Turns out that its a mweb "feature" that they block incoming port 80 so that subscribers cant have their ADSL router hacked. To overcome this you need to do the following:

1. Log into: https://myaccount.mweb.co.za/
2. Log in with your adsl username/password but only the username without the rest @dsl512 whatever whatever.
3. Click on My Adsl
4. Click on ADSL protected access
5. Disable this "feature"

port unblocked

Hope this helps in the future. Not a single person on their helpdesk knew about this.
 
Top