Router issues and Android TV wifi issue

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
Lounge Setup:
D-link DSL-G2562DG , dsl port isn't working but I need the Wireless AC to stream 4K as the lan port buffers when trying to stream from plex server even with MrMC.
Not using any WAN
Connected by cat6 lead to LAN port on the Zyxel router, LAN port to LAN port.
Connected to Plex server's Gigabit Ethernet connection.
Enable DHCP relay - pointing to Zyxel routers ip
LAN port maps all checked.

On both 2 and 5ghz my iPhones and laptops can connect to the internet and receive ip via dhcp.
On the Ematic Android TV it detects the D-links WiFi, try and connect it cant receive an IP, even static IP with correct gateway doesn't work (no internet)
On the Ematic Android TV if I connect the LAN port it receives dhcp IP and works.

Garage:
Zyxel VMG1312-B10A connected to Vdsl.
Connected via Cat6 lead to the D-link.

Any ideas why the Ematic Android TV box doesn't receive an IP on the D-link WiFi and every other device has no issues?
 

Sharan

Well-Known Member
Joined
Oct 16, 2008
Messages
180
On my Android TV box, I had to physically unplug the ethernet cable for the wifi to connect
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
Lan cable already uplugged.

Think what I'll do is complete reset on both router, start from scratch.

Sigh
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
37,383
If you Ethernet cable is causing buffering on a gigabit link it’s already a sign that something else is very very wrong.

You don’t even need 100MB or 802.11ac to stream 4K.

What is MrMC?
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213

only Blu-ray 4K stuff that buffers on lan , on AC it streams fine from plex server , i3,4gb ram
 
Last edited:

cpu.

Expert Member
Joined
Jun 23, 2010
Messages
4,772
Did you try static IP settings on the Ematic?
Edit: nevermind, I didn't read properly. You did.
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
Got it working after resetting both routers to defaults, think it was Droid tv wifi MAC address that Zyxel router had issue with.

now on 5ghz and blu rays streaming just fine.
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
37,383

only Blu-ray 4K stuff that buffers on lan , on AC it streams fine from plex server , i3,4gb ram
Then you problem is likely not network at all but the fact that it’s trying to transcode it at the source which isn’t strong enough for the job.

Your Plex stuff should always Direct Play whenever possible.
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
37,383
Got it working after resetting both routers to defaults, think it was Droid tv wifi MAC address that Zyxel router had issue with.

now on 5ghz and blu rays streaming just fine.
Very strange.

It should stream equally fine even on 802.11n 2.4ghz.
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
Yeah, it's mainly the Blu Ray copies that struggle, talking file sizes like Blue Planet II alone each episode is 16GB, Movies file sizes are around 25GB to 65GB.
 

yogidabear

Well-Known Member
Joined
Jan 20, 2011
Messages
104
Did I read this right, you unplug the Gigabit Ethernet as your media player streams better on wifi?

Like the one chap said you can direct play with Plex but why use MrMC for plex anyway when you can just add the source and it would never transcode?

Sorry I know I am not offering any help just dont understand your scenario as I have MrMC on an apple tv connected via Ethernet and it plays blueray no worries with a samba share. Maybe you didnt share the content and think you have to use plex, but you confused me with your setup.
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
As far as I know the Ematic doesn't have a gigabit nic?
I prefer Plex to MrMC but often Plex gives me the buffering circle, annoying
 

Hemps

Honorary Master
Joined
Jan 19, 2009
Messages
10,213
Using wifi sweetspot app
On wifi in garage I get 90Mbps @ 2ghz Zyxel (only wireless N)
On wifi in the lounge I get 360Mbps @ 5ghz D-link
 

yogidabear

Well-Known Member
Joined
Jan 20, 2011
Messages
104
11ac but 100meg Ethernet seems like a mistake but suppose a vast majority are connected wireless so maybe even having Ethernet is a bonus. Understand you now.

Only thing we use plex for in this house is on the ipads. The media players play the file directly from the network share and we can skip forward with no buffering even on very large file sizes. This worked even when there was 100meg Ethernet in the one bedroom over power line which is not even a full 100meg. So if you are using the plex add on for MrMC not a network share that could be affecting the performance. However it sounds like you sorted anyway so enjoy!
 
Top