• You are not registered on MyBroadband, which means you miss out on great benefits. To join our community is very easy, and completely free. Register now.
  • New Two-Day Giveaway - Enter Here

Setup problems Huawei E1752 (from 2Gb deal) ubuntu 10.04

parkks

New Member
Joined
Mar 9, 2011
Messages
1
#1
I've just spent a couple of hours trying to get a cell c dongle to work on my laptop. Hopefully this will save someone else some time.

It was for the 2Gb deal. The model number on the dongle was E1752 and the USB ID (from when I ran lsusb in Terminal) was 12d1:1446

The problem seems to be the computer not recognising the USB device in the right way. I solved the problem by installing usb-modeswitch and then changing a value in the configuration file.

For more info on usb-modeswitch visit http://www.draisberghof.de/usb_modeswitch/

For info on how to install usb-modeswitch visit http://ubuntuforums.org/showthread.php?p=10540909#post10540909

For info on changing the value (it's adding something to "TargetProductValues" in the usb-modeswitch.config file) check out
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=585#top
and http://www.draisberghof.de/usb_mode...hp?t=561&sid=b1fc4ab2946571296dc2042a4630ef21

I'm not 100% sure why it now works, but it does seem to
 

CornelisW

New Member
Joined
Oct 6, 2013
Messages
2
#2
Thank you for this post, I'm completely new with Ubuntu, I'm having the same problem that you had, I'm going to try your advice, hopefully it will work!
 
Top