Western Digital My Passport Essential Help!

Silver Surfer

Member
Joined
Dec 19, 2010
Messages
23
Good Afternon My Fine My Broadband Co-Browsers :)

I purchased a 500GB Western Digital My Passport Essential Hard Drive during the December break. It was all swell and working up until the point were it froze and I had to pull it out. Ever since then when I plug it into mine or any other computer, It makes a sound to notify that it was plugged in, installs drivers and doesn't come up for a while then a Local Disk pops up in My Computer. When I try to open Local Disk it says that I need to Format The Drive before I can use it, so trying to save the remains of my hard drive when I try and format it, it freezes and will only allow to format once the hard drive is out -- which is obviously impossible.

Can anyone please advise me on what to do?
The Data on my hard drive is valuable, I would return it back to Digicape where I bought it from but I'm not sure if they would accept it without a reciept.

Thank You
Regards Silver Surfer
 

Silver Surfer

Member
Joined
Dec 19, 2010
Messages
23
@ South Bit -- Without the hard drive my Disk Management Shows All My Drives and their statuses but when the hard drive is inserted the Disk Management freezes and does not show any drives.
@ Mantis -- Sorry for my poor explanation. What I meant was that I am told the drive needs to be formatted but when I decided to format it, it freezes and then once I pull it out without Safely Removing the the options for the format pop up and once I click Format..it tells me the drive it not in the computer.

I think all problems are brought up by the fact that the drive is in the computer but then ejects itself. I have also tried this drive on my mac and the drive is shown only in Disk Utility and when I try and format (looks like the only solution) it ejects itself.
 

SouthBit

Dealer
Joined
Jan 6, 2011
Messages
1,164
and no disrespect South Bit but that article looked way too confusing to even start reading :)
No problem, was just supplying some extra info.

A problem with these drives is that they do not have a SATA controller on the PCB, so if you remove the drive from it's enclosure you won't be able to connect it up via a normal SATA port as it doesn't have one. There is a way around this, but beyond the scope of this conversation. So only basic recovery can be done, as we can only work through USB, which is very limiting for this purpose.

There's a great possibilty of recovering the data from this drive, but it will most likely include opening it up (there goes your warranty) and progressing from there. You have to decide what is more important, your data or your warranty.
 

n3cr0

Active Member
Joined
Apr 24, 2011
Messages
57
I had a similar issue with my WD 1.5Tb My Book, issue only occurred when using it with Windows. Backed up the data using a Linux box and then formatted and CHKDSK'd it. Has been running fine for a few months now.

Typed with my iThumbs
 
Top