apple macbook pro mtu

murray654

Senior Member
Joined
Aug 15, 2005
Messages
627
hi,

I am a windows user, but my cousins husband uses a macbook pro.

The internet was a disaster on this macbook pro and after trying a lot of things I found the MTU was wrong. After changing the MTU to 1400 everything works fine.

From the Apple menu, choose System Preferences.
Click Network.
From the Show pop-up menu, choose AirPort.
Click the Ethernet tab.
From the Configure pop-up menu, choose Manually.
From the MTU pop-up menu, choose Custom.
In the field to the right of Custom, enter your new setting.

It fixed the macbook pro's slow slow internet, hopefully for good. Hope this helps someone...
 

Jack Shizz

Well-Known Member
Joined
Dec 29, 2011
Messages
120
MTU would also depend on router config. What was his MTU before the change? Looking at mine its 1500 and I have not a single problem with internet. (Except google chrome, but thats just googles fault IMO)
 

Jack Shizz

Well-Known Member
Joined
Dec 29, 2011
Messages
120
UPDATE: Best MTU Settings (the default in most network devices) Is 1492. Rather check your Routers MTU before changing yours, as a mismatched MTU can cause a lot of problems. (But I guess thats what the whole thread is about anyway).
 

murray654

Senior Member
Joined
Aug 15, 2005
Messages
627
Beyond the existing broadband infrastructure lies us. We don't qualify for ADSL, because we don't live in an area with the right kind of exchange/backhaul/communications infrastructure. So some wisps set up some towers and use wifi signals to sell us internet "broadband". That is all good and well.

MTU of 1500 should be ok, but unfortunately due to the limitations of wifi, and the point to point protocol used by the wisps, there is a lower mtu. The point to point protocol adds some overhead to each packet.

So that's where the macbook pro was falling over.

Ideally you should not fiddle with this. On my windows computer mtu is 1500. On my router mtu is 1480 - But my computer can communicate with the outside world. Any packet larger than 1480 is fragmented. This seems not to bother windows, but the macbook does not like this one bit. So the fix is to lower MTU on the macbook.

The apple website said to try changing it to 1400 from 1500. That worked on my cousin's husband's macbook pro.

I only posted it here as a solution for people with a similar problem.

Don't drink cough mixture if you don't have a cough.
 
Top