Firefox 9.0.1 on property24.com - only Linux version doesn't work?

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Hi all,

Can somebody please test the www.property24.com website in Linux with the latest Firefox 9.0.1?

For some reason, it works in other browsers including Windows Firefox 9.0.1 but when visiting on Linux version, it asks to download a page rather than opening.

if its not just my PC, then either its something on the property24 website or in Linux version.

Many Thanks!
Nick
 

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Working fine here on Fedora 16.

Thanks MickZA, and can you please check which versino of Firefox you have? (Help->About Firefox)

Yup, used to work before and cleaned the cookies but no difference :(
 

qinglung

Expert Member
Joined
Mar 3, 2007
Messages
1,509
Firefox 9.0.1 on Xubuntu 11.10. Same thing here, it wants to download "Mobile.aspx".
 

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Thank you everyone!

Well, looks like we got 3 that say is working fine but 2 (including me) that isn't?

Common between 2 is that we use Ubuntu-based distros but the other 3 is Fedora and Debian.

Perhaps something wrong with Ubuntu builds?

I also checked extensions and nothing I can see there that would cause this.

Going to talk to property24 again and also Ubuntu.

Thanks again everyone
 

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Hi again everyone,

Have spoken to more people and they say it could be the user agent detection on property24 side. Looks like they dont recognize Ubuntus one and it tries to kick us to the mobile site.

May I therefore please ask that the Fedora and Debian guys above visit this link and paste their user agent string here so I can report to property24? Thanks :)

http://www.whatsmyuseragent.com/

Mine: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
 

MickZA

Executive Member
Joined
Jan 19, 2007
Messages
7,575
Here you go

Mozilla/5.0
X11
Linux
x86_64
rv
9.0.1
Gecko/20100101
Firefox/9.0.1

Edit: hmmm - no distro ID in my string
 
Last edited:

Property24.com

New Member
Joined
Jan 13, 2012
Messages
1
Hi Nic777,

Thanks for taking the time to work through this problem. I will take a look at what we are doing and ensure that we do not detect FireFox on Ubuntu as a mobile device if that is the case. It should give you a choice of which site you would like to view when it picks up a mobile device. Are you getting the choice or is it redirecting you straight away to mobile site? I will confirm once we have looked at it on our side. If this a problem on our side I will ensure it makes it to our next release and if it isn't I will take it up with Ubuntu. Thanks once again and good luck with your property search! Property24.com
 

fskmh

Expert Member
Joined
Feb 23, 2007
Messages
1,184
Page loads fine for me on Slackware64 13.1 and 13.37 here:

Mozilla/5.0
X11
Linux
x86_64
rv
9.0.1
Gecko/20100101
Firefox/9.0.1

P.S. Open a new tab in firefox, type about:config and try toggling "general.useragent.compatMode.firefox". Maybe that will help with the agent identification.
 

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Thank you everyone, the only diff I really see is that Ubuntu adds "Ubuntu" before the X11 line.

And thanks for property24.com for coming on board as well. What happens is that when you visit the page, it quickly asks if you want to save the file "Mobile.aspx" and doesn't show the website at all. Here is screenshot after I typed www.property24.com and hit enter (I was on news24): http://imgur.com/8HpjD

So looks like its not recognizing the user agent and then sending me straight to the mobile page, although I don't get why it tries to downloads the page and not just open it?

Well, hope the info above is useful, will be glad to see it working again :)
 

MyWorld

Executive Member
Joined
Mar 24, 2004
Messages
5,001
Works fine for me as well.

Arch Linux:

Mozilla/5.0
X11
Linux
x86_64
rv
9.0.1
Gecko/20100101
Firefox/9.0.1
 

BigAl-sa

Executive Member
Joined
Dec 26, 2006
Messages
6,652
Works fine on my Debian Wheezy-64 machine as well:

Mozilla/5.0
X11
Linux
x86_64
rv
9.0.1
Gecko/20100101
Firefox/9.0.1
 

ocky

Well-Known Member
Joined
Apr 6, 2007
Messages
158
Kubuntu 11.10 64 bit
Firefox 9.01 (Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1) = Mobile.aspx
Opera 11.60 (Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.10.229 Version/11.60) = No problems
 

ocky

Well-Known Member
Joined
Apr 6, 2007
Messages
158
Many thanks to vasa1 for elevating this issue Here.
In the meantime let's just change the user agent string as outlined by vasa1.

See also This thread initiated by vasa1 back in November 2011.
 

nic777

Expert Member
Joined
Mar 29, 2005
Messages
2,060
Shoo, thanks guys, didn't know there was previous discussion as well.

I think its a very valid question on why Ubuntu put their name before X11 compared to other distros.

Some guy has pointed out that it could be issue with website as other mobile phone detectors pick up Ubuntu Firefox correctly so this is a tricky one - should Ubuntu change or the website detecting browsers change? :(

Meanwhile, I am going to change my user agent string and see how it goes.
 
Last edited:
Top