iBurst FAIL

LithIX

Well-Known Member
Joined
May 24, 2009
Messages
233
Shaun,
and anybody else interested in getting iBurst.

I dunno anymore, seriously!
Let me tell you a secret: upgrading/overhauling your systems aint gonna do nothing when you customer services is non-existant.

Anyway,

I've been using iBurst for the best part of 2.5 years:
The other day while browsing the iBurst site ( for whatever reason :erm: ) I noticed that my package does not exist anymore, and that there's a "new" package for the same monthly fee providing a whopping 1.5gb more cap. WTF. Time to give them a call and migrate I thought.

The lady at customer services told me to login on the website, and migrate from there, which I did. That was July 17th. Got a confirmation email 'n all...

Come Aug 1st, I notice I'm STILL on the legacy package, gave them a few days to see if the mistake will sort itself out (which it didn't) and contacted support through email to have it sorted. After 2 weeks of communication, and forwarding of confirmation mails, I eventualy get a the following
Dear Mr _______

Reference Number: ______

Thank you for your e-mail.

Please accept our sincere apologies for the inconvenience caused to you.

The system didn’t read your application hence we don’t have it in our files.

We are going to allocate 1.5 gigs into your account immediately for this month (August) to make up the 5gigs you would have received on the Xtreme package as of the 1st of the month, the subscription fees are the same.

As of September, the full 5gigs will be allocated as normal.

Thank you for your understanding.

For further assistance please do not hesitate to contact our Customer Retentions Department on (011) 676-6550 or via e-mail at info@iburstgroup.co.za.

Regards,

bla, bla, bla

Great :)

My bandwidth usage reports even showed the additionally allocated cap.
That as until yesterday...
Got my 1st "Usage Report" in more than a week and noticed my additional cap was removed and I only have 100mb odd left. /sigh

Sent support a mail yesterday, which is still unanswered...
Decided this morning to phone them, and after explaing the above situation to 4 different agents, got to a young man called ______ which assured me this will be sorted before 11AM. He just need authorisation from his manager, after which he'll contact me with confirmation.
14h30, and still no word.
Phoned AGAIN, and had to explain my situation to another agent.
He told me ______ was busy on another call, and that I'll be contacted in a few minutes.

Its now 19h00 and I'm still waiting. WTF?
To makes things worse, SEEMS like I've been throttled. :mad: (As slow as a crawl)

The point of this whole rant is, well, that its useless contacting support to sort out issues. WTF do you have a call center for?
Even after contacting and sending "evidence" to half your callcenter I'm still left high and dry.
I have high blood preassure 'n all, and if I have to explain this issue to just one more bloke I'm going to get a heart attack or fcking stroke.

I know the ultimate fail is on my side for still being with iBurst. But come-on:
throw me a bone there. I've been a loyal customer for quite a while.

Seriously guys, where do I have to go to get this sorted?
 
Last edited:

subculture

Banned
Joined
Mar 17, 2009
Messages
328
all i want is extra bandwidth... i even phoned... but their system was broken.

i've been with iburst since beta days... i never phone the call centre. I have learned rather come here or phone speak to shaun.

when they clone people they must clone shaun.

When were you throttled btw... cuz it looks like their system is broken which in theory usually means we can rape and pillage bandiwidth without them knowing. (that is if you are not throttled)
 

LithIX

Well-Known Member
Joined
May 24, 2009
Messages
233
When were you throttled btw...

I can't say for sure that I am throttled, but its (more than) unusualy slow. I'm struggling to open this site :confused: So most likely the nerfbat has swung

Been like this since, say 18h00
 

subculture

Banned
Joined
Mar 17, 2009
Messages
328
I can't say for sure that I am throttled, but its (more than) unusualy slow. I'm struggling to open this site :confused: So most likely the nerfbat has swung

Been like this since, say 18h00

well this side its full speed but there was a moment when it did come across as being all throttle like.

Are you sure you are not having an iburst moment. sometimes they degrade for a day or 3 in an area.
 

LithIX

Well-Known Member
Joined
May 24, 2009
Messages
233
I suppose it is possible that I'm having an iBurst "moment", but its slower at the moment than I've seen it in years. Even in peak times its faster.
Anyway...
 

iBurst

iBurst representative
Company Rep
Joined
Jan 12, 2005
Messages
1,440
Hi LithIX

I will make contact in the morning as per your request.


Thanks
 

Gekco

Expert Member
Joined
Jun 3, 2008
Messages
1,522
Is this still going on??

Shaun,
and anybody else interested in getting iBurst.

I dunno anymore, seriously!
Let me tell you a secret: upgrading/overhauling your systems aint gonna do nothing when you customer services is non-existant.

Anyway,

I've been using iBurst for the best part of 2.5 years:
The other day while browsing the iBurst site ( for whatever reason :erm: ) I noticed that my package does not exist anymore, and that there's a "new" package for the same monthly free providing a whopping 1.5gb more cap. WTF. Time to give them a call and migrate I thought.

The lady at customer services told me to login on the website, and migrate from there, which I did. That was July 17th. Got a confirmation email 'n all...

Come Aug 1st, I notice I'm STILL on the legacy package, gave them a few days to see if the mistake will sort itself out (which it didn't) and contacted support through email to have it sorted. After 2 weeks of communication, and forwarding of confirmation mails, I eventualy get a the following

WTF???
Do those 'old' packages STILL exist???
This after the matter was dragged through the mud on these forums and in online media as well as 702 talk radio... ???
(I can post links for those really interested... Although there is a new team at the helm now and I don't really want to dredge up that whole issue again... I thought it would have been sorted a long time ago already)

Note to the iBurst team:
I suggest doing an audit to find all users are still on old packages and Migrate them immediately.
 

LithIX

Well-Known Member
Joined
May 24, 2009
Messages
233
Unsurprisingly

Hi LithIX

All sorted?

Let us know.

No

Logged in from home earlier to find I'm STILL on the Pro Classic package. /sigh

Now: I'm unable to login to iBurst from work as well.

Maybe its unrelated:
But is there problems connecting to certain sites?
I could'n open news24 earlier, and my wife can't log onto her Univercity of Pretoria "profile". /epicsigh

BTW,
Thanx Shaun for the "FreeBee" complementary 1gb to keep me going for the rest of the month. Appreciated.
 
Last edited:
Top