iPhone 3GS Tethering issue - Vodacom

FaNIX

Expert Member
Joined
Jan 15, 2006
Messages
2,232
Seeing as I dont have ADSL anymore, I bought some gconnect 3g data to try and tether... But this is what happened...

I connected the iPhone to the USB, closed iTunes, enabled Tethering (General->Network->Tethering) and then tried to access the internet on my notebook, but it didnt work. When I went back to NetWork->Tethering, the option was GONE!!! I've read that a lot of people have this issue, seems that it's related to fw 3.1.2 and the mobile operator.. Funny thing is, my partner has the exact same phone, he is also on vodacom and it works flawlessly on his iPhone...

Would appreciate some help!
Thanks
 

Gambit

Expert Member
Joined
Apr 26, 2005
Messages
1,540
You don't need to hack your phone to get tethering support for vodacom. This facility is supposed to be enabled for all iphones on vodacom by default after 3.1.1 software update. MTN and cellc require hacks.

I have successfully used this method that I found somewhere on the net after searching to get tethering option back for a couple of friends iPhones:

Go to Settings->general->Reset->Network Settings

After reseting network settings switch phone off and back on.

This should reset your apn to iphone.vodacom.za so make sure this apn is enabled in the services section of the vodacom4me (enabling this apn sometimes takes a little while). Changing your apn to "internet" may disable tethering.
 
Last edited:

FaNIX

Expert Member
Joined
Jan 15, 2006
Messages
2,232
You don't need to hack your phone to get tethering support for vodacom. This facility is supposed to be enabled for all iphones on vodacom by default after 3.1.1 software update. MTN and cellc require hacks.

I have successfully used this method that I found somewhere on the net after searching to get tethering option back for a couple of friends iPhones:

Go to Settings->general->Reset->Network Settings

After reseting network settings switch phone off and back on.

This should reset your apn to iphone.vodacom.za so make sure this apn is enabled in the services section of the vodacom4me (enabling this apn sometimes takes a little while). Changing your apn to "internet" may disable tethering.

Awesome!!! Tethering option is back! But I dont have a cable to test it here at work, will need to test it at home tonight!

Thanks a mil!
 

GrootBaas

Expert Member
Joined
May 25, 2006
Messages
1,018
Exactly where on vodacom4me do I change the APN? Can't find it for some reason. Still using internet APN.
 

FaNIX

Expert Member
Joined
Jan 15, 2006
Messages
2,232
Okay so i figured it out, tethering option works on the vodacom apn, vut as soon as i change it to gconnects apn it dissapears... Guess it doesnt work with gconnect :(
 

WiT8litZ

Senior Member
Joined
Nov 26, 2005
Messages
956
Once logged in to www.vodacom4me.co.za site on the menu bar near the top:
My Account -> Services

On the "modify services" tab make sure iPhone APN is ticked.

This only works if your contract is directly with Vodacom I think. Mine does not have it (via NashuaMobile), and a friend does have it (Vodacom Provider). We have both have the same Topup contract.
 

MikeCTZA

Expert Member
Joined
Jan 18, 2008
Messages
2,487
Just a thought (may be obvious but worth checking) - is your phone model correct (ie the iPhone 3G/GS) when you sign into the v4me site. I'm assuming it is, but maybe the option to allow that service is based on what phone the site thinks you have. I may be totally wrong but worth a quick look.
 

Gambit

Expert Member
Joined
Apr 26, 2005
Messages
1,540
This only works if your contract is directly with Vodacom I think. Mine does not have it (via NashuaMobile), and a friend does have it (Vodacom Provider). We have both have the same Topup contract.

I think you are correct. I don't think you can modify your services via the vodacom4me site if you with other service providers. I know people with nashua mobile and they also can't access this. I think you actually need to call your service provider and ask for the services to be enabled.
 
Top