Network Issue

Nadir

Well-Known Member
Joined
Mar 9, 2013
Messages
499
#1
As of yesterday morning around 7:00 my signal to the MTN network has been going crazy. I cannot connect to the 4G network at all, I'm stuck on Edge or 3G, and every few min I will lose signal such that there is no internet connectivity and goes into "emergency calls only mode". Now, 24 hours later, it's still doing the same thing.

It's similar to when I upgraded my contract and few a few hours after that it would do the same thing until everything was activated and I restarted my phone then everything went back to normal

Yesterday I called MTN probably around 6 times. 4 of the agents "reset my line". One even said I just try my phone settings to reconnect manually to the MTN network after leaving my phone off for 5 min.

Another agent told me it's probably my phone. I put my SIM into my modem and that's also stuck on 3G signal only. While the other people at work who are on MTN are getting full signal.

The last agent told me to call the coverage dept to see if there is any faults in the area. Spoiler alert, there were no faults on the tower I was connecting to. Another 15 min wasted on that.

I even went as far as buying another SIM to test in my phone and modem, and it's connecting to 4G with full signal, so I'm guessing it's a technical fault affecting my SIM only.

At the same time yesterday morning my dual call SIM also stopped working and one of the agents told me that it was deactivated around that time. I didn't ask them to deactivate it and he said it might be a system technical fault. I don't see how deactivating a secondary SIM will affect my primary SIM.

So anyone had a similar experience. How does one go about trying to resolve it? The agents that try to assist all do the same thing with the same failed result. There must be another number I can contact to get this sorted.
 
Joined
Jul 25, 2007
Messages
4,639
#2
I can't connect to 4G what so ever as well, even manually forcing to 4G, I get emergency calls only, tried 4 different sims same result, 3 of them contract.

There is a broader network issue, since the cellc roaming, things have gone to shyte.
 

Nadir

Well-Known Member
Joined
Mar 9, 2013
Messages
499
#4
I can't connect to 4G what so ever as well, even manually forcing to 4G, I get emergency calls only, tried 4 different sims same result, 3 of them contract.

There is a broader network issue, since the cellc roaming, things have gone to shyte.
I thought I was the only one. At least now I know it's a broader issue.

I called the network coverage dept (083 900 1212) and they told me there are no faults on the network.

The prepaid SIM I bought is still working perfectly with full 4G signal.

I called the call centre again about 2 hours ago and the agent escalated it to the networks dept and said 2 to 24 hours. So now it's a waiting game for me now.
 

Nadir

Well-Known Member
Joined
Mar 9, 2013
Messages
499
#5
I can't connect to 4G what so ever as well, even manually forcing to 4G, I get emergency calls only, tried 4 different sims same result, 3 of them contract.

There is a broader network issue, since the cellc roaming, things have gone to shyte.
What have you tried to sort out your SIMs?
After all the calls to 135. Some suggested I do a SIM swop. I'm going to an MTN later to get it done
 
Top