Opel Corsa Lite Sport Power Issues

soutie15

New Member
Joined
Mar 8, 2017
Messages
1
Good Evening

I had to replace the battery on my 2007 Opel Corsa lite sport early last week and since the installation the car has developed serious power issues. The car was serviced in October 2016 and was running perfectly up until the new battery was installed. The HT leads and coil pack all test in a good range but acceleration is a struggle, especially if I have to start on an incline. The revs drop to below 500 if my foot is not on the accelerator and drop almost to zero if I bring the car to a stop. At this point, the car shudders before the revs return to between 500 and 1000. I have unplugged the throttle sensor at times which alleviates the low revs but the power is still very low.

Any help on what may be the cause and why it only started after replacing the battery will be greatly appreciated.

Thanks.
 

SuperMario

Well-Known Member
Joined
Mar 11, 2013
Messages
250
I have a corsa lite plus 2004 model. I had exactly the same issue, but the car fixed itself after a few times of driving it. Think it has something to to with the ecu being a little messed up after a change of battery.
 

Necropolis

Executive Member
Joined
Feb 26, 2007
Messages
8,401
I had a Corsa lite Sport with the same issues - my progressed to the point where it would actually cut out and struggle to start again.

I eventually traded the car in because no one could figure out wtf was wrong with the thing.
 

TheChamp

Honorary Master
Joined
Feb 26, 2011
Messages
36,816
Good Evening

I had to replace the battery on my 2007 Opel Corsa lite sport early last week and since the installation the car has developed serious power issues. The car was serviced in October 2016 and was running perfectly up until the new battery was installed. The HT leads and coil pack all test in a good range but acceleration is a struggle, especially if I have to start on an incline. The revs drop to below 500 if my foot is not on the accelerator and drop almost to zero if I bring the car to a stop. At this point, the car shudders before the revs return to between 500 and 1000. I have unplugged the throttle sensor at times which alleviates the low revs but the power is still very low. Any help on what may be the cause and why it only started after replacing the battery will be greatly appreciated.

Thanks.

So you drove that car with the sensor unplugged?

Sounds to me like a failing coil pack, mine did that intermittently until the coil failed completely and the car couldn't start. Also check and clean the ICV as well as the throttle body on the flap thing.
 

CORSA1.6

New Member
Joined
Dec 3, 2017
Messages
2
GOOD DAY EVERYONE. I HAVE A CORSA B 1.6I... MY CAR WAS WORKING PERFECT AND FRIDAY I TOOK MY BATTERY OUT N PUT IT BACK THE SAME AFTERNOON. THE NEXT DAY I TRIED STARTING MY CAR AND IT REFUSE TO START SO I KICKED STARTED THE CAR. IT BACKFIRED AND STARTED BT WOULD NOT REV UP PAY 2000RPM.. I SWITCHED IT OFF AND STARTED AGAIN BUT WOULD NOT CHANGE... I HAVE CHANGED THE PLUGS THINKING IT WAS OLD. BUT STILL THE SAME. I HAVE CHECKED FUEL AIR N SPARK.. ALL SEEMS TO BE DOING ITS REQUIRED DUTIES. MY MECHANIC HAS FAILED TO SORT MY CAR OUT AND IT HAS 3WEEKS. WE TESTED CRANK AIRFLOW AND MAP SENSOR AND ALL WORKING BUT LAST TRIED HE RETARDED THE TIMING BACKWARDS 3 TEETH AND IT REVS UP TO RED LINE BUT STILL LACKS A LARGE AMOUNT OF POWER. IT DRIVES NOW ATLEEST BUT WILL NOT CLIMB A SLITE STEEP HILL EVEN IN 1ST

PLEASE HELP ME OUT.
 

Hp86lvgp

New Member
Joined
Oct 25, 2020
Messages
1
I have a corsa lite plus 2004 model. I had exactly the same issue, but the car fixed itself after a few times of driving it. Think it has something to to with the ecu being a little messed up after a change of battery.
Exactly
 
Top