Purchased BIS but BBM and Emails do not work!

Jubsta

New Member
Joined
Nov 7, 2014
Messages
7
Hi there guys,

I recently moved from 8ta's R30 Social Plan to the normal R59 BIS plan and I have not been able to connect to BBM or Emails! However, Whatsapp and all other applications work. I have tried many things such as taking my battery out, going to host section in options and pressing "register now" etc etc. I have even backed up my phoned and security wiped it!

I phoned the help line twice and they have not been able to help me. Anyone else experiencing this or able to assist me?

P.S I have a Blackberry Bold 9900

Thanks!
 

Batista

Executive Member
Joined
Sep 2, 2011
Messages
7,900
PHone call center and make sure BIS is active, it sounds like its not
 

ReBeL25

Well-Known Member
Joined
Sep 13, 2006
Messages
246
Hi,

Do you have the blackberry icon next to 3G or if your on EDGE is it in caps? If not then your BIS isn't active. If you go to service status you should see a section that says Blackberry Internet Service. The connection should say Mobile Network.
 

Jubsta

New Member
Joined
Nov 7, 2014
Messages
7
The blackberry logo (flag) is next to my 3G (in capitals).

I phoned in and they say my BIS is activated. So I do not know what the issue is.

P.S Only the browser and whatsapp works. NO other applications.
 
K

kingrob

Guest
The blackberry logo (flag) is next to my 3G (in capitals).

I phoned in and they say my BIS is activated. So I do not know what the issue is.

P.S Only the browser and whatsapp works. NO other applications.
Go to a Telkom Mobile store and let them check it out for you.
 

Jubsta

New Member
Joined
Nov 7, 2014
Messages
7
Is it possible that my old 8ta sim card is having issues with telkom mobile?

Besides from that, my sim card has been giving some errors sometimes I start my phone. But surely when my card reads fine it shouldnt be an issue?
 

Jubsta

New Member
Joined
Nov 7, 2014
Messages
7
Lol ok thanks:) just trying to avoid the inevitable trip to the mall.
 
Top